LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 12-20-2004, 01:30 PM   #1
jennifer2004
LQ Newbie
 
Registered: Dec 2004
Posts: 9

Rep: Reputation: 0
network card


I just installed SuSE linux 9.1 kernel 2.6.4-52. My original setup is using
e100 driver for my network card and that is works fine. However,I am having
problem with running cisco vpn client due to an existing bug with the vpn client.
The suggested workaround of the bug is to use eepro100 instead of e100.
The instruction I got was to use the following commands:

ifdown eth0
rmmod e100
modprobe eepro100
ifup eth0

I was able to do the first 3 commands. However, when I tried to do
ifup eth0 at the last step, I got the following error message:
# ifup eth0
eth0
ERROR: No configuration found for eth0

Can anybody help ?

Thanks
 
Old 12-21-2004, 11:22 AM   #2
pturner7
Member
 
Registered: Jun 2003
Location: UK
Distribution: openSUSE 11.0
Posts: 30

Rep: Reputation: 15
Seems like no configuration for eth0.

Whats the output from :

ifconfig
 
Old 12-21-2004, 12:06 PM   #3
jennifer2004
LQ Newbie
 
Registered: Dec 2004
Posts: 9

Original Poster
Rep: Reputation: 0
the ifconfig before I do 'ifdown' is
eth0 Link encap:Ethernet HWaddr 00:11:11:49:EA:B7
inet addr:192.168.2.5 Bcast:192.168.2.255 Mask:255.255.255.0
inet6 addr: fe80::211:11ff:fe49:eab7/64 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:69620 errors:0 dropped:13 overruns:0 frame:13
TX packets:56514 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:74862130 (71.3 Mb) TX bytes:6053016 (5.7 Mb)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:11682 errors:0 dropped:0 overruns:0 frame:0
TX packets:11682 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1679128 (1.6 Mb) TX bytes:1679128 (1.6 Mb)

But after I tried to swith to using eepro100, by doing rmmod e100, modprobe eepro100
ifup eth0, ifconfig is
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:11682 errors:0 dropped:0 overruns:0 frame:0
TX packets:11682 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1679128 (1.6 Mb) TX bytes:1679128 (1.6 Mb)

I added the alias eth0 eepro100 in /etc/modprobe.conf but that does not seem to
help. Any pointers ?

Thanks
 
Old 12-21-2004, 12:56 PM   #4
mtaylor57
Member
 
Registered: Jun 2004
Location: Houston
Distribution: Suse, Redhat
Posts: 48

Rep: Reputation: 15
Have you tried it using Yast? Sounds kinda weird.
 
Old 12-21-2004, 01:11 PM   #5
jennifer2004
LQ Newbie
 
Registered: Dec 2004
Posts: 9

Original Poster
Rep: Reputation: 0
Which step should I use Yast, sorry I am still new to linux.
When I click network card:
I only have one that is under 'already configured device'.
Should I configure another one ?
 
Old 12-21-2004, 02:35 PM   #6
mtaylor57
Member
 
Registered: Jun 2004
Location: Houston
Distribution: Suse, Redhat
Posts: 48

Rep: Reputation: 15
You can edit your card even if it's configured already. From network card, you can choose your driver settings...I'm not on my SuSE box right now, so I can't tell you step-by-step, but it should be easy to figure out from there.
 
Old 12-21-2004, 02:40 PM   #7
pturner7
Member
 
Registered: Jun 2003
Location: UK
Distribution: openSUSE 11.0
Posts: 30

Rep: Reputation: 15
I would edit the one that is already configured. Click on 'Change ...' then 'Edit'.
Click on 'Advanced' then 'Hardware details'

What do you see under Module Name? If this is e100 then change to eepro100 and click OK to accept any changes.

See if this helps.
 
Old 12-21-2004, 03:32 PM   #8
jennifer2004
LQ Newbie
 
Registered: Dec 2004
Posts: 9

Original Poster
Rep: Reputation: 0
I changed the module name in hardward detail from e100 to eepro100 in
YaST. After I restarted the computer, now when I do lsmod, I can
see eepro100 is loaded automatically instead of e100. However, I still
get the message when I do ifup eth0
ERROR: No configuration found for eth0.

Any more suggestions ? Thank you so much for helping me out on
this. I have been stuck on this issue for very long.
 
Old 12-21-2004, 06:49 PM   #9
pturner7
Member
 
Registered: Jun 2003
Location: UK
Distribution: openSUSE 11.0
Posts: 30

Rep: Reputation: 15
When you edited the configuration in Yast, what was the Device name (or Network Device name)? This should be eth0. If it is anything different then it will need to be changed to eth0.
 
Old 12-21-2004, 07:06 PM   #10
jennifer2004
LQ Newbie
 
Registered: Dec 2004
Posts: 9

Original Poster
Rep: Reputation: 0
The network device is eth-id-00:11:11:49:ea:b7 in YaST, however
it is not an editable field, so I cannot change it to eth0.

If I do modprobe e100, and do a ifup, it shows
linux:/usr/lib # ifup eth0
eth0 device: Intel Corp.: Unknown device 1064 (rev 03)
eth0 configuration: eth-id-00:11:11:49:ea:b7
DHCP client is already running on eth0

only after modprobe eepro100, ifup shows
linux:/usr/lib # ifup eth0
eth0
ERROR: No configuration found for eth0

Seems like eth0 and eth-id-00:11:11:49:ea:b7 are the same, do
I have to change from eth-id-00:11:11:49:ea:b7 to eth0
in network device field ?

Thanks
 
Old 12-22-2004, 07:07 AM   #11
pturner7
Member
 
Registered: Jun 2003
Location: UK
Distribution: openSUSE 11.0
Posts: 30

Rep: Reputation: 15
Quote:
The network device is eth-id-00:11:11:49:ea:b7 in YaST, however
it is not an editable field, so I cannot change it to eth0.
You are right, it is not editable. If I remember correctly, I think what you can do is one of two things:

1. Delete the network card in Yast and reconfigure as eth0 - I think you can set the device name when configuring a new card.

or/and

2. In terminal as root go to directory /etc/sysconfig/network

Look for a file called ifcfg-eth-id-00:11:11:49:ea:b7 and make a copy of this with the name ifcfg-eth0
Check the contents of the new file to see if the settings look correct for your setup.
Now, you will have to restart network services to implement this.

ifdown eth0
ifup eth0

What do you get now?
 
Old 12-22-2004, 12:07 PM   #12
jennifer2004
LQ Newbie
 
Registered: Dec 2004
Posts: 9

Original Poster
Rep: Reputation: 0
I did #2 and have eth0 as my network device, but when I
do a ifup, I still get the same mesage.
ERROR: Interface eth0 is not available
 
Old 12-22-2004, 01:43 PM   #13
pturner7
Member
 
Registered: Jun 2003
Location: UK
Distribution: openSUSE 11.0
Posts: 30

Rep: Reputation: 15
I think you may have to re-configure the network card in Yast as eth0 after deleting the current configuration.

Try this then followup with ifconfig and post result.
 
Old 12-22-2004, 02:24 PM   #14
jennifer2004
LQ Newbie
 
Registered: Dec 2004
Posts: 9

Original Poster
Rep: Reputation: 0
I also did it using YaST for eth0, after I do ifup got the usual error
messgae and the result of ifconfig is
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:52 errors:0 dropped:0 overruns:0 frame:0
TX packets:52 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3360 (3.2 Kb) TX bytes:3360 (3.2 Kb)
 
Old 12-22-2004, 03:32 PM   #15
pturner7
Member
 
Registered: Jun 2003
Location: UK
Distribution: openSUSE 11.0
Posts: 30

Rep: Reputation: 15
And the contents of ifcfg-eth0 ?

Also, which driver is loaded when command lsmod is issued?

Last edited by pturner7; 12-22-2004 at 03:38 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 10 network configuration. Problem with 8139 network card drivers ! Padmakiran Linux - Networking 8 03-27-2007 07:48 AM
linux shuts down built in network card then windows tells me network card is unplugge lesmoxhaybaker SUSE / openSUSE 8 08-29-2006 06:10 PM
3c905C network card in docking station. Cannot activate network device eth0. pathelms Linux - Networking 4 04-12-2006 03:55 PM
how to set up SMC EZ Card 10/100 ethernet PCI network card mymojo Linux - Networking 2 12-16-2003 03:35 AM
network installation of RH7.3 on laptop with pcmcia network card. Smerk Linux - Distributions 1 11-01-2002 12:56 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 09:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration