-   SUSE / openSUSE (
-   -   ndiswrapper and bcm4309 help installing also ati and brightness (

FireFerum 09-16-2006 12:54 PM

ndiswrapper and bcm4309 help installing also ati and brightness
I have two questions. The first is about wireless drivers and ndiswrapper.

I went through and installed ndiswrapper, found the driver for my broadcom wireless card on my windows partition, did ndiswrapper -i bcmwl5.inf and then ndiswrapper -l showed me the driver and that it was installed and the hardware was present.

Then, I went to yast, added a wireless card to load from module ndiswrapper with all the default settings.

I cannot see the card in network tools. Thus, I cannot connect. I think my module does not load. I tried ndiswrapper -m and everything went ok, but still I don't think the module loaded? This is the first time I am trying wireless on linux so I'm having issues. Any help would be appreciated.

Second question: With the ATI drivers, on a laptop, my brightness keys don't work anymore. I was able to change screen brightness before I put in the drivers, but now I am not. Is this something that can be fixed? I know a lot of people are having this same issue. Also, can I enable compiz on here or will the ATI card and drivers mess my whole suse installation up?


FireFerum 09-17-2006 10:56 AM

Any ideas are welcome even if they may sound stupid because I don't have any. I'm willing to try anything that would help.

FireFerum 09-18-2006 09:39 AM

Bump back to the top with hope for a solution. :Pengy:

falcon56215 09-19-2006 02:17 PM

What does:

# ifup wlan0

give you?

I have a Compaq Presario 2195US with broadcom 4xxx wireless built in. The brightness worked straight out of the install, as well as suspend to disk and battery meter. Wireless took a little more effort, I installed ndiswrapper as you described. Reboot. See if you can bring up the network with the above command. Also make sure you have installed your card through Yast>Network Devices>Network Card. Then run:

# dhclient

and try to pull up a web page.

Hope this helps.

FireFerum 09-19-2006 03:23 PM

ifup wlan0 gives me: "Interface wlan0 is not available."

How do I add this interface? I tried uninstalling ndiswrapper with YAST and then reinstalling. Reinstalled the driver, and when I did ndiswrapper -m it said "modprobe config already contains alias directive"

I checked my modprobe.conf.local and it's empty. In modprobe.conf there is nothing about wlan0

beagle2 09-19-2006 03:38 PM

Have you loaded the module with modprobe ndiswrapper? What did dmesg say when you did that?

FireFerum 09-19-2006 03:46 PM

modprobe ndiswrapper says: "FATAL: Module ndiswrapper not found."

beagle2 09-19-2006 03:53 PM

If you installed ndiswrapper from the dvd check you have the correct version for the kernel you are running, I think there were 2 or 3 different versions. Other than that try this excellent howto

FireFerum 09-19-2006 03:57 PM

I installed from packman but I am following some instructions i found while googling on this page:

I will let you know if this works. I am sure I had the ndiswrapper for my source because the versions were the same... I am about to compile it from scratch so maybe that will fix some stuff.

beagle2 09-19-2006 04:06 PM

I did the same when I first tried installing ndiswrapper, uname -a will show you running kernel and the ndiswrapper version should have same suffix ie. kmp-default, kmp-smp, kmp-xen. Anyway that guide is pretty good and also helps avoid the problems with networkmanager.

FireFerum 09-19-2006 04:16 PM

Yeah. SOLVED!!! That guide helped a lot. Now I see wlan0 and it lists my Wireless card. I'm kind of happy. It only took like a week to fix but hey, I got it :) Thanks all for the help.

All times are GMT -5. The time now is 05:05 AM.