LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 11-15-2004, 09:30 PM   #1
mukman
LQ Newbie
 
Registered: Nov 2004
Location: Tulsa, Oklahoma
Distribution: suse 9.2
Posts: 5

Rep: Reputation: 0
Mplayer on the amd64


I'm running suse 9.2 on my amd 64 2800+, and I tried pointing yast at packman's 9.2 stuff and it said it couldn't resolve the dependancies. So then I looked around and I was told that the standard release of mplayer didn't like amd64's, so I went and got the latest cvs and tried to compile it. Here's what happens:
Quote:
cc -c -I../libvo -I../../libvo -O4 -pipe -ffast-math -fomit-frame-pointer -D_REENTRANT -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I. -I.. -I../osdep -I/usr/include/freetype2 -I/usr/include/SDL -D_REENTRANT -I/usr/include/directfb -DMPG12PLAY -o vo_fbdev.o vo_fbdev.c
In file included from /usr/include/asm/pda.h:4,
from /usr/include/asm-x86_64/thread_info.h:14,
from /usr/include/asm/thread_info.h:4,
from /usr/include/linux/thread_info.h:21,
from ../osdep/kerneltwosix.h:4,
from vo_fbdev.c:21:
/usr/include/asm-x86_64/pda.h:26: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
/usr/include/asm-x86_64/pda.h:26: error: requested alignment is not a constant
In file included from /usr/include/asm/processor.h:4,
from /usr/include/linux/prefetch.h:14,
from /usr/include/linux/list.h:7,
from ../osdep/kerneltwosix.h:5,
from vo_fbdev.c:21:
/usr/include/asm-x86_64/processor.h:228: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
/usr/include/asm-x86_64/processor.h:228: error: requested alignment is not a constant
In file included from /usr/include/linux/list.h:7,
from ../osdep/kerneltwosix.h:5,
from vo_fbdev.c:21:
/usr/include/linux/prefetch.h: In function `prefetch_range':
/usr/include/linux/prefetch.h:64: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared (first use in this function)
/usr/include/linux/prefetch.h:64: error: (Each undeclared identifier is reported only once
/usr/include/linux/prefetch.h:64: error: for each function it appears in.)
make[1]: *** [vo_fbdev.o] Error 1
make[1]: Leaving directory `/home/sgoodwin/bin/main/libvo'
make: *** [libvo/libvo.a] Error 2

 
Old 11-15-2004, 11:59 PM   #2
electronique
Member
 
Registered: Mar 2004
Location: Menomonie, WI
Distribution: SuSE 9.2, Slackware Current, Arch Linux 0.7
Posts: 119

Rep: Reputation: 15
tried another player?

Why don't you try using an alternate player such as XINE it has all the same functionality if not more than Mplayer
 
Old 11-16-2004, 10:27 PM   #3
mukman
LQ Newbie
 
Registered: Nov 2004
Location: Tulsa, Oklahoma
Distribution: suse 9.2
Posts: 5

Original Poster
Rep: Reputation: 0
I installed libdvdcss and xine/totem didn't think they could play dvd's. they flat out refused even. I couldn't bother with mplayer if they would just work.
 
Old 12-03-2004, 03:20 AM   #4
rustynailz
Member
 
Registered: Jun 2004
Distribution: MDK 9.2/10.0, VectorLinux 4.0
Posts: 50

Rep: Reputation: 15
Not sure if you've already figured this out, but just add --disable-fbdev after configure (in addition to any other options) and you should be good to go.
 
Old 12-03-2004, 07:25 AM   #5
mukman
LQ Newbie
 
Registered: Nov 2004
Location: Tulsa, Oklahoma
Distribution: suse 9.2
Posts: 5

Original Poster
Rep: Reputation: 0
THat didn't work, bt I did find a guy on the suse-amd64 mailing list who had rpms that worked. Thanks though
 
Old 12-07-2004, 03:30 AM   #6
carpe_noctum
LQ Newbie
 
Registered: Dec 2004
Location: St. Louis
Distribution: SuSe 9.2
Posts: 2

Rep: Reputation: 0
Mukman,
I'm running an AMD64 3000+ with SUSE 9.2, and I am encountering the same problems compiling MPlayer. Could you direct me to the rpm's you found that work? Thanks.
 
Old 12-07-2004, 03:37 AM   #7
rustynailz
Member
 
Registered: Jun 2004
Distribution: MDK 9.2/10.0, VectorLinux 4.0
Posts: 50

Rep: Reputation: 15
Did you try:
./configure --disable-fbdev
make
?

That's the fix suggested by someone at SuSE - worked for me.
 
Old 12-07-2004, 07:55 AM   #8
snakedriver
Member
 
Registered: Nov 2003
Location: North East Arkansas
Distribution: Suse 9.2 x86-64
Posts: 59

Rep: Reputation: 15
X86-64 Xine Install

Here's how I did it. It's beautiful!
Go Here:
ftp://ftp.gwdg.de/pub/linux/suse/apt...suser-jmorris/

Download these rpm's.

kaffeine-0.5-1rc2.x86_64.rpm
libfame-0.9.1-5.x86_64.rpm
libdvdcss2-1.2.8-3.x86_64.rpm
libstk-0.2cvs20041023-1.x86_64.rpm
libxine1-1_rc7-0[1].x86_64.rpm
libxine1-aa-1_rc7-0.x86_64.rpm
libxine1-dvb-1_rc7-0.x86_64.rpm
libxine1-dxr3-1_rc7-0.x86_64.rpm
libxine1-gnome-vfs-1_rc7-0.x86_64.rpm
libxine1-sdl-1_rc7-0.x86_64.rpm
libxine1-stk-1_rc7-0.x86_64.rpm
speex-1.1.6-2.x86_64.rpm
suser-jmorris.asc

uninstall all previously installed xine related rpm's = Yast, search, xine, delete all in right panel
I would suggest uninstalling the SuSE supplied xine-ui & leave uninstalled.

if these need any other packages as dependencies, they should be on the dvd.

To install the key, you should only need to rpm -ivh rpmkey-suser-jmorris*rpm.
Try rpm -q rpmkey-suser-jmorris to make sure it is installed.
You can also check using kpackage or Yast. The asc file is available so you could
also if needed do an rpm --import.

I would like to thank suser jmorris for making all the x86-64 rpm's and sharing them with all newbs of the world -- Suse 9.2 x86-64 just got a whole lot better!!!


Have fun,
Snakedriver

Last edited by snakedriver; 12-07-2004 at 09:02 AM.
 
Old 12-07-2004, 08:18 AM   #9
snakedriver
Member
 
Registered: Nov 2003
Location: North East Arkansas
Distribution: Suse 9.2 x86-64
Posts: 59

Rep: Reputation: 15
Mplayer on Amd64

Recommend installing with apt!
go here for suse apt howto:
http://linux01.gwdg.de/apt4rpm/

needed suse apt rpm's are here:
ftp://ftp.gwdg.de/pub/linux/suse/apt...suser-jmorris/

Lua-0.5.5 (or later) = may be included in apt-libs but won't hurt to install
apt-libs-0.5.5(or later)
apt-0.5.5(or later)
synaptic-0.4.6(or later)

Plus. I had to issue command:
kdesu -c /usr/sbin/synaptic
to get synaptic to run from start list.

edit sources.list iaw suse apt howto to include suser-jmorris
run synaptic, run synaptic update
tell synaptic to install Mplayer

Enjoy,
Snakedriver

ps: Note: If you also add rpmkeys to sources.list & Install packman & jmorris rpmkeys first, all your apt installs work flawlessly

Last edited by snakedriver; 12-07-2004 at 09:03 AM.
 
Old 12-09-2004, 07:01 PM   #10
carpe_noctum
LQ Newbie
 
Registered: Dec 2004
Location: St. Louis
Distribution: SuSe 9.2
Posts: 2

Rep: Reputation: 0
I installed the new version of Xine... I still have a few library dependency issues, but as soon as I get a few minutes to reload those libraries, I'm sure those will be fixed. Thanks much for the link.
 
Old 12-17-2004, 02:44 AM   #11
ShadowMetis
Member
 
Registered: Dec 2004
Location: Newburgh
Distribution: Gentoo
Posts: 85

Rep: Reputation: 15
The --disable-fbdev fix also worked for me. Just wondering, what is it that I disabled? Is it going to affect anything?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Difference between amd64 generic and amd64 k8? halfpower Linux - General 6 09-07-2006 06:28 PM
using mplayer with .asx without -playlist? Would be useful for mplayer plug-in pierrethibault Linux - Software 1 02-18-2005 09:12 AM
No sound in mplayer or mplayer firefox plugin case1984 Linux - Newbie 1 01-21-2005 01:58 AM
How to install mplayer gui after installing mplayer kaega2 Linux - Software 5 10-07-2003 11:44 AM
mplayer is cool ... mplayer plug-in is even cooler..! linuxlah Linux - General 4 07-16-2003 11:55 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 07:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration