LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   SUSE / openSUSE (https://www.linuxquestions.org/questions/suse-opensuse-60/)
-   -   Mplayer on the amd64 (https://www.linuxquestions.org/questions/suse-opensuse-60/mplayer-on-the-amd64-255338/)

mukman 11-15-2004 08:30 PM

Mplayer on the amd64
 
I'm running suse 9.2 on my amd 64 2800+, and I tried pointing yast at packman's 9.2 stuff and it said it couldn't resolve the dependancies. So then I looked around and I was told that the standard release of mplayer didn't like amd64's, so I went and got the latest cvs and tried to compile it. Here's what happens:
Quote:

cc -c -I../libvo -I../../libvo -O4 -pipe -ffast-math -fomit-frame-pointer -D_REENTRANT -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I. -I.. -I../osdep -I/usr/include/freetype2 -I/usr/include/SDL -D_REENTRANT -I/usr/include/directfb -DMPG12PLAY -o vo_fbdev.o vo_fbdev.c
In file included from /usr/include/asm/pda.h:4,
from /usr/include/asm-x86_64/thread_info.h:14,
from /usr/include/asm/thread_info.h:4,
from /usr/include/linux/thread_info.h:21,
from ../osdep/kerneltwosix.h:4,
from vo_fbdev.c:21:
/usr/include/asm-x86_64/pda.h:26: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
/usr/include/asm-x86_64/pda.h:26: error: requested alignment is not a constant
In file included from /usr/include/asm/processor.h:4,
from /usr/include/linux/prefetch.h:14,
from /usr/include/linux/list.h:7,
from ../osdep/kerneltwosix.h:5,
from vo_fbdev.c:21:
/usr/include/asm-x86_64/processor.h:228: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
/usr/include/asm-x86_64/processor.h:228: error: requested alignment is not a constant
In file included from /usr/include/linux/list.h:7,
from ../osdep/kerneltwosix.h:5,
from vo_fbdev.c:21:
/usr/include/linux/prefetch.h: In function `prefetch_range':
/usr/include/linux/prefetch.h:64: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared (first use in this function)
/usr/include/linux/prefetch.h:64: error: (Each undeclared identifier is reported only once
/usr/include/linux/prefetch.h:64: error: for each function it appears in.)
make[1]: *** [vo_fbdev.o] Error 1
make[1]: Leaving directory `/home/sgoodwin/bin/main/libvo'
make: *** [libvo/libvo.a] Error 2



electronique 11-15-2004 10:59 PM

tried another player?
 
Why don't you try using an alternate player such as XINE it has all the same functionality if not more than Mplayer

mukman 11-16-2004 09:27 PM

I installed libdvdcss and xine/totem didn't think they could play dvd's. they flat out refused even. I couldn't bother with mplayer if they would just work.

rustynailz 12-03-2004 02:20 AM

Not sure if you've already figured this out, but just add --disable-fbdev after configure (in addition to any other options) and you should be good to go.

mukman 12-03-2004 06:25 AM

THat didn't work, bt I did find a guy on the suse-amd64 mailing list who had rpms that worked. Thanks though

carpe_noctum 12-07-2004 02:30 AM

Mukman,
I'm running an AMD64 3000+ with SUSE 9.2, and I am encountering the same problems compiling MPlayer. Could you direct me to the rpm's you found that work? Thanks.

rustynailz 12-07-2004 02:37 AM

Did you try:
./configure --disable-fbdev
make
?

That's the fix suggested by someone at SuSE - worked for me.

snakedriver 12-07-2004 06:55 AM

X86-64 Xine Install
 
Here's how I did it. It's beautiful!
Go Here:
ftp://ftp.gwdg.de/pub/linux/suse/apt...suser-jmorris/

Download these rpm's.

kaffeine-0.5-1rc2.x86_64.rpm
libfame-0.9.1-5.x86_64.rpm
libdvdcss2-1.2.8-3.x86_64.rpm
libstk-0.2cvs20041023-1.x86_64.rpm
libxine1-1_rc7-0[1].x86_64.rpm
libxine1-aa-1_rc7-0.x86_64.rpm
libxine1-dvb-1_rc7-0.x86_64.rpm
libxine1-dxr3-1_rc7-0.x86_64.rpm
libxine1-gnome-vfs-1_rc7-0.x86_64.rpm
libxine1-sdl-1_rc7-0.x86_64.rpm
libxine1-stk-1_rc7-0.x86_64.rpm
speex-1.1.6-2.x86_64.rpm
suser-jmorris.asc

uninstall all previously installed xine related rpm's = Yast, search, xine, delete all in right panel
I would suggest uninstalling the SuSE supplied xine-ui & leave uninstalled.

if these need any other packages as dependencies, they should be on the dvd.

To install the key, you should only need to rpm -ivh rpmkey-suser-jmorris*rpm.
Try rpm -q rpmkey-suser-jmorris to make sure it is installed.
You can also check using kpackage or Yast. The asc file is available so you could
also if needed do an rpm --import.

I would like to thank suser jmorris for making all the x86-64 rpm's and sharing them with all newbs of the world -- Suse 9.2 x86-64 just got a whole lot better!!!


Have fun,
Snakedriver

snakedriver 12-07-2004 07:18 AM

Mplayer on Amd64
 
Recommend installing with apt!
go here for suse apt howto:
http://linux01.gwdg.de/apt4rpm/

needed suse apt rpm's are here:
ftp://ftp.gwdg.de/pub/linux/suse/apt...suser-jmorris/

Lua-0.5.5 (or later) = may be included in apt-libs but won't hurt to install
apt-libs-0.5.5(or later)
apt-0.5.5(or later)
synaptic-0.4.6(or later)

Plus. I had to issue command:
kdesu -c /usr/sbin/synaptic
to get synaptic to run from start list.

edit sources.list iaw suse apt howto to include suser-jmorris
run synaptic, run synaptic update
tell synaptic to install Mplayer

Enjoy,
Snakedriver

ps: Note: If you also add rpmkeys to sources.list & Install packman & jmorris rpmkeys first, all your apt installs work flawlessly

carpe_noctum 12-09-2004 06:01 PM

I installed the new version of Xine... I still have a few library dependency issues, but as soon as I get a few minutes to reload those libraries, I'm sure those will be fixed. Thanks much for the link.

ShadowMetis 12-17-2004 01:44 AM

The --disable-fbdev fix also worked for me. Just wondering, what is it that I disabled? Is it going to affect anything?


All times are GMT -5. The time now is 06:11 AM.