LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 12-20-2004, 10:55 PM   #1
joney_bravo
Member
 
Registered: Jul 2004
Distribution: Blag
Posts: 35

Rep: Reputation: 15
Mounting partition


A couple days ago I resized my windows partition from 20gb to 15gb using yast and now it does not show up in the "My Computer" folder on the desktop or in the main "/" directory. It is a 15GB Windows 2000 NTFS partition. How can I mount this partition?

I also encountered some other problems.

After resizing my ntfs partition I tried to make a 4.8gb partition with the left over space I created and mount it but it didn't work. I tried it a few times with different mount points such as "/jonathan". Now when I start up the computer this folder appears in the main "/" directory. How can I prevent this from happening.

My third problem is that I cannot make that 4.8gb partition with the unused harddrive space. I am trying to make a partition around 5gb because I am going to try and make a linux distro with "Linux From Scratch".

Could someone please help me solve my three problems.

Thanks
 
Old 12-21-2004, 01:22 PM   #2
valerie_tux
Member
 
Registered: Aug 2003
Distribution: Debian
Posts: 150

Rep: Reputation: 15
First.. we need the contents of your /etc/fstab file. Its clear that after the partition resize the blocks are not numbered the same.
So...
run the following command at the console
Code:
dmesg | grep hda
(assuming your hard disk is the primary disk other wise use hdb)

fstab should contain details regarding where it is looking for the partition blocks.
Make sure they exist and have the right format i.e. you cant load a linux partition assuming its an NTFS partition. Need more details about that? check man fstab

Next try mounting the partitions one by one and check if they are all working fine. You might need to tweak fstab.. (make sure you a have a back up, if you mistake then you might not be able to boot in)

Lets see. All that should answer your first question and the second one too...
For the third question am not sure I understood it in the first place.

Do let us know....
 
Old 12-21-2004, 05:22 PM   #3
joney_bravo
Member
 
Registered: Jul 2004
Distribution: Blag
Posts: 35

Original Poster
Rep: Reputation: 15
here is what I got from the dmesg | grep hda command:

Kernel command line: root=/dev/hdc3 vga=0x317 desktop resume=/dev/hdc2 splash=si lent
ide1: BM-DMA at 0xc808-0xc80f, BIOS settings: hdcMA, hddio
hdc: Maxtor 4W060H4, ATA DISK drive
hdc: max request size: 128KiB
hdc: 120103200 sectors (61492 MB) w/2048KiB Cache, CHS=65535/16/63, UDMA(100)
hdc: cache flushes not supported
hdc: hdc1 hdc2 hdc3
Resume Machine: resuming from /dev/hdc2
Resuming from device hdc2
ReiserFS: hdc3: found reiserfs format "3.6" with standard journal
ReiserFS: hdc3: using ordered data mode
ReiserFS: hdc3: journal params: device hdc3, size 8192, journal first block 18, max trans len 1024, max batch 900, max commit age 30, max trans age 30
ReiserFS: hdc3: checking transaction log (hdc3)
reiserfs: disabling flush barriers on hdc3
ReiserFS: hdc3: Using r5 hash to sort names
Adding 1032184k swap on /dev/hdc2. Priority:42 extents:1
 
Old 12-21-2004, 05:23 PM   #4
joney_bravo
Member
 
Registered: Jul 2004
Distribution: Blag
Posts: 35

Original Poster
Rep: Reputation: 15
here i disabled the smilies:

Kernel command line: root=/dev/hdc3 vga=0x317 desktop resume=/dev/hdc2 splash=si lent
ide1: BM-DMA at 0xc808-0xc80f, BIOS settings: hdc:DMA, hdd:pio
hdc: Maxtor 4W060H4, ATA DISK drive
hdc: max request size: 128KiB
hdc: 120103200 sectors (61492 MB) w/2048KiB Cache, CHS=65535/16/63, UDMA(100)
hdc: cache flushes not supported
hdc: hdc1 hdc2 hdc3
Resume Machine: resuming from /dev/hdc2
Resuming from device hdc2
ReiserFS: hdc3: found reiserfs format "3.6" with standard journal
ReiserFS: hdc3: using ordered data mode
ReiserFS: hdc3: journal params: device hdc3, size 8192, journal first block 18, max trans len 1024, max batch 900, max commit age 30, max trans age 30
ReiserFS: hdc3: checking transaction log (hdc3)
reiserfs: disabling flush barriers on hdc3
ReiserFS: hdc3: Using r5 hash to sort names
Adding 1032184k swap on /dev/hdc2. Priority:42 extents:1

When I try and mount the windows partition (which is /dev/hdc1) it says this:

mount /dev/hdc1
mount: can't find /dev/hdc1 in /etc/fstab or /etc/mtab

Here are the contents of my fstab file:

/dev/hdc3 / reiserfs acl,user_xattr 1 1
/dev/hdc2 swap swap pri=42 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
sysfs /sys sysfs noauto 0 0
/dev/dvd /media/dvd subfs fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/dvdrecorder /media/dvdrecorder subfs fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/fd0 /media/floppy subfs fs=floppyfss,procuid,nodev,nosuid,sync 0 0

and here are the contents of my mtab file:

/dev/hdc3 / reiserfs rw,acl,user_xattr 0 0
proc /proc proc rw 0 0
tmpfs /dev/shm tmpfs rw 0 0
devpts /dev/pts devpts rw,mode=0620,gid=5 0 0
/dev/hdb /media/dvd subfs ro,nosuid,nodev,fs=cdfss,procuid,iocharset=utf8 0 0
/dev/hda /media/dvdrecorder subfs ro,nosuid,nodev,fs=cdfss,procuid,iocharset=utf8 0 0
/dev/fd0 /media/floppy subfs rw,nosuid,nodev,sync,fs=floppyfss,procuid 0 0
usbfs /proc/bus/usb usbfs rw 0 0

Last edited by joney_bravo; 12-21-2004 at 05:41 PM.
 
Old 12-22-2004, 12:00 PM   #5
valerie_tux
Member
 
Registered: Aug 2003
Distribution: Debian
Posts: 150

Rep: Reputation: 15
Okie dokie..
Add this line to your fstab you should be able to mount the windows partition after that
Code:
/dev/hdc1       /mnt/windows     ntfs    noatime,defaults,users,ro,umask=0 0 0
The /mnt/windows should be created if its not present already. Basically you can use any folder where you would like to see your windows folders.
now issue the command
mount /dev/hdc1
everything should be fine.

What I understand from your fstab and dmesg output-
-you have three partitions.. hdc1 is windows ntfs, hdc2 is linux swap and hdc3 is linux partition
-your swap partition (hdc2) is around 1000MB

which leaves me wondering... WHERE is that 4.8 GB of unused space you were talking about?
 
Old 12-22-2004, 03:38 PM   #6
joney_bravo
Member
 
Registered: Jul 2004
Distribution: Blag
Posts: 35

Original Poster
Rep: Reputation: 15
I resized the hdc1 partition from 20GB to 15GB. What would be the best way to create a linux partition with that space?

I entered that code into my fstab file but I changed the mount location from /mnt/windows to /windows/C because that is what it was origionally. When I try to mount the partition it says:

Code:
mount: wrong fs type, bad option, bad superblock on /dev/hdc1,
or too many mounted file systems

Last edited by joney_bravo; 12-22-2004 at 04:06 PM.
 
Old 12-23-2004, 11:49 AM   #7
valerie_tux
Member
 
Registered: Aug 2003
Distribution: Debian
Posts: 150

Rep: Reputation: 15


I dont know whats wrong with the fstab entry... make sure the words are separated by tabs and not by spaces (but I guess you've done that already).
Try the program qtparted. I used it to format my new drive. It gives a very nice view of where the disk space has been allocated.
 
Old 12-23-2004, 03:13 PM   #8
joney_bravo
Member
 
Registered: Jul 2004
Distribution: Blag
Posts: 35

Original Poster
Rep: Reputation: 15
I edited the fstab file with the program "vi" in the command line. I have just been using the spacebar to seperate the words. How do I use tab?

Thanks
 
Old 12-23-2004, 05:50 PM   #9
dohanc
LQ Newbie
 
Registered: Dec 2004
Distribution: Suse 9.1
Posts: 12

Rep: Reputation: 0
Try skipping mounting devices with fstab for a second. Just to make sure you're doing it correctly, as it's a little hard to follow. Do

mount /dev/hdc1 /directory_name

Obviously make sure your directory exists. If this doesn't work, check back with Yast --> Partioner and list us all your partitions there.

If your still having problems with it, and you DO NOT want the data on /dev/hdc1 for whatever reason you can simply remake the Reiser filesystem on it. This sounds like at least what you want to do with your extra space. Yast --> Partitioner should show you where that extra space is, perhaps /dev/hdc4.

mkreiserfs /dev/hdc# where # is whatever partition number you want to create a new filesystem. This WILL delete any data you have stored on that partition, blank or not.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounting Partition DDRfreak2 Mandriva 8 09-10-2005 01:33 PM
Mounting a partition 1veedo Linux - Hardware 6 12-19-2004 07:40 PM
Partition mounting/KDE errors after creating Fat32 Partition BertBert Linux - General 1 07-07-2004 11:59 AM
Mounting mounting extended partition and its Logical drives desbyleo Linux - Newbie 10 02-18-2002 04:13 PM
Partition mounting Rex_chaos Linux - General 11 09-24-2001 06:35 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 03:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration