LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 07-07-2005, 01:44 PM   #1
bomberb17
Member
 
Registered: Jul 2005
Posts: 47

Rep: Reputation: 0
Monitor just goes blank and won't go to standby


My monitor just goes blank and won't go to standby...display power management is enabled in the desktop configuration and after the specified time in standby, suspend or power off, it just goes blank (like a blank screen screensaver) but won't go to power-save mode. How can I fix this?
 
Old 07-07-2005, 01:57 PM   #2
kencaz
Senior Member
 
Registered: Mar 2005
Location: Las Vegas, NV
Distribution: Mandriva Slackware FreeBSD
Posts: 1,468

Rep: Reputation: 48
You may want to adjust some of the DMPS functions in "ServerLayout" Section in your X configuration file. You may add the section if it does not exist.

To manipulate the DPMS functions, you can create/modify the following items in the ServerLayout section.

Section "ServerLayout"
Option "BlankTime" "10" # Blank the screen in 10 minutes (Fake)
Option "StandbyTime" "20" # Turn off screen in 20 minutes (DPMS)
Option "SuspendTime" "30" # Full hibernation in 30 minutes (DPMS)
Option "OffTime" "40" # Turn off DPMS monitor (DPMS)
EndSection

BlankTime is not actually a power saving level at all. The screen is sent a "fake" blanking effect and defaults to activate after 10 minutes. Alternately, it can indicate the number of minutes until the screensaver should activate. It has nothing to do with DPMS.

StandbyTime is a very minor power saving level. This setting usually involves blanking the screen by turning off the electron (RGB) gun. However, the power supply is left on and the tube filaments energized. When you need to use the monitor again, the monitor will come back on very quickly. This option requires DPMS monitor/video-card support and defaults to 20 minutes under X-Windows. Also known as hsync suspend mode, since the horizontal sync signal is turned off to signal this power management state to a DPMS monitor.

SuspendTime is a very strong low power alternative. This setting usually involves the same power conservation as StandbyTime, however in addition the power supply is turned off. This option requires DPMS monitor/video-card support and defaults to 30 minutes under X-Windows. Also known as vsync suspend mode, since the vertical sync signal is turned off to signal this power management state to a DPMS monitor.

OffTime usually means just that. The computer monitor is turned off. A small auxiliary circuit stays on to monitor the signals from the computer to turn the monitor back on when data needs to be displayed to the screen. Obviously, this keeps power consumption to a bare minimum (zero). While the power saving is substantial, to reactivate the monitor may take up to 8-10 seconds. This option requires DPMS monitor/video-card support and defaults to 40 minutes under X-Windows. Both the horizontal and vertical sync signals are turned off to signal this power management state to a DPMS monitor.

KC
 
Old 07-07-2005, 03:12 PM   #3
bomberb17
Member
 
Registered: Jul 2005
Posts: 47

Original Poster
Rep: Reputation: 0
The X configuration file is the /etc/X11/xorg.conf? There is a serverlayout section in it, but it doesn't have any blank/standby time values in it... It looks like this:
Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection

Should I just add the lines you wrote? Or is it the wrong file?
 
Old 07-07-2005, 08:12 PM   #4
kencaz
Senior Member
 
Registered: Mar 2005
Location: Las Vegas, NV
Distribution: Mandriva Slackware FreeBSD
Posts: 1,468

Rep: Reputation: 48
Yes, you can add them all and just comment '#' out the ones you don't wish to use as such:

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
# Option "BlankTime" "10" # Blank the screen in 10 minutes (Fake)
Option "StandbyTime" "20" # Turn off screen in 20 minutes (DPMS)
# Option "SuspendTime" "30" # Full hibernation in 30 minutes (DPMS)
# Option "OffTime" "40" # Turn off DPMS monitor (DPMS)
EndSection

KC
 
Old 07-08-2005, 12:51 PM   #5
Crito
Senior Member
 
Registered: Nov 2003
Location: Knoxville, TN
Distribution: Kubuntu 9.04
Posts: 1,168

Rep: Reputation: 53
Hmm, I've been having the exact same problem. So I guess Xorg broke the KDE control center applet for power management, because I know this was working perfectly with Mandrake 9.2 which uses XFree.
 
Old 07-08-2005, 03:08 PM   #6
Crito
Senior Member
 
Registered: Nov 2003
Location: Knoxville, TN
Distribution: Kubuntu 9.04
Posts: 1,168

Rep: Reputation: 53
Well, it was worth a try.

Despite never having a 'BlankTime' entry in my xorg.conf and despite adding an 'OffTime' entry, it continues to blank my screen (leaving the backlight on, just blanking it) after about 5 minutes -- where it gets that number from I'll never know. Ironically, running 'xset -dpms' stops the useless screen blanking but does nothing to dpms. As a side note, running 'setterm -powersave off' -- yes, I've tried EVERYTHING -- returns 'cannot (un)set powersave mode', whatever the !@#$ that means.
 
Old 07-08-2005, 03:14 PM   #7
bomberb17
Member
 
Registered: Jul 2005
Posts: 47

Original Poster
Rep: Reputation: 0
I added the lines in xorg.conf, still the same problem...
 
Old 07-08-2005, 03:17 PM   #8
BROse
Member
 
Registered: Nov 2003
Location: Here & Now
Distribution: SuSE 10.2
Posts: 96

Rep: Reputation: 15
Sounds like driver prob......
 
Old 07-08-2005, 03:26 PM   #9
Crito
Senior Member
 
Registered: Nov 2003
Location: Knoxville, TN
Distribution: Kubuntu 9.04
Posts: 1,168

Rep: Reputation: 53
Well, I'm using an integrated Intel 'ExtremeGraphics2' (or something like that) video card. 3D DRI is working perfectly with it, surprsingly, since I've had many probs with that in the past. What kind of vid card are you using bomber?


OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) 852GM/855GM 20041217 x86/MMX/SSE2
OpenGL version string: 1.3 Mesa 6.2.1
 
Old 08-20-2005, 01:16 PM   #10
bomberb17
Member
 
Registered: Jul 2005
Posts: 47

Original Poster
Rep: Reputation: 0
I have a Nvidia Vanta card. Haven't installed nvidia drivers. My monitor is a Sony CPD-200ES.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Monitor doesn't standby koodoo Linux - Newbie 6 03-24-2007 08:01 PM
monitor goes into standby on boot alex17 SUSE / openSUSE 7 10-28-2005 04:33 PM
Monitor goes into standby dave`2005 Slackware 14 08-12-2005 09:06 PM
monitor will not standby Hectic Linux - General 1 10-22-2004 02:33 AM
How do I put monitor on standby? hussar Slackware 6 06-14-2004 12:18 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 02:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration