Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
SUSE / openSUSE This Forum is for the discussion of Suse Linux.


  Search this Thread
Old 07-06-2006, 04:35 PM   #1
LQ Newbie
Registered: Jul 2006
Location: Winnipeg, Canada
Distribution: SuSE
Posts: 12

Rep: Reputation: 0
Master Volume Control Doesn't work, only PCM does


I've got an annoying problem with the 'kmix' sound control. The Master Control does nothing, but the PCM volume control works perfectly. I can adjust the volume, mute, and it all works as it should with the PCM slider. I've tried kmix, kamix and gnome-alsamixer, and they all do the same thing.

I've configured my multimedia keyboard so that I can control the sound, but since it only controls the Master volume (which does nothing), it's pretty well useless.

I'm currently running KDE on SuSE 10.1, but this problem probably existed in 10, and maybe even 9.x, I just didn't care about it back then.

I don't really care if I get the master control to work, what I really want is to be able to control/mute the volume from the keyboard. If there's a way to 'slave' the PCM to the Master, or something like that, that would do the trick. Or, if there's another volume control out there where I can config the keyboard shortcuts. 'kmix' is sooo close, as the mute, vol up/down keyboard shortcuts work, it's just that they're controlling the Master volume, which does nothing. I'd like them to control the PCM volume instead.

Here's my config:
Sound Driver 3.8.1a-980706 (ALSA V1.0.11rc3 emulation code)
Installed driver: Type 10 ALSA emulation
card config: Intel 82801DB-ICH4 with AD1981A at 0xfe300400, irq 209
Audio Device: Intel 82801DB-ICH4 (DUPLEX)
Synth & Midi devices NOT ENABLED IN CONFIG
Mixer: 0: Analog Devices AD1981A

All suggestions appreciated.


Old 07-06-2006, 05:50 PM   #2
LQ Guru
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 64
Check out this post. It should get you started. Look at the scripts I wrote and then you can edit /etc/X11/Xmodmap to map keys to whatever. Or check out xbindkeys to map to scripts or whatever again. Also can be done from the Control Center from KDE.

Instead of using -v for master volume you use -w for the pcm channel. You can get that from the command ' man aumix '.

Old 07-07-2006, 09:57 AM   #3
LQ Newbie
Registered: Jul 2006
Location: Winnipeg, Canada
Distribution: SuSE
Posts: 12

Original Poster
Rep: Reputation: 0
Thanks for the tip, but I found a much easier way to do it. Don't know why/how I didn't notice this before, but when I right click 'kmix', there's an option to 'Select Master Channel'. I did this, and selected PCM as my master channel. I had already mapped my multimedia keys and configured them in 'kmix', so once I did that, everything works perfectly!



Old 11-11-2008, 08:53 AM   #4
Registered: Sep 2006
Posts: 74

Rep: Reputation: 15
I had the same problem on my Debian Etch, and now It works like a charm, right click - select master channel, lol, funny solution, but It's what a needed.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Gnome: make volume hotkeys alter PCM chanel instead of MASTER (ALSA) qwijibow Linux - General 1 11-13-2005 09:42 PM
No Master or PCM volume working J_stuart Ubuntu 2 10-17-2005 03:43 PM
Master Volume Control Issue dingledoink Ubuntu 0 09-23-2005 01:34 PM
PCM volume control doesn't work / 5.1 Wynand1 Linux - Hardware 3 03-09-2004 06:23 PM
master volume control for both front and rear? zarathustra674 Mandriva 1 12-05-2003 06:03 PM > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 11:11 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration