-   SUSE / openSUSE (
-   -   kernel update in suse 9.2 (

asamma 04-14-2005 08:47 AM

kernel update in suse 9.2
hello everybody!
i am new to linux. i have installed suse 9.2
some time ago i tried to use apt-synaptic to update programs, because i saw that yast didn't update many of them (for example from kde 3.3 to 3.4). using synaptic also updated the kernel (i marked all updates). after that i couldn't boot: kernel panic.
for that time i installed all again. i tried again because i wasn't sure of what was happening. same thing but this time i found out how to boot starting from the installation dvd (run installed version), and i downgraded everthing. it worked. so i started to look in the web for similar problems and i found the mk_initrd thing.
but continuing readin i understood (wrong?) that yast2 runs it automatically.
so i used synaptic only to download the packages and after i installed them with yast2. it ran suseconfig but it all happened again!! kernel panic....
so, does suseconfig (or anyway yast2) run mk_initrd? is this the problem?


broch 04-14-2005 09:46 AM

what is the error you are getting?

asamma 04-14-2005 09:51 AM

i can tell the exact message when i get back home in a couple of hourse but it's almost this:
kernel panic
can't resync .....
try to kill init

so, usually yast2 should run the mkinitrd for me?

asamma 04-14-2005 12:48 PM

ok, here's the error:
/bin/udev_volume_id: notfound
:= notfound

umount2:device or resource is busy
kernel panic - not syncing: attempted to kill init!

i ran the installed system starting from the installation dvd and did from the terminal (as root) mkinitrd.
no errors, but as i rebooted i got the same problem.

what can i try still?
thank you

broch 04-14-2005 09:45 PM

what you can try?
well, get vanilla, add FS and hard disk info to the kernel and ignore initrd completely (remove initrd info from GRUB/LILO). It looks like SuSE has some problems (you are not the only one, people complains about this issue).

asamma 04-15-2005 02:01 AM

it seems we are in different time zones..i'm in italy.
sorry, but to me vanilla FS and putting hard disk information to the kernel means almost nothing, i'm new to linux!

tumbelo 04-15-2005 10:07 AM

I almost killed my system trying to compile a new kernel (yes, I kept my old one but somehow it got crippled in the action, too) and I got the exact same message except for this:

umount2:device or resource is busy

But remove initrd from GRUB, you say? I assume you meant removing the line in bold. Correct me if I'm mistaken. Doesn't that stop the whole loading of kernel, making it irrelevant if the FS support is built-in? At least it did when I played with the settings.

###Don't change this comment - YaST2 identifier: Original name: linux###
title SUSE LINUX 9.2
kernel (hd0,3)/boot/vmlinuz root=/dev/hda4 vga=0x31a selinux=0 splash=silent resume=/dev/hda3 desktop elevator=as showopts
initrd (hd0,3)/boot/initrd

broch 04-15-2005 12:02 PM

The only point to use initrd is to allow loading modules (FS or SCSI) before actuall kernel will boot.
To load modules you need to boot kernel first. In case of SCSI or FS you will need these first and that is why you need initrd. If you build FS and disk into kernel, there is no need for initrd (with exception of splash)
I don't have it, even I removed it from kernel options, but FS and disk is in the kernel. It boots fine.

So to you need to make changes before you will remove initrd.

All times are GMT -5. The time now is 03:23 AM.