-   SUSE / openSUSE (
-   -   Kernel update has broken SAMBA (

abovett 01-01-2005 09:25 AM

Kernel update has broken SAMBA
Ever since the last kernel update (which I noticed included patches to address SMB vulnerabilities), I have not been able to get the SAMBA client on SuSE 9.1 PE to work correctly. I can mount shares with smbmount and I can then read existing files and write new files. However, I can't open existing files for writing or overwrite existing files. If I do, there is a pause and then an error. For example:

[andrew@neptune-suse scratch]$ touch testfile
[andrew@neptune-suse scratch]$ cp testfile ~/mnt/SOL/copying/
[andrew@neptune-suse scratch]$ cp testfile ~/mnt/SOL/copying/
cp: cannot create regular file `/home/andrew/mnt/SOL/copying/testfile': Input/output error
[andrew@neptune-suse scratch]$

I've tried it against several SAMBA servers, running on SuSE 9.1 PE, Mandrake 10.1, SME Server (Was Mitel, now Lycoris) and Fedora Core 3, and I get the same result.

However, SMB clients on Mandrake 10.1 and Vector 4.3 (Slackware based) work OK against these servers - so it appears to be a client side problem.

Anyone got any ideas? Here's my smb.conf, if it helps:

-- SOF----------------------------------------------------
workgroup = AJBLAN
server string = Samba Server %v
map to guest = Bad User
log file = /var/log/samba/log.%m
max log size = 50
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
dns proxy = No
printer admin = @adm

comment = Home Directories
read only = No
browseable = No

comment = All Printers
path = /var/spool/samba
create mask = 0700
guest ok = Yes
printable = Yes
print command = lpr-cups -P %p -o raw %s -r # using client side printer drivers.
use client driver = Yes
browseable = No

path = /var/lib/samba/printers
write list = @adm, root
inherit permissions = Yes
guest ok = Yes

comment = PDF Generator (only valid users)
path = /var/tmp
printable = Yes
printing = bsd
print command = /usr/share/samba/scripts/print-pdf "%s" "%H" "//%L/%u" "%m" "%I" "%J" &
lpq command = /bin/true
lprm command = lprm -P'%p' %j

path = /home/andrew/share
valid users = andrew
read only = No
-- EOF----------------------------------------------------

Andy B

All times are GMT -5. The time now is 06:34 AM.