-   SUSE / openSUSE (
-   -   Kernel Hangs at "Freeing unused kernel memory." (

jbo5112 11-16-2009 01:54 PM

Kernel Hangs at "Freeing unused kernel memory."
I had a running install of SUSE Linux Enterprise Server 10 SP2, but I'm moving it to a virtual machine (VMware Server 2.0.1). As far as it should matter to Linux, I'm just swapping out some devices: network card, video card, hard drive controller. The only critical change is that the hard drives were just attached to the SATA ports on the motherboard, but now they're running through a virtual LSI SAS controller.

I changed /etc/fstab and /boot/grub/menu.lst to reflect proper device names. I edited /etc/sysconfig/kernel to include the proper modules for the hard drive in INITRD_MODULES, which now reads "piix ahci processor thermal fan reiserfs edd mptsas sg." I ran mkinitrd without arguments, and rebooted the virtual machine.

Now, when it boots, it hangs at "Freeing unused kernel memory." I'm not sure how to debug this, fix this, or really all that sure about the mkinitrd command. I've compiled plenty of my own kernels, but this is the first time adjusting things in a package managed kernel.

If I remember correctly, I used to get this problem on occasion when I compiled my own kernel and left out necessary pieces, but it's been a couple of years since I've compiled my own kernel and much longer since I've had a problem. I could just be imagining it.

bhaslinux 11-22-2009 08:18 AM

since you have already got the knowledge about kernels, i would just suggest these things which come to my mind

1. The config of kernel you use for the virtual machine may be different and need some drivers which are not present and thus does not boot up.
2. The kernel is hanging due to some driver being loaded in initrd ? try doing a clean install (in a virtual machine) and then transfer the kernels to this machine ... i think this might work.
I am not sure how to enable verbose debugging during booting ... but removing 'quiet' from the kernel command line which many distros put, may help a lot !

jbo5112 11-22-2009 08:38 PM

I already have noquiet turned on, which gives you extra output, but it wasn't any help. I'll set up another virtual machine and copy the kernels across. I didn't think about being able to do that. Thanks!

All times are GMT -5. The time now is 12:15 PM.