-   SUSE / openSUSE (
-   -   KDE-windows behaviour (

kirth 01-18-2005 06:35 AM

KDE-windows behaviour
I've an annoying problem related to windows management in KDE 3.3.2 (recently I updated form previous version that had the same problem)
Here it is: when I open a new window launching an application, terminal, file system browser, or whatsoever, and after that I iconize it, I can't find it in the application task bar. So I have to left clik on the desktop to see the list of my open tasks and re-maximize them.
This occurs when logged in Graphical mode as user, not as root, where it works right fine
I have already checked all the settings hundred of times and they are idenitcal.
Use Suse 9.1 Pro
Where is the problem?
Any help would be extremely appreciated.



You can always log off, but you can't ever leave

leonscape 01-18-2005 06:43 AM

All I can think of is taskbar is not actually running, and where you expect them to appear is a blank panel.

Right click where you want the taskbar select add->applet->taskbar

kirth 01-19-2005 12:09 AM

Kde-windows behaviour
Thks for your suggestion
I already tried it...doesn't work...
I have no idea what it could depend on...

leonscape 01-19-2005 04:35 AM

This is very strange, theres no bug reports, and nobody seems to have had this particular problem.

The only thing I can think of suggesting is removing the task bar and then go into ~/.kde/share/config for file(s) beginning with taskbar and delete it/them. Then restart the taskbar.

If this doesn't work then all I can suggest is you create another user, and login into KDE with that new user, If the taskbar doesn't work, then you might have a permission problem, which will need more investigation.

If the new user doesn't have this problem, It might be advisable to delete ~/.kde and redo all your settings, which I know is a pain. You might have a corruption in some configuration files that are causing the problem.

kirth 01-19-2005 12:20 PM

Thks very much leonscape!
Your suggestions will help me, surely.
I think I'll go firstly through ~/.kde/share/config and if it doesn't work I'll create another user.
I hope not to arrive to last step you mentioned!!! :)

kirth 01-24-2005 07:10 AM

It worked!
I removed the task bar form the add/remove applet function and then went through the config file in .kde/share/config and delete those files beginning with taskbar.
After that readd the applet and reboot
Now it works again fine!

Thks a lot again!

All times are GMT -5. The time now is 10:04 AM.