LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 01-28-2019, 11:20 AM   #1
Crb999
Member
 
Registered: Jan 2017
Location: West Coast Scotland
Distribution: Suse Linux 42.2
Posts: 183

Rep: Reputation: Disabled
KDE seems to have lost data. Not able to use launcher


Hi,
There have been a lot of system updates in the last few days and as ever, I let the system get on with it because there is no way I could possibly help.
I have also been trying to get mmcheck running so as to sort out the video capabilities. mmcheck is now running well.
I thought I had it under control. No.

Audacity wouldn't start today, it normally works perfectly.

Now, after a reboot, I get a huge on screen keyboard. I can dismiss it and log in normally but across the centre of the screen, which is almost completely devoid of all the things I put there, is the message:

Unable to create io-slave. klauncher said:Error loading '/usr/lib64/qt5/plugins/kt5/kio/desktop.so.

It is extremely difficult for me to read, so there could be errors there.
I can't copy it, (and that applies to other error messages.It would be good to click and copy, especially for us old dodderers!)

One last point. I keep the little HD I/O monitor running on the screen and since this problem appeared, its been doing a hell of a lot of work, when it would normally be very close to dormant.

Any pointers (preferably explicit), gratefully received.

Regards

Chris
 
Old 01-28-2019, 12:07 PM   #2
petelq
Member
 
Registered: Aug 2008
Location: UK
Distribution: openSUSE(Leap and Tumbleweed) and a regularly changing third
Posts: 362

Rep: Reputation: Disabled
Try starting the packages from the terminal. You may get more info in the error messages.
The file desktop.so is part of the plasma5-workspace package so you could try reinstalling plasma5-workspace with
Code:
sudo zypper in plasma5-workspace
or
Code:
sudo zypper in -f plasma5-workspace
if the first method doesn't work.

It just occurred to me that you may have trouble launching a terminal so you may have to use a console screen (alt +F1) or login to init level 3.

Last edited by petelq; 01-28-2019 at 12:13 PM. Reason: in case terminal doesn't work.
 
Old 01-29-2019, 05:02 AM   #3
Crb999
Member
 
Registered: Jan 2017
Location: West Coast Scotland
Distribution: Suse Linux 42.2
Posts: 183

Original Poster
Rep: Reputation: Disabled
Hi petelq
I can get xterm from the rather otherwise blank KDE screen.
The first and second suggestion both return this:
Code:
crb999@linux-ox1l:~> sudo zypper in plasma5-workspace
[sudo] password for crb999: 
zypper: symbol lookup error: /usr/lib64/libproxy.so.1: undefined symbol: _ZN9libmodman14module_manager8load_dirENSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEEb
I shifted to a login screen by using the CTRL+ALT+F1 sequence, logged in as root and executed the first of your suggestions but got the same response!

Have I missed something out?

Regards

Chris
 
Old 01-29-2019, 09:34 AM   #4
petelq
Member
 
Registered: Aug 2008
Location: UK
Distribution: openSUSE(Leap and Tumbleweed) and a regularly changing third
Posts: 362

Rep: Reputation: Disabled
Hi Chris.
You did the right thing but the problem is more than just that missing package. That looks like a mismatched package (libproxy.so) and if zypper isn't working then its hard to see how to fix it.
Have you tried the opensuse forum?

You could try an upgrade from an opensuse net iso (you may need a wired internet connection). Choose upgrade instead of install and keep existing repos unless you have any mismatched. In fact if you're still using 42.2 it may be worth a complete update to 15.0 (leap)

Last edited by petelq; 01-29-2019 at 09:39 AM.
 
Old 01-29-2019, 12:09 PM   #5
Sauerland
Member
 
Registered: Jul 2017
Posts: 32

Rep: Reputation: Disabled
Such errors are often because of incompatible Repositories....
 
Old 01-29-2019, 12:56 PM   #6
petelq
Member
 
Registered: Aug 2008
Location: UK
Distribution: openSUSE(Leap and Tumbleweed) and a regularly changing third
Posts: 362

Rep: Reputation: Disabled
Quote:
Originally Posted by Sauerland View Post
Such errors are often because of incompatible Repositories....
That's what I was trying to say.
Thanks Sauerland. You put it so much more succinctly than I did.
 
Old 01-29-2019, 06:35 PM   #7
mrmazda
Senior Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE, Debian, Knoppix, Mageia, Fedora, others
Posts: 1,192

Rep: Reputation: 354Reputation: 354Reputation: 354Reputation: 354
You could try deleting icon*/k*/plasm*/q* caches from ~/.cache/ (while logged out of Plasma session).

Are you actually still using 42.2? It went out of support a year ago. 42.3 goes out in a few months. 15.1 is due in May. Now may be an appropriate time and opportunity for a distro upgrade.
 
Old 01-29-2019, 11:43 PM   #8
Sauerland
Member
 
Registered: Jul 2017
Posts: 32

Rep: Reputation: Disabled
So please post:
Code:
zypper lr -d
Hoping it will work....

Also:
Code:
rpm -qa libproxy1
 
Old 01-30-2019, 06:43 AM   #9
Crb999
Member
 
Registered: Jan 2017
Location: West Coast Scotland
Distribution: Suse Linux 42.2
Posts: 183

Original Poster
Rep: Reputation: Disabled
Sorry folks, I should have done this at the start:
====================================
=== openSUSE Leap
=== uname -r = 4.12.14-lp150.12.4-default
=== VERSION ="15.0"
=== ID="opensuse-leap"
=== kernel version is 4.13.0-rc4-1.g94b098f-default
=== kernel version is 4.12.14-lp150.12.4-default (geeko@buildhost)
=== Dell OptiPlex 780
=== X86-64
=== Intel Graphics Media Accelerator 950
=== Intel 4 Series Chipset Integrated Graphics Controller
=== Intel Gigabit Ethernet Controller
=== Intel(R) Core(TM)2 Quad CPU Q8400 @ 2.66GHz
=== 8Gb RAM
=== Intel SATA Controller [RAID mode]
=== 2 x 1Gb HD (Mirrored)
=== PIONEER DVD-RW DVR-219L
=== # WLAN network interface
====================================

On to business.

Code:
crb999@linux-ox1l:~> zypper lr -d
Repository priorities are without effect. All enabled repositories share the same priority.

#  | Alias                               | Name                                        | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                           | Service
---+-------------------------------------+---------------------------------------------+---------+-----------+---------+----------+--------+-------------------------------------------------------------------------------+--------
 1 | download.nvidia.com-leap            | nVidia Graphics Drivers                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.nvidia.com/opensuse/leap/15.0                                |        
 2 | download.opensuse.org-oss           | Update Repository (DEBUG)                   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/debug/update/leap/15.0/oss                       |        
 3 | download.opensuse.org-oss_1         | Main Repository (Sources)                   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/source/distribution/leap/15.0/repo/oss/          |        
 4 | http-download.opensuse.org-2de603a2 | home:ykoba                                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/ykoba/openSUSE_Leap_15.0/     |        
 5 | http-download.opensuse.org-3a11ff1b | KDE:KDE3                                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/KDE3/openSUSE_Leap_15.0/       |        
 6 | http-download.opensuse.org-587fba91 | home:Sauerland                              | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/Sauerland/openSUSE_Leap_15.0/ |        
 7 | http-download.opensuse.org-659768fb | home:bilson                                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/bilson/openSUSE_Leap_15.0/    |        
 8 | http-download.opensuse.org-abf4058b | home:medozas74                              | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/medozas74/openSUSE_Leap_15.0/ |        
 9 | http-download.opensuse.org-c47d8002 | openSUSE:Leap:42.3                          | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.3/repo/oss/                 |        
10 | http-download.opensuse.org-d7c097ef | network                                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/network/openSUSE_Leap_15.0/         |        
11 | http-download.opensuse.org-e470b3eb | KDE:Extra                                   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_Leap_15.0/      |        
12 | mozilla                             | Mozilla based projects (openSUSE_Leap_15.0) | Yes     | (r ) Yes  | No      |   99     | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_Leap_15.0/         |        
13 | openSUSE-Leap-15.0-1                | openSUSE-Leap-15.0-1                        | No      | ----      | ----    |   99     | rpm-md | cd:///?devices=/dev/disk/by-id/ata-HL-DT-ST_DVDRAM_GH40F_FB5019F34FC2         |        
14 | opensuse-guide.org-repo             | Libdvdcss Repository                        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_15.0/                            |        
15 | packman.inode.at-suse               | Packman Repository                          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_15.0/                              |        
16 | repo-debug                          | openSUSE-Leap-15.0-Debug                    | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.0/repo/oss/           |        
17 | repo-debug-non-oss                  | openSUSE-Leap-15.0-Debug-Non-Oss            | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.0/repo/non-oss/       |        
18 | repo-debug-update                   | openSUSE-Leap-15.0-Update-Debug             | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.0/oss/                      |        
19 | repo-debug-update-non-oss           | openSUSE-Leap-15.0-Update-Debug-Non-Oss     | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.0/non-oss/                  |        
20 | repo-non-oss                        | openSUSE-Leap-15.0-Non-Oss                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.0/repo/non-oss/             |        
21 | repo-oss                            | openSUSE-Leap-15.0-Oss                      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.0/repo/oss/                 |        
22 | repo-source                         | openSUSE-Leap-15.0-Source                   | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/15.0/repo/oss/          |        
23 | repo-source-non-oss                 | openSUSE-Leap-15.0-Source-Non-Oss           | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/15.0/repo/non-oss/      |        
24 | repo-update                         | openSUSE-Leap-15.0-Update                   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.0/oss/                            |        
25 | repo-update-non-oss                 | openSUSE-Leap-15.0-Update-Non-Oss           | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.0/non-oss/                        |        
crb999@linux-ox1l:~>
and

Code:
crb999@linux-ox1l:~> rpm -qa libproxy1
libproxy1-0.4.15-lp150.2.2.x86_64
crb999@linux-ox1l:~>
mrmazda, I'll try the deletes you suggest after I've posted this.
 
Old 01-30-2019, 07:00 AM   #10
Crb999
Member
 
Registered: Jan 2017
Location: West Coast Scotland
Distribution: Suse Linux 42.2
Posts: 183

Original Poster
Rep: Reputation: Disabled
Mrmazda, I don't have "icon*/k*/plasm*/q* " in either the /home/crb999/ or the /root/ directories.

But in both I have:

Code:
drwxr-xr-x 2 crb999 users       33 Jan 28 15:25 gstreamer-1.0
-rw-r--r-- 1 crb999 users 10547304 Jan 30 12:46 icon-cache.kcache
drwxr-xr-x 3 crb999 users       22 Jul 18  2018 kcmshell5
and in the /root/ example, it is bigger.
 
Old 01-30-2019, 07:58 AM   #11
petelq
Member
 
Registered: Aug 2008
Location: UK
Distribution: openSUSE(Leap and Tumbleweed) and a regularly changing third
Posts: 362

Rep: Reputation: Disabled
You obviously have all those additional repos for specific reasons but I think that is likely to be the source of your problem. Once you've loaded the odd package you want you should disable the extra repos until such time as you may need them again. I can't understand why you would still keep 42.3 when you have 15.
 
Old 01-30-2019, 10:38 AM   #12
Sauerland
Member
 
Registered: Jul 2017
Posts: 32

Rep: Reputation: Disabled
Please post:
Code:
zypper se -sir 9
To see, what is installed from the 42.3 Repo.
 
Old 01-30-2019, 10:39 AM   #13
Crb999
Member
 
Registered: Jan 2017
Location: West Coast Scotland
Distribution: Suse Linux 42.2
Posts: 183

Original Poster
Rep: Reputation: Disabled
Petelq, I have not specifically chosen those repos.

As I have tried to expand the range of operation I want to undertake, invariably, I have to search for, and try out, various applications.

I have been trusting of the system but clearly, something recent, has troubled my setup.

now, if I could establish the dates the repositories were added, I could work backwards, deleting them as I went but this is very new territory for me and I dread doing more damage than I may have already done.

It is not helpful, (for beginners), that the names of the repositories don't reflect in some way the software they are related to.

Perhaps that is available but currently, invisible to me.

I have now deleted the 43.2 repo but I wasnt aware that it had been added. I didn't do it on purpose, honest :-)

So I am going to use Yast to disable repositories that I believe have been added while I've been upgrading my capabilities, (mainly due to audio and video applications).
 
Old 01-30-2019, 10:48 AM   #14
Crb999
Member
 
Registered: Jan 2017
Location: West Coast Scotland
Distribution: Suse Linux 42.2
Posts: 183

Original Poster
Rep: Reputation: Disabled
Petelq, I forgot to mention that zypper is working.

What is 'libproxy.so'? How can I check, replace or repair it?

I've checked this, is it useful?

Code:
crb999@linux-ox1l:~> ls -l /etc/zypp/repos.d/
total 96
-rw-r--r-- 1 root root 169 Jan 30 16:41 download.nvidia.com-leap.repo
-rw-r--r-- 1 root root 196 Jan 30 16:41 download.opensuse.org-oss_1.repo
-rw-r--r-- 1 root root 181 Jan 30 16:41 download.opensuse.org-oss.repo
-rw-r--r-- 1 root root 187 Jan 30 16:41 http-download.opensuse.org-2de603a2.repo
-rw-r--r-- 1 root root 183 Jan 30 16:41 http-download.opensuse.org-3a11ff1b.repo
-rw-r--r-- 1 root root 195 Jan 30 16:41 http-download.opensuse.org-587fba91.repo
-rw-r--r-- 1 root root 189 Jan 30 16:41 http-download.opensuse.org-659768fb.repo
-rw-r--r-- 1 root root 195 Jan 30 16:41 http-download.opensuse.org-abf4058b.repo
-rw-r--r-- 1 root root 180 Jan 30 16:41 http-download.opensuse.org-d7c097ef.repo
-rw-r--r-- 1 root root 185 Jan 30 16:41 http-download.opensuse.org-e470b3eb.repo
-rw-r--r-- 1 root root 299 Jan 30 16:41 mozilla.repo
-rw-r--r-- 1 root root 169 Jan 30 16:41 opensuse-guide.org-repo.repo
-rw-r--r-- 1 root root 185 Jan 30 16:41 openSUSE-Leap-15.0-1.repo
-rw-r--r-- 1 root root 163 Jan 30 16:41 packman.inode.at-suse.repo
-rw-r--r-- 1 root root 195 Jan 30 16:41 repo-debug-non-oss.repo
-rw-r--r-- 1 root root 175 Jan 30 16:41 repo-debug.repo
-rw-r--r-- 1 root root 198 Jan 30 16:41 repo-debug-update-non-oss.repo
-rw-r--r-- 1 root root 178 Jan 30 16:41 repo-debug-update.repo
-rw-r--r-- 1 root root 179 Jan 30 16:41 repo-non-oss.repo
-rw-r--r-- 1 root root 167 Jan 30 16:41 repo-oss.repo
-rw-r--r-- 1 root root 198 Jan 30 16:41 repo-source-non-oss.repo
-rw-r--r-- 1 root root 178 Jan 30 16:41 repo-source.repo
-rw-r--r-- 1 root root 182 Jan 30 16:41 repo-update-non-oss.repo
-rw-r--r-- 1 root root 162 Jan 30 16:41 repo-update.repo
crb999@linux-ox1l:~>
 
Old 01-30-2019, 11:31 AM   #15
mrmazda
Senior Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE, Debian, Knoppix, Mageia, Fedora, others
Posts: 1,192

Rep: Reputation: 354Reputation: 354Reputation: 354Reputation: 354
Quote:
Originally Posted by Crb999 View Post
I don't have "icon*/k*/plasm*/q* " in either the /home/crb999/ or the /root/ directories.
Oh, but you do have icon* and k*.

Quote:
But in both I have:

Code:
drwxr-xr-x 2 crb999 users       33 Jan 28 15:25 gstreamer-1.0
-rw-r--r-- 1 crb999 users 10547304 Jan 30 12:46 icon-cache.kcache
drwxr-xr-x 3 crb999 users       22 Jul 18  2018 kcmshell5
and in the /root/ example, it is bigger.
Unless they have already been deleted, I don't know why you don't have others like I do:
Code:
15.0:
> inxi -Gxxb
System:    Host: gx780 Kernel: 4.12.14-lp150.12.25-default x86_64 bits: 64 compiler: gcc v: 7.3.1 Desktop: Trinity R14.0.5
           tk: Qt 3.5.0 wm: Twin dm: TDM Distro: openSUSE Leap 15.0
Machine:   Type: Desktop System: Dell product: OptiPlex 780 v: N/A serial: F23NBM1 Chassis: type: 15 serial: F23NBM1
           Mobo: Dell model: 03NVJ6 v: A01 serial: ..CN7360402902O7. BIOS: Dell v: A15 date: 08/06/2013
CPU:       Dual Core: Intel Core2 Duo E8400 type: MCP arch: Penryn speed: 1995 MHz min/max: 2000/3000 MHz
Graphics:  Device-1: Intel 4 Series Integrated Graphics vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:2e12
           Display: server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa alternate: intel resolution: 1920x1200~60Hz
           OpenGL: renderer: Mesa DRI Intel Q45/Q43 v: 2.1 Mesa 18.0.2 direct render: Yes
Network:   Device-1: Intel 82567LM-3 Gigabit Network vendor: Dell driver: e1000e v: 3.2.6-k port: ece0 bus ID: 00:19.0
           chip ID: 8086:10de
Drives:    Local Storage: total: 698.64 GiB used: 126.15 GiB (18.1%)
Info:      Processes: 177 Uptime: N/A Memory: 7.62 GiB used: 310.3 MiB (4.0%) Init: systemd v: 234 runlevel: 5
           target: runlevel3.target Compilers: gcc: N/A Shell: bash v: 4.4.23 running in: konsole inxi: 3.0.30

TW:
.cache> ls -Gg
-rw-rw-r--   1 10547304 Jan  3 15:01 icon-cache.kcache
drwxrwxr-x   3     4096 Dec  8  2017 konsole
-rw-rw-r--   1  1016919 Dec  9 01:57 ksycoca5_en_ZO9BCAqxRsYOeb+jgSNOcFvO9+Y=
drwx------   3     4096 Jan 29 22:58 mc
drwxr-xr-x 134     4096 Dec  9 01:58 mesa_shader_cache
drwx------   3     4096 Aug  3 11:25 mozilla
-rw-------   1     9119 Jan  3 15:01 plasma-svgelements-air_v1.3
-rw-rw-r--   1 16875624 Jan  3 15:01 plasma_theme_air_v1.3.kcache
-rw-rw-r--   1   165196 Dec  9 01:58 qt_compose_cache_little_endian_03d5f45da2504a81a9dbf4eda64d8078
drwxrwxr-x   2     4096 Dec  9 01:58 qtshadercache
drwxrwxr-x   3     4096 Jul 15  2018 systemsettings
drwxrwxr-x   3     4096 Jul 15  2018 thumbnails
Note I have TW and 15.0 among others on this Optiplex 780, but Plasma only on TW.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Long lag between clicking the Application Launcher icon and the launcher appearing in KDE alex14641 Slackware 2 03-28-2016 05:36 PM
[SOLVED] firefox launcher doesn't show icon on panel bar of slackware but launcher still there mshlinux Linux - Newbie 6 04-24-2013 10:56 PM
Launcher Problems! Why is there a line through my icons on my launcher? LinuxNoob12 Linux - Newbie 1 10-26-2012 01:37 AM
LXer: Move unity launcher to the bottom with Unity Bottom Launcher | PPA Ubuntu LXer Syndicated Linux News 0 12-19-2011 12:30 AM
Creating a launcher (could be java launcher) The_Messiah Linux - Newbie 12 04-06-2005 01:36 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 08:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration