Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
SUSE / openSUSE This Forum is for the discussion of Suse Linux.


  Search this Thread
Old 05-01-2006, 09:41 AM   #1
LQ Newbie
Registered: Jan 2004
Distribution: Fedora Core 1
Posts: 5

Rep: Reputation: 0
Intel Pro/Wireless 3945


I've got SuSe 10.1 RC2 installed on a Dell Latitude D620. I'm having wireless problems. Yast lists the Intel Pro/Wireless 3945 and it's configured to start on boot and use DHCP. The SSID is set to ANY. I can't seem to bring up the interface. I've tried a number of things but I get errors like "configuration file not found". There is an ifcfg-wireless-pciXXX file. What am I missing?

Old 05-01-2006, 11:21 AM   #2
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Rep: Reputation: 30
If you do and ifconfig do you see it listed?
Old 05-05-2006, 11:22 AM   #3
LQ Newbie
Registered: Jan 2004
Distribution: Fedora Core 1
Posts: 5

Original Poster
Rep: Reputation: 0
No, just the wired and loopback.
Old 05-09-2006, 03:07 PM   #4
Registered: Nov 2004
Distribution: Red Hat Version 9 / Attempting to use Gentoo
Posts: 48

Rep: Reputation: 15
I have the same problem running Ubuntu on a Del lattitude 410. Same wireless built in but Linux does not recognize it.
Old 05-09-2006, 11:20 PM   #5
Senior Member
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
Maybe the card isn't supported. Have you tried using NDISWRAPPER with the Windows driver?

Side question, but what kind of video card do you have on your D620? is it the basic Intel i945 graphics card? Did you manage to get it to go to 1400x990? I am using VESA and it won't go to 1400x900.
Old 05-10-2006, 06:57 PM   #6
Registered: Jul 2004
Location: Los Angeles (the Great Cultural Wasteland)
Distribution: SuSe 10.2
Posts: 151

Rep: Reputation: 30
try installing the driver at i'm just about to myself.
Old 05-17-2006, 01:50 AM   #7
Registered: Jun 2004
Location: Nova Scotia, Canada!
Distribution: Ubuntu
Posts: 170

Rep: Reputation: 30
Anyone have any luck with this card? Intel says its supported and has drivers, but my kernel (2.6.12) doesn't even recognize it:

From lspci:

Intel Corp.: Unknown device 4222 (rev 02)

I've tried the instuctions off the Intel site, but when I get to the load stage, the device can never be found.

Anyone got this working? I'd hate to take my shiny new Dell 9400 back...

Old 05-18-2006, 12:40 AM   #8
Registered: Jul 2004
Location: Los Angeles (the Great Cultural Wasteland)
Distribution: SuSe 10.2
Posts: 151

Rep: Reputation: 30
suse 10.1 detected the device no problem.

Love the new KnetworkManagemer too. I was a little supprized, even the light on the keyboard works. I just got a new model 17" hp with a lot of 'new' hardware..only need to work on ACPI.
Old 05-18-2006, 09:40 AM   #9
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Rep: Reputation: 30
Have you installed the ipw3945d Daemon?
Old 05-20-2006, 07:37 PM   #10
LQ Newbie
Registered: Mar 2004
Posts: 1

Rep: Reputation: 0
I have the exact same problem on my new Sony Vaio sz140P .. SuSE 10.1 detects the wireless card fine and seems to be loading the kernel module but ifconfig does not list it. 'iwconfig' says I've no wireless device on my system and when I try to edit the config for kwifimanager, it says it could not find a device.

I remember trying ndiswrapper with SuSE 10 and it did not work either. Anyone have any luck with ndiswrapper ?
Old 05-23-2006, 03:14 AM   #11
Registered: Aug 2004
Location: Wales
Distribution: Kubuntu, Mageia, OpenSUSE
Posts: 100

Rep: Reputation: 29
Have you installed ipw-firmware (from the add on CD)?
Old 05-25-2006, 07:29 AM   #12
LQ Newbie
Registered: May 2006
Posts: 1

Rep: Reputation: 0
I have a Intel PRO/Wireless 3945ABG, in my pc with SuSe 10.1.

with Yast find then:

Dispositivos de red: Intel PRO/Wireless 3945ABG
Nome dispositivo: Wlan_bus_pci_0000:05:00.0
Nome Configuracion: wlan_bus_pci_0000:05:00.0
Nome Hardware:bus_pci_0000:05:00.0
Nome Modulo: ipw3945

If i execute the comand ifconfig:


If i execute the comand iwconfig:

lo no wireless extensions
eth0 no wireless extensions
sit0 no wireless extensions

how can i do to run this target.

my english is very bado, sorry
Old 07-02-2006, 07:18 AM   #13
LQ Newbie
Registered: Jun 2006
Posts: 3

Rep: Reputation: 0
I have same problem with Inspiron E1705 - help


I have

vr ~ # lspci | grep ireless
0c:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)

It seems like the hardware is detected. However

vr ~ # iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

I am using gentoo running kernel 2.6.17.

what will be the next step in configuring the wireless network connection?

Thank you vey much

Old 07-03-2006, 04:30 AM   #14
Registered: Feb 2004
Location: 'Ol Blighty
Distribution: SLED 10, SUSE 10.3
Posts: 722

Rep: Reputation: 32
I had similar - but now fixed. For some reason ACPI seemed to hose up something.
Try starting your pc with ACPI=OFF at boot.

Don't ask me why but this fixed my wireless problem.

With ACPI=OFF my wireless was detected and I could configure the interface.

The possible downside of this of course is when you shut down your machine you'll at the end of the shutdown sequence probably have to switch your machine off manually.


Old 07-03-2006, 04:31 AM   #15
LQ Newbie
Registered: Jun 2006
Posts: 3

Rep: Reputation: 0
Configure wireless on Dell E1705 with Intel Corporation PRO/Wireless 3945ABG Network

Even if lspci found the device and iwconfig did not, then the hardware driver is not installed properly. Do the following to install driver

# emerge ieee80211 ipw3945 ipw3945d wireless-tools

that will install driver for the wireless device Intel Corporation PRO/Wireless 3945ABG Network. However, you will need to recompile the kernel to suit the requirment. Look at the complain during the installation of the ieee80211 ebuild. You will need to disable and enable something, namely the portion associated with the tag CONFIG_IEEE80211 (under networking) need to be no, and for flag CONFIG_NET_RADIO, you need to build that into the kernel (I did, you can try as module). CONFIG_NET_RADIO is embedded in Device Drivers -> Network Device Support -> Wireless LAN (non-hamradio)

If everything goes fine with the emerge, then when you do a iwconfig, you will find eth1 given eth0 is your wired network. Only when iwconfig shows the wireless network, you are in business to configure. I believe other distribution users can download ipw3945 and compile the driver yourself with a little more work - I welcome you to drop me a line at to share your experience.

The following website has most of the information I used during my exploration process

(do a google search on that since I am not allow to post the link yet)

Then, in /etc/conf.d/net file add in the following lines

config_eth1=( "dhcp" )
dhcp_eth1="nodns nontp nonis"

given eth1 is the wireless device reported by iwconfig. My iwconfig shows

vr conf.d # iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11g ESSID:"yournetworkname" Nickname:"yournetworkname"
Mode:Managed Frequency:2.412 GHz Access Point: 00:60:B3:F3:18:27
Bit Rate:48 Mb/s Tx-Power:15 dBm
Retry limit:15 RTS thrff Fragment thrff
Encryption keyff
Power Managementff
Link Quality=65/100 Signal level=-67 dBm Noise level=-69 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:1200 Missed beacon:0

Then, in directory /etc/init.d directory, create another link to point net.lo to net.eth1 just like you did for net.eth0

The emerge process for the wireless-tools will also put a wireless config file at /etc/conf.d/wireless.example

You can edit the file to specify the needed information for your wireless network. The second link above will tell you all you need to know on this.

If you are generous and did not set a key to access you wireless resources, then you basically just copy wireless.example file to /etc/conf.d/example with all the line commented out. Maybe you also don't need it but I have not tried it.

Then, you need to turn off the wired interface using the command

#/etc/init.d/net.eth0 down

then unplug the network wire from the notebook before you turn on the wireless interface at eth1 by

# /etc/init.d/net.eth1 start

You are online...... wirelessly..... that simple......

Do not get fooled with lspci report!! - like I did..... confused me for a day or two....


Last edited by simonmssu; 07-03-2006 at 04:36 AM.


setup, wireless

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot get Intel 3945 to work with ndiswrapper on Debian 3.1r1 eljofi Linux - Laptop and Netbook 2 06-22-2006 05:51 AM
intel wireless pro 2200 detected as atheros wireless card? whf SUSE / openSUSE 5 08-29-2005 06:04 PM
connecting to the internet via wireless through Intel PRo/Wireless LAN 2100 3B Mini P k_wjss Linux - Newbie 1 09-28-2004 05:00 PM
FC2 not recognizing the Intel PRO/Wireless 2200BG wireless card mdslf Linux - Laptop and Netbook 2 08-24-2004 02:25 AM
Wireless intel PRO/Wireless 2100 802.11b WLAN gummimann Linux - Hardware 0 03-01-2004 04:20 PM > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 06:36 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration