LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   SUSE / openSUSE (https://www.linuxquestions.org/questions/suse-opensuse-60/)
-   -   Intel Pro/Wireless 3945 (https://www.linuxquestions.org/questions/suse-opensuse-60/intel-pro-wireless-3945-a-440538/)

mwarbeck 05-01-2006 09:41 AM

Intel Pro/Wireless 3945
 
Hi,

I've got SuSe 10.1 RC2 installed on a Dell Latitude D620. I'm having wireless problems. Yast lists the Intel Pro/Wireless 3945 and it's configured to start on boot and use DHCP. The SSID is set to ANY. I can't seem to bring up the interface. I've tried a number of things but I get errors like "configuration file not found". There is an ifcfg-wireless-pciXXX file. What am I missing?

Thanks

EclipseAgent 05-01-2006 11:21 AM

If you do and ifconfig do you see it listed?

mwarbeck 05-05-2006 11:22 AM

No, just the wired and loopback.

blazted 05-09-2006 03:07 PM

I have the same problem running Ubuntu on a Del lattitude 410. Same wireless built in but Linux does not recognize it.

Micro420 05-09-2006 11:20 PM

Maybe the card isn't supported. Have you tried using NDISWRAPPER with the Windows driver?

Side question, but what kind of video card do you have on your D620? is it the basic Intel i945 graphics card? Did you manage to get it to go to 1400x990? I am using VESA and it won't go to 1400x900.

osbie 05-10-2006 06:57 PM

try installing the driver at intel.com. i'm just about to myself.

jonwatson 05-17-2006 01:50 AM

Anyone have any luck with this card? Intel says its supported and has drivers, but my kernel (2.6.12) doesn't even recognize it:

From lspci:

Intel Corp.: Unknown device 4222 (rev 02)

I've tried the instuctions off the Intel site, but when I get to the load stage, the device can never be found.

Anyone got this working? I'd hate to take my shiny new Dell 9400 back...

Thanks

osbie 05-18-2006 12:40 AM

suse 10.1 detected the device no problem.

Love the new KnetworkManagemer too. I was a little supprized, even the light on the keyboard works. I just got a new model 17" hp with a lot of 'new' hardware..only need to work on ACPI.

EclipseAgent 05-18-2006 09:40 AM

Have you installed the ipw3945d Daemon?

rajvikram 05-20-2006 07:37 PM

I have the exact same problem on my new Sony Vaio sz140P .. SuSE 10.1 detects the wireless card fine and seems to be loading the kernel module but ifconfig does not list it. 'iwconfig' says I've no wireless device on my system and when I try to edit the config for kwifimanager, it says it could not find a device.

I remember trying ndiswrapper with SuSE 10 and it did not work either. Anyone have any luck with ndiswrapper ?

john2 05-23-2006 03:14 AM

Have you installed ipw-firmware (from the add on CD)?

acrego 05-25-2006 07:29 AM

I have a Intel PRO/Wireless 3945ABG, in my pc with SuSe 10.1.

with Yast find then:

Dispositivos de red: Intel PRO/Wireless 3945ABG
Nome dispositivo: Wlan_bus_pci_0000:05:00.0
Nome Configuracion: wlan_bus_pci_0000:05:00.0
Nome Hardware:bus_pci_0000:05:00.0
Nome Modulo: ipw3945


If i execute the comand ifconfig:


eth0:
l0
sit0

If i execute the comand iwconfig:

lo no wireless extensions
eth0 no wireless extensions
sit0 no wireless extensions


how can i do to run this target.

thanks
my english is very bado, sorry

simonmssu 07-02-2006 07:18 AM

I have same problem with Inspiron E1705 - help
 
Hello,

I have

vr ~ # lspci | grep ireless
0c:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)

It seems like the hardware is detected. However

vr ~ # iwconfig
lo no wireless extensions.

eth0 no wireless extensions.


I am using gentoo running kernel 2.6.17.


what will be the next step in configuring the wireless network connection?

Thank you vey much

Simon

1kyle 07-03-2006 04:30 AM

I had similar - but now fixed. For some reason ACPI seemed to hose up something.
Try starting your pc with ACPI=OFF at boot.

Don't ask me why but this fixed my wireless problem.

With ACPI=OFF my wireless was detected and I could configure the interface.


The possible downside of this of course is when you shut down your machine you'll at the end of the shutdown sequence probably have to switch your machine off manually.

Cheers

-K

simonmssu 07-03-2006 04:31 AM

Configure wireless on Dell E1705 with Intel Corporation PRO/Wireless 3945ABG Network
 
Even if lspci found the device and iwconfig did not, then the hardware driver is not installed properly. Do the following to install driver

# emerge ieee80211 ipw3945 ipw3945d wireless-tools

that will install driver for the wireless device Intel Corporation PRO/Wireless 3945ABG Network. However, you will need to recompile the kernel to suit the requirment. Look at the complain during the installation of the ieee80211 ebuild. You will need to disable and enable something, namely the portion associated with the tag CONFIG_IEEE80211 (under networking) need to be no, and for flag CONFIG_NET_RADIO, you need to build that into the kernel (I did, you can try as module). CONFIG_NET_RADIO is embedded in Device Drivers -> Network Device Support -> Wireless LAN (non-hamradio)

If everything goes fine with the emerge, then when you do a iwconfig, you will find eth1 given eth0 is your wired network. Only when iwconfig shows the wireless network, you are in business to configure. I believe other distribution users can download ipw3945 and compile the driver yourself with a little more work - I welcome you to drop me a line at simonmssu@gmail.com to share your experience.

The following website has most of the information I used during my exploration process
h_t_t_p_:_/_/_buzzy_._tesuji_._org_/_thinkpad_t60p.html_
h_t_t_p_:_/_/_www_._gentoo-wiki_._com_/_HOWTO_Wireless_Configuration_and_Startup

(do a google search on that since I am not allow to post the link yet)

Then, in /etc/conf.d/net file add in the following lines

config_eth1=( "dhcp" )
dhcp_eth1="nodns nontp nonis"

given eth1 is the wireless device reported by iwconfig. My iwconfig shows

vr conf.d # iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11g ESSID:"yournetworkname" Nickname:"yournetworkname"
Mode:Managed Frequency:2.412 GHz Access Point: 00:60:B3:F3:18:27
Bit Rate:48 Mb/s Tx-Power:15 dBm
Retry limit:15 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=65/100 Signal level=-67 dBm Noise level=-69 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:1200 Missed beacon:0


Then, in directory /etc/init.d directory, create another link to point net.lo to net.eth1 just like you did for net.eth0

The emerge process for the wireless-tools will also put a wireless config file at /etc/conf.d/wireless.example

You can edit the file to specify the needed information for your wireless network. The second link above will tell you all you need to know on this.

If you are generous and did not set a key to access you wireless resources, then you basically just copy wireless.example file to /etc/conf.d/example with all the line commented out. Maybe you also don't need it but I have not tried it.

Then, you need to turn off the wired interface using the command

#/etc/init.d/net.eth0 down

then unplug the network wire from the notebook before you turn on the wireless interface at eth1 by

# /etc/init.d/net.eth1 start

You are online...... wirelessly..... that simple......

Do not get fooled with lspci report!! - like I did..... confused me for a day or two....

Cheers


All times are GMT -5. The time now is 08:28 AM.