-   SUSE / openSUSE (
-   -   Intel 855 GM, i810, 3D acceleration? (

Enil8 03-25-2007 07:48 PM

Intel 855 GM, i810, 3D acceleration?
I was thinking about trying Beryl on my openSUSE 10.2 laptop by following this, but I ran into a problem when I was about to set it up. The setup would be easy, but when I get to the stop to make sure that I have 3D acceleration checked in, but the box is not checkable and when I go to my system information, it says that 3D acceleration is not supported. Am I mistaken? Is it just the driver that doesn't have it supported? Or what can I do to set this up correctly? Thanks so much for your help!

cormack 03-27-2007 04:23 PM

The driver comes in the latest kernel, i think, if not in latest Xorg. cant remeber which one. But if you a pretty up to date versoin of both of these, then in sax, in order to get 3d acceleration on intel cards, you need to change the colour to 16 bit. It doesnt realy make much difference to the user, as i doubt any person could see the differences between even 16bit colours, let alone if it is even possible. But hopefully once you have done that, you should have 3d accel in no time.
I tried beryl on my i845 pc intel chip... :(, hope you have better luck. I didnt realy try much though got a new mobo for my nvidia card. :D

Good luck


Enil8 03-27-2007 08:03 PM

Thanks for the help! Unfortunately, it still doesn't work. I changed it to 16 bit color and I know I have the latest kernel and Xorg 7.3, but when I try to load Sax2 it still tells me that 3D acceleration cannot be enabled because my card/driver does not support it. :(

Is there a way I can find out what version of the i810 driver I have? Or does anyone know of a good tutorial or can describe an easy way to upgrade my driver?

SkippyBoy 03-28-2007 08:12 AM

I was able to get compiz running on my laptop with the i855 chipset, but it was not fun. It could be that I have a Celeron processor that just doesnt have enough power... The effects really slowed down the system, so I went back to my old setup.

Sorry I can't remember which tutorial I used.

Enil8 03-28-2007 08:15 AM

So at least I know that it's possible. I think the problem is with my current driver. I've looked around, but I can't even find a place to download the driver. I must be looking in all the wrong places or something. If you remember what tutorial it was, please post back :)

SkippyBoy 03-29-2007 08:53 AM

Sorry Enil8 - I can't find the tutorial now. Like I said - it involved some jumping through hoops, and when it was set up - it really didn't look good on my laptop.

Enil8 03-29-2007 04:58 PM

Maybe it's just a lost cause. I think I'll just give up on it, haha. Maybe if I get a new computer in a few months I'll try again. Thanks for the help guys!

bluecog6 04-15-2007 03:10 PM

had the same issue
my computer has a celeron processor and the i845 chipset, with the i810 driver

i got the same message when i went to enable the 3d acceleration - found something that told me i could double-click the [greyed-out] enable radio button, and that would override the support-checking mechanism. i did that, and when i set xgl as my window manager, i got a black screen at the login, so i had to change /etc/sysconfig back to xorg from command line. i wasn't thrilled about that, but it gave me some more linux experience (and i fixed it), so i couldn't be too mad.

a couple weeks later, i was messing around in YaST, and clicked on 'hardware', and 'graphics card and monitor', and saw that my monitor setup was not correct. when i installed SuSE, it apparently auto-selected some generic settings for me. when i changed that, i was able to enable 3d acceleration from YaST. i changed the window manager back to xgl, and it worked!!! albeit a little slow, but it worked. i did not have to update my driver at all. i only discovered later that it was using the i810 driver. before, when i accessed 'my computer' it told me "unknown" for the vendor, model and driver; since the settings change in YaST, it shows intel, i845, and i810, respectively.

i ended up changing back to xorg though b/c my wife didn't like the desktop effects... :)

maybe that might help you

Tonykk 11-06-2007 03:32 PM

This few commands might help
Hi all,
I am using Intel 82852/855GM chipset too.
I had been trying to get opengl hardware acceleration to work for the last month.
My project still doesn't run smoothly, don't know if it's because the card simply is not fast enough for it or I didn't set it up properly

I found These few commands helpful
To find out which driver you are using and version of it:
#dpkg -l | grep intel

I am not sure why but the chipset seems to need intel i915 module(you might need to recompile kernel to get it) to enable DRI.

Hope they help,

All times are GMT -5. The time now is 06:31 PM.