LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   SUSE / openSUSE (https://www.linuxquestions.org/questions/suse-opensuse-60/)
-   -   Installing sane scanner software (https://www.linuxquestions.org/questions/suse-opensuse-60/installing-sane-scanner-software-324606/)

JeTa 05-18-2005 01:47 AM

Installing sane scanner software
 
Hi there

I am trying to install Sane on SUSE 9.2. Apparently this supports my Optipro 4800p

I have downloaded and unpacked:
sane-backends-1.0.14.tar.gz sane-frontends-1.0.12.tar.gz xsane-0.93.tar.gz

I did
./configure
make
make install
with backends as in manual.

When I then try to install the frontends and do ./configure it tells me
checking for SANE - version >= 1.0.0... no
*** The sane-config script installed by SANE could not be found
*** If SANE was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the SANE_CONFIG environment variable to the
*** full path to sane-config.
**********************************************************************
ERROR: Couldn't find SANE libraries (sane-backends). Possible reasons:
- sane-backends isn't installed (install sane-backends before
sane-frontends
- the SANE header files aren't installed (if you installed
SANE as RPM make sure you also included the sane-devel RPM)
- the SANE libraries can't be found because /usr/local/lib/ isn't
searched by the dynamic linker (see INSTALL for details)
**********************************************************************

I have checked my file /etc/ld.so.conf.
It includes /usr/local/lib. Then I have done "ldconfig".
Same error message as above.

I have also tried
export LD_LIBRARY_PATH=/usr/local/lib/
./configure

and
./configure --prefix=/usr/local/lib

Also sane_config is in /usr/local/bin

Anyone any ideas?

Thanks

JeTa

abisko00 05-18-2005 09:24 AM

Before you try compiling sane yourself, I suggest to try the rpm from packman (0.1.15). Have a look at the sticky thread about YaST update sources on how to use packman as a YaST source.

Mikech 03-28-2006 06:18 PM

Sticky Thread
 
Whats a sticky thread?

abisko00 03-29-2006 01:25 AM

Sticky threads are threads that are always on top in the forum view. Makes them easier to find.


All times are GMT -5. The time now is 09:42 AM.