LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   SUSE / openSUSE (https://www.linuxquestions.org/questions/suse-opensuse-60/)
-   -   installing Flash Player 10.0 on Open Suse 10.3 (https://www.linuxquestions.org/questions/suse-opensuse-60/installing-flash-player-10-0-on-open-suse-10-3-a-837249/)

Sam French 10-10-2010 02:23 PM

installing Flash Player 10.0 on Open Suse 10.3
 
Hey guys sorry for such a noob question. My yast crashes just as soon as started installing flash.

Do have flash saved as .tar.gz on desktop.

What is the easiest way to install it? Also searched in Tutorials.

Just patching as I go untill I build a new PC.

Thank You

Sam

yancek 10-10-2010 07:29 PM

Click the Suse icon Kmenu in the Taskbar, got to Computer then click nstall Software, and in Search box enter: flash-player
Need the dash between flash and player

Put a check mark in the box to the left of flash-player to install:
Click Accept at bottom right and follow prompts.

Open firefox, type about:plugins in firefox address box and icheck to see if Flashplayer showed up as a plugin.
This next step may not be necessary, so probably only use it if it doesn't initially work: In Firefox, open Edit, Preferences, Applications and go down to Shockwave Flash File, to the right of
this, select Use Shockwave Flash (in Firefox) drop down arrow with several choices.

Test sound. If it doesn't work, right click on the sound icon in the Sytem Tray, click Show Mixer Window and moved the PCM
slider up.

If Gnash is installed, it may conflict with flash-player so uninstall it if it is installed.

Not sure which Opensuse you are using, I did this in 11.2.

Sam French 10-13-2010 08:34 AM

Can I install flash from the console? Or is Flash 10.0 not compatable with
Open Suse 10.3?

Thank You
Sam

yancek 10-13-2010 10:06 AM

The link below states this method should be successful on 10.3. This is the method I tried first on Opensuse 11.2 and it did not work. Could try it on 10.3:

http://www.susegeek.com/multimedia/i...pensuse-linux/

dth1 10-16-2010 06:52 PM

10.3 is so old now that it isn't supported anymore

you can try the downloading the rpm from the repo for 11.0 at:-

http://download.opensuse.org/update/11.0/rpm/i586/

just save the file to your desktop and then click on it and select the install with yast option

Sam French 10-17-2010 04:41 PM

Thank You
I downloaded the file. Tried installing via Yast. It said 10.3 needed 40MB in updates. Skipped that. Crashed on install.

I got it downloaded on my desktop as a tar.gz. Trying to figure the Konsole commands to install it.

Thanks again

Sam

yancek 10-17-2010 08:03 PM

If you have the tar.gz file downloaded to your Desktop, you need to make sure you change directories to the Desktop directory before running any commands. If that isn't the problem, I don't know what to suggest. The method in the link I posted above is the only one I've used to install flash from konsole and it has worked on earlier versions of Suse for me. As I stated above, this method didn't work for me on Opensuse 11.2 for some reason.

dth1 10-19-2010 07:01 AM

1. start a Terminal (ALT + F2)

2. type

su

and add your root password

3. type

cd /home/xxxxx/Desktop

NB - 'xxxxx' this means your user name not xxxxx

4. Unpack it here - /usr/lib/browser-plugins with:

tar -xf flashplayer*.tar.gz -C /usr/lib/browser-plugins

5. restart any browser

Sam French 11-01-2010 11:33 AM

Hey dth1 I followed your instructions. Though I am scared of wildcards so this is what I did. I do have libflashplayer.so on my desktop.

Started terminal tried to copy libflashplayer.so to /usr/lib/browser-plugins Wouldn't let me do it.
Logged in as root did a mv of libflashplayer.so /usr/lib/browser-plugins

Closed all open browers and reopened and did not work.

Then rm of libflashplayer.so /usr/lib/browser-plugins
executed the mv liblfashplayer.so /usr/lib/browser-plugins.
closed all browsers and did a reboot.

Still did not work and here is my terminal screen.
sam@linux-kzhj:~> cd /usr/lib/browser/plugins
bash: cd: /usr/lib/browser/plugins: No such file or directory
sam@linux-kzhj:~> cd /usr/lib/browser-plugins
sam@linux-kzhj:/usr/lib/browser-plugins> ls
javaplugin.so libflashplayer.so nphelix.so nphelix.xpt
sam@linux-kzhj:/usr/lib/browser-plugins> libflashplayer.so
Segmentation fault
sam@linux-kzhj:/usr/lib/browser-plugins> ls libflashplayer.so
libflashplayer.so
sam@linux-kzhj:/usr/lib/browser-plugins> cksum libflashplayer.so
2741030277 11951040 libflashplayer.so

I am using two browsers opera and firefox seems both have lost flahsplayer. Going to do some more homework.

Thank You
Sam

Sam French 11-01-2010 03:29 PM

Just looking some stuff up and found where the libflashplayer.so for Opera is.
My terminal screen:
sam@linux-kzhj:~> cd /usr/lib/opera/plugins
sam@linux-kzhj:/usr/lib/opera/plugins> ls
libflashplayer.so README <libflashplayer.so is aqua green
sam@linux-kzhj:/usr/lib/opera/plugins> cksum libflashplayer.so
2809408590 10291000 libflashplayer.so
sam@linux-kzhj:/usr/lib/opera/plugins> cd /usr/lib/browser-plugins
sam@linux-kzhj:/usr/lib/browser-plugins> ls
javaplugin.so libflashplayer.so nphelix.so nphelix.xpt <libflashplayer.so < is green
sam@linux-kzhj:/usr/lib/browser-plugins> cksum libflashplayer.so
2741030277 11951040 libflashplayer.so
sam@linux-kzhj:/usr/lib/browser-plugins


As it stands now. Opera and Firefox are using different libflashplayer.so's
Should I do this?
log in terminal as root mv libflashplayer.so from desktop to
/usr/lib/opera/plugins
Should I remove existing libflashplayer.so before moving file from deskop?
That way both browsers are using same file.

Thank You
Sam

Sam French 11-01-2010 07:22 PM

I have found 3 locations of libflashplayer.so
sam@linux-kzhj:/usr/lib/opera/plugins> cd /usr/lib/opera/plugins
sam@linux-kzhj:/usr/lib/opera/plugins> ls
libflashplayer.so README
sam@linux-kzhj:/usr/lib/opera/plugins> cksum libflashplaer.so
cksum: libflashplaer.so: No such file or directory
sam@linux-kzhj:/usr/lib/opera/plugins> cksum libflashplayer.so
2741030277 11951040 libflashplayer.so
sam@linux-kzhj:/usr/lib/opera/plugins> cd /usr/lib/flash-plugin
sam@linux-kzhj:/usr/lib/flash-plugin> ls
homecleanup libflashplayer.so LICENSE README setup
sam@linux-kzhj:/usr/lib/flash-plugin> cksum libflashplayer.so
2741030277 11951040 libflashplayer.so
sam@linux-kzhj:/usr/lib/flash-plugin> cd /usr/lib/browser-plugins
sam@linux-kzhj:/usr/lib/browser-plugins> ls
javaplugin.so libflashplayer.so nphelix.so nphelix.xpt
sam@linux-kzhj:/usr/lib/browser-plugins> cksum libflashplayer.so
2741030277 11951040 libflashplayer.so
sam@linux-kzhj:/usr/lib/browser-plugins> cd /usr/lib64/browser-plugins
sam@linux-kzhj:/usr/lib64/browser-plugins> ls
npwrapper.libflashplayer.so npwrapper.nphelix.so npwrapper.so
sam@linux-kzhj:/usr/lib64/browser-plugins> cksum libflashplayer.so
cksum: libflashplayer.so: No such file or directory
sam@linux-kzhj:/usr/lib64/browser-plugins> cksum libflashplayer.so
cksum: libflashplayer.so: No such file or directory
sam@linux-kzhj:/usr/lib64/browser-plugins> su
Password:
linux-kzhj:/usr/lib64/browser-plugins # ls
npwrapper.libflashplayer.so npwrapper.nphelix.so npwrapper.so
linux-kzhj:/usr/lib64/browser-plugins # cksum libflashplayer.so
cksum: libflashplayer.so: No such file or directory
linux-kzhj:/usr/lib64/browser-plugins # rm libflashplayer.so
rm: cannot remove `libflashplayer.so': No such file or directory
linux-kzhj:/usr/lib64/browser-plugins # exit
exit
sam@linux-kzhj:/usr/lib64/browser-plugins> cd libflashplayer.so
bash: cd: libflashplayer.so: No such file or directory
sam@linux-kzhj:/usr/lib64/browser-plugins> cd npwrapper.so
bash: cd: npwrapper.so: Not a directory
sam@linux-kzhj:/usr/lib64/browser-plugins> cd nephelix.so
bash: cd: nephelix.so: No such file or directory
sam@linux-kzhj:/usr/lib64/browser-plugins> ls -l
total 152
-rwxr-xr-x 1 root root 72808 2008-12-21 15:27 npwrapper.libflashplayer.so
-rwxr-xr-x 1 root root 72808 2007-12-09 13:18 npwrapper.nphelix.so
lrwxrwxrwx 1 root root 51 2007-12-09 13:18 npwrapper.so -> ../../lib/nsplugin wrapper/x86_64/linux/npwrapper.so
sam@linux-kzhj:/usr/lib64/browser-plugins> cksum npwrapper.libflashplayer.so
2181825404 72808 npwrapper.libflashplayer.so
sam@linux-kzhj:/usr/lib64/browser-plugins>
When looking at about:jplugins in firefox it list flashpler9
npwrapper.libflashplayer.so I kinda think this the root of the problem.
Could I rm npwrapper.libflashplayer.so and mv libflashplayer.so in it's place? If not how can I get a flash 10 nwrapper.libflashplayer.so?

Thank You
Sam


All times are GMT -5. The time now is 01:27 AM.