-   SUSE / openSUSE (
-   -   Inconsistent sound functionality on reboot (SBx00 Azalia (Intel HDA)) (

ph73nt 03-01-2009 04:15 PM

Inconsistent sound functionality on reboot (SBx00 Azalia (Intel HDA))
Hi, hope someone can help with this

I have an HP 6735s laptop running Opensuse 11.1 with a troublesome soundcard (output of lspci |grep Azalia):


00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
There are plenty of posts with hints for configuring this soundcard. Getting the sound working is not much of a problem, the problem is getting it working after a reboot without any intervention. I shall detail what I have done:

I have tried OSS4, which does give a guaranteed success after reboot, but compatibility is not as smooth as with alsa, so I stuck with alsa.

updated alsa following instructions at:

edited /etc/modprobe.d/sound to read:


alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd slots=snd-hda-intel
options snd-hda-intel model=laptop position_fix=1

added the following line to /etc/init.d/boot.local:


rcalsasound restart
It seems about 50:50 that the sound works after a reboot. When it doesn't I can execute su -c 'rcalsasound restart' and then it works fine, but I shouldn't have to do this and my wife certainly can't be trusted with the command line ;-). I have tried putting the following into a script in ~/.kde4/Autostart:


sudo /usr/sbin/alsasound restart

This is just as intermittent (and yes, I have edited the sudoers file). Does anybody have any ideas how I can get a guaranteed success after reboot?

Many thanks in advance,


business_kid 05-08-2009 02:32 PM

I have a HP 6715S with _no_ sound and the same chip. What does it identify as in alsamixer? Mine calls itself an AD1981 (which is an AC97 based thing.

All times are GMT -5. The time now is 01:01 AM.