-   SUSE / openSUSE (
-   -   ibus-pinyin in Opensuse 12.3 (

future_computer 03-06-2013 06:59 PM

ibus-pinyin in Opensuse 12.3
I install it, but it does not appear for me to enter chinese character.
The "language and region" keyboard selection does not have it, the default Chinese does not give keyboard for chinese words.

I am using opensuse gnome.

So, how to launch the ibus?

future_computer 03-07-2013 08:03 PM

any idea?
maybe I will try scim, scim works better in opensuse.

Randicus Draco Albus 03-10-2013 07:07 AM

You have installed IBus.
I assume you also installed your desired input methods.
But have you enabled the input methods? Before input methods can be used, they must be added in IBus Preferences/ Input Method.

future_computer 03-10-2013 01:05 PM

it works now, ctrl-space

andrew.comly 06-17-2017 09:59 PM

Separately install ibus-pinyin
I just had a similiar problem, but Ctrl + Space OR Super + Space didn't help me. Even when I went into Start | System Preferences | IBus Preferences I saw that no choices for Chinese were present. This means that Chinese is not one of the languages installed by default.

I then installed ibus-pinyin and then was able to add pinyin via "IBus Preferences" as an input method. Only then I could I switch input to ibus-pinyin by a simple "W-Space". [W - Window(/Super) button]

sudo apt-get install ibus-pinyin

andrew.comly 06-17-2017 10:37 PM

Even though when learning Chinese I really like Baidu for checking that pronunciation is the Standard Beijing pronunciation (As opposed to Taiwan's pronunciation, which is heavily influenced by their dialect Taiwanese), beware of the following incorrect advice given on Baidu:

Debian GNU/Linux
apt-get install build-essential libgtk+2.0-dev libgtk-3-dev libgirepository1.0-dev libdbus-glib-1-dev libdconf-dev libdconf-dbus-1-dev dconf-tools libvala-0.16-dev libsqlite3-dev python-gobject-dev python-notify python-dev python-dbus-dev python-enchant python-xdg uuid-dev iso-codes sqlite3 valac valabind gnome-common gtk-doc-tools

When I followed the above advice on 2017 06 17, this resulted in the following symptoms:
I could add pinyin via IBus Preferences, but upon switching to pinyin input, typing any Chinese character, choosing it from the selection list, the OUTPUT (across several applications) was always:

[Invalid UTF-8]
Only when I purged each of the above and then rebooted could I actually get the true Han Character output.

All times are GMT -5. The time now is 04:41 AM.