-   SUSE / openSUSE (
-   -   I need to mount a floppy drive, optical drive, jumpdrive & burning CD's. (

talagm 04-08-2009 09:04 PM

I need to mount a floppy drive, optical drive, jumpdrive & burning CD's.
I'm running SuSE Linux 11.0 KDE version 3.5. I have two IDE hard drives that are detected as SCSI drives. Both of those drives optical drives. I have been able to format and mount the secondary hard drive, but I have had no luck with the optical drives.

I have tried many steps.

Could anybody out there give me a hand. Every time I try to mount a drive through command line, I end up having to repair the operating system.

Also, I am trying to mount a jumpdrive and burn a CD as well. Even in the GUI, it doesn't recognize the jumpdrive.

Any help would be greatly appreciated. I know how to use vi pretty good and I am learning some scripting, but I am still relatively new to Linux command line editing.

Stéphane Ascoët 04-09-2009 01:48 AM

Optical drive
What is exactly the optical drive model?

talagm 04-10-2009 10:29 AM

Here's the model's of the optical drives and the make of the jump drive
I am running an LG DVD-ROM Model GDR-H30N (S/N: 709HTBH195381) ROM version 1.00 as Secondary Master. As a secondary slave, I am running an Lite-ON CD-RW Model LTR-24102B drive. Both are IDE. Also, I am running a SanDisk U3 Jump Drive 8GB.

Stéphane Ascoët 04-10-2009 10:34 AM

Totally confused
I don't understand at all your set. Could you write a sort of scheme showing each device, where it's physically attached and what is its behaviour under Linux?

talagm 04-12-2009 10:42 PM

The LG DVD ROM drive is on the Secondary Master chain on the outer part of the cable and the inner part is the Secondary Slave of the ribbon cable; the CDRW drive. They are both jumpered correctly. They are using only 40-pin IDE ribbon cables because they don't require the 80-pin.

When I go into the Linux GUI, it reports that both drives are recognized when there is an optical disk in the drives.

The DVD ROM drive is mounted in the GUI as /dev/sr0 in the /media folder. It detects it as a mounted CD writer. The CDRW drive is in /media/disk when checking through the GUI and the node is /dev/sr1. According to cat /var/log/messages and scrolling through, it says that they both use the ISO 9660 extensions (Microsoft Joilet Level 3 and RRIP_1991A)

The floppy drive is /dev/fd0. I did not have time to get to the Jump Drive, but it is detected when I check in /var/log/messages. It even detects the right type, but not in the GUI.

If you need more information, please let me know what you need.


Stéphane Ascoët 04-20-2009 02:47 AM

And so?
So what's the problem?

talagm 04-22-2009 09:09 PM

I got most of the problem solved, but not all of them.

Originally Posted by Stéphane Ascoët (Post 3514779)
So what's the problem?

It took me about two weeks but I finally got the DVD ROM drive to read through the command line of mount -t iso9660 /dev/sr0 /media

I also mounted only read only the jump drive. I still am trying to figure out how to burn a CD through command line, but that's not the problem I am having right now.

I purchased a HP Deskjet D2530 inkjet printer. I went through the setup script provided by HP, checked my dependencies, and made it all the way to where Linux recognizes the driver.

However, when I go to print from an application, like open office, all I get is the power light blinking and no printing.

Should I try the manual install method and forget the script?

Stéphane Ascoët 04-23-2009 05:14 AM

To burn you must use cdrtools, or its remplacement(I don't remember the name).
I don't know nothing about non-Postscript printers. The first thing you have to know is which printer manager you are using(probably CUPS), and read documentation about it.

All times are GMT -5. The time now is 04:55 AM.