LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 11-08-2004, 05:08 PM   #1
philF
LQ Newbie
 
Registered: Sep 2003
Posts: 20

Rep: Reputation: 0
how to start in text mode?


Hi All
I have just installed SUSE 9.1 Personal on my home pc in VMWARE Workstation. I want to install the VMWARE tools but I need to be running in text mode to do this. The VMWARE website says "Be sure the guest operating system is running in text mode. You cannot install VMware Tools from a terminal in an X window session."

How should I go into text mode? do i have to edit the xconfig file so it boots into text mode?

Thanks for your help

Phil
 
Old 11-08-2004, 05:34 PM   #2
CroMagnon
Member
 
Registered: Sep 2004
Location: New Zealand
Distribution: Debian
Posts: 900

Rep: Reputation: 33
Try ctrl-alt-f1 - I'm sure this would be captured and passed to vmware. It doesn't say you need to stop X running, just that you need to start the install from a proper console.
 
Old 11-08-2004, 05:36 PM   #3
serz
Member
 
Registered: Apr 2003
Location: Buenos Aires, Argentina
Distribution: Slackware, Gentoo
Posts: 397

Rep: Reputation: 30
As root, edit /etc/inittab.

Look for:
Quote:
id:5:initdefault:
and change it to:
Quote:
id:3:initdefault:
If you already have that set to 3 then you don't have to change anything.
 
Old 11-08-2004, 06:53 PM   #4
philF
LQ Newbie
 
Registered: Sep 2003
Posts: 20

Original Poster
Rep: Reputation: 0
thanks for all your help

I got vmware tools installed and running successfully so i can get a nice resolution desktop now!
 
Old 11-30-2004, 08:29 PM   #5
VinE
LQ Newbie
 
Registered: Nov 2004
Posts: 2

Rep: Reputation: 0
Hi.. I'm the ultimate noob in Linux, however, i like to learn..

First of all i got to install vmware, and run a VM with Fedora core 3, all nice, ran like a charm, now the ugly part, installing vmware tools...

I did edit the inittab to 3, now i want to go back to graphic mode but I can't..

I don't know how do edit inittab in order to change to 5 again..

How do I do that in text mode only..?


Tnx in advance...


EDIT: Oh damn.. big mistake.. i used search and thought that this thread was in Linux - Newbie.. SOrry.. :\

Last edited by VinE; 11-30-2004 at 08:33 PM.
 
Old 11-30-2004, 08:41 PM   #6
CroMagnon
Member
 
Registered: Sep 2004
Location: New Zealand
Distribution: Debian
Posts: 900

Rep: Reputation: 33
How you do it depends on which text editor is installed. If you have vi or vim (reasonably likely), try this (vi is not a nice editor for a newbie, so if at any point you do something wrong, press ESC a couple of times, then type ':q!' and hit enter - this will exit without making any changes). For everything I tell you to type, don't include the quote marks.
First type 'vi /etc/inittab'. If vi is installed, this will load the file. Now use the cursor keys to move to the initdefault line, position the cursor on top of the 3, and then press 'r', then '5'. If everything looks right, type ':wq' to exit and save.

[edit] You will need to log in as root to make this change - just making sure
 
Old 11-30-2004, 08:58 PM   #7
VinE
LQ Newbie
 
Registered: Nov 2004
Posts: 2

Rep: Reputation: 0
Ok.. Used Vi and had no trouble.. Kinda reminds me of PC Tools.... :\

Now i can't get into graphic mode because it doesn't like the mouse...

What the..?

Tnxs anyway..
 
Old 12-01-2004, 08:43 AM   #8
philF
LQ Newbie
 
Registered: Sep 2003
Posts: 20

Original Poster
Rep: Reputation: 0
i had a nightmare with the X window system in fedora (especially after doing security updates). Therefore I have gone with Mandrake on work PC and Suse for home. Both in VMWARE at the minute. Must say I like them both. Mandrake looks better but SUSE has lots of software. I am just trying to get Bit torrents working properly at home with Suse. Once I can do this i will be using it permanently.
 
Old 12-01-2004, 01:41 PM   #9
minrich
Member
 
Registered: Aug 2003
Location: Isles of Man & Wight
Distribution: See signature
Posts: 548

Rep: Reputation: 40
Just for info. I don't modify inittab, I just su to root and pwd then enter: init 3 and then init 5 when I have finished installing vmware tools.

However, it has taken a major effort to load tools onto a Suse9.2pro guest (on my tablet PC) since the default 2.6.x kernel uses Xorg rather than Xfree86, it took some time swapping back and forth editing vmware-config-tools.pl - I think that some four changes were needed, after I had finally found a patch for Sus e - the first patch I found was for Fedora Core 2. Since my DVD did not giv me a text mode option I followed someone else's advice and used VESA set at 800x600. I also had to install - using YAST - the linux source package and gcc (and dependencies) so that I could install the tools.

When I have more time I intend to write this saga up for the wiki and the vmware communiity site.
 
Old 12-01-2004, 01:56 PM   #10
mykrob
Member
 
Registered: Jun 2004
Location: Jackson, TN
Distribution: Kubuntu Feisty
Posts: 606

Rep: Reputation: 31
Quote:
Originally posted by philF
I am just trying to get Bit torrents working properly at home with Suse. Once I can do this i will be using it permanently.
use Azureus. This is by far the easiest BitTorrent client to get running in any distribution. Just make sure you have Java installed, which Suse installs by default. Download and unpack the tarball.No installation necessary, just run the application from the folder you unpacked it in. Go through the setup wizard and you're done


-myk
 
Old 12-02-2004, 01:21 PM   #11
thekat
Member
 
Registered: Oct 2003
Location: /dev/null > Oklahoma
Distribution: Mepis 3.3.2-test 3, CC Home 3.0, OpenBSD 3.8
Posts: 64

Rep: Reputation: 15
Quote:
Originally posted by mykrob
use Azureus. This is by far the easiest BitTorrent client to get running in any distribution. Just make sure you have Java installed, which Suse installs by default. Download and unpack the tarball.No installation necessary, just run the application from the folder you unpacked it in. Go through the setup wizard and you're done


-myk
on tidbit on Azureus.. the latest Azureus 2.20 requires jre 1.5 (latest)
9.2 if that is what you are ruuning has jre 1.42.. Azureus 2.20 will run
on this version but you will get 100% CPU utilization.. been there done that..
started cussing it like a windows box.. till I back reved Azureus to 2.14...

other than that.. Azureus is a great BT client..

hth
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to start Linux in text mode gregor2416 Fedora 5 10-25-2005 06:52 PM
start in text mode instead of graphical inc0gs Linux - Software 3 01-27-2005 04:23 PM
How to start drakconf in text mode, question raxxal Mandriva 5 08-03-2004 03:51 PM
howto start linux in text mode and not in graphical? ichbinesderelch Linux - General 5 08-20-2003 08:11 PM
Installing RH8.0 and specifying text mode but still wants to try and start anaconda? severedhead Linux - Software 2 10-17-2002 03:39 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 03:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration