-   SUSE / openSUSE (
-   -   How to set login and password and root password in suse 10.2 (

sirius57 06-30-2007 09:03 PM

How to set login and password and root password in suse 10.2
I have just installed suse 10.2. The install froze about half way to the end and I rebooted and finished the install using the 'update' option. It finished stage-two install and will boot using grub and stop at the login prompt. Since I never set the password, I can not log in. Is there a generic password or can I edit the file responsible for holding it? Is there a way to invoke yast and set it that way? I can use puppy linux and see the hda2 and hda3 partitions. Can I fix it that way?

jdmcdaniel3 06-30-2007 09:14 PM

Have you tried using root as the password as well as just blank, or no password? I am not sure I have heard of a behind the scenes default password other than using User:root/PW:root. I think if you find no solution, you are going to need and reinstall one more time.

Thank You,

sirius57 07-01-2007 07:42 AM

I can boot in repair mode and it will log me in as root. From there I need to know how make a new root login, user and password. I have added users when I had a root login with suse 10.1 like this:

useradd -d /home/username -m username
passwd username

Can yast be started in repair mode and if so, what is the command?

leandean 07-01-2007 11:39 PM

Boot into rescue mode, mount the file system then edit /etc/shadow removing everything between the first two colons, save and reboot. That will leave root with no password. Boot into the system as root and set the root password. You can then add users via the command line like sirius57 shows but without the -d /home/username or via YaST.

sirius57 07-02-2007 09:26 PM

I found the shadow file under /etc. If there is no password, how do I log in and make a root password? Can an example be provided?

leandean 07-02-2007 11:35 PM

At the user prompt enter 'root'. At the password prompt hit <enter>.

sirius57 07-04-2007 11:00 AM

I have been able to set the root password and make a user account and password, but have not been able to start kde. I used puppy to look into /etc/shadow and saw that there was nothing for root in the root line. I rebooted without the puppy cd and at the grub screen for login options typed: init=/bin/bash. This allowed system to boot as root without root password. I then set a new root password, rebooted and logged in as the new root and made a user account, but I mistakenly did not give it a home directory so its home is /. I did not know how to change that fact, so I made a new account with /home, however neither one will start kde. I typed kde at the command line and got: can not contact kdeinit
trying to create local folder permission denied (this is for the user with /.)
cannot create directory /home..... permission denied
the user at /home said it could not start kdeinit.
I feel that I am very close. Is there a way to fix kde?

sirius57 07-05-2007 09:30 PM

I got the box up and running. I had to nuke the hard drive and remove the video card in order to use the integrated onboard video on the motherboard to get it to install. After installing, to run x-org, I reinstalled the video card, started x manually and the kde desktop loaded. I also had to make new usernames and passwords.

sirius57 07-24-2007 09:51 AM

I had to reinstall to remove zenworks. However, I am back to setting the root password again. I typed init=/bin/bash in the suse grub loader to boot as root, but it did not work, so I think I have to edit the shadow file. (Yast never lets me set one during the install). I was going to use my puppy cd to edit the file. From the above description, did I forget something using init=/bin/bash ?

All times are GMT -5. The time now is 11:25 AM.