-   SUSE / openSUSE (
-   -   How to disable touchpad? (

simanyay 05-07-2005 06:48 AM

How to disable touchpad?
Hello. I've installed SuSe Linux 9.3 Pro on my Gateway 7422GX. Everything is ok except one thing: i can't disable my touchpad. Touchpad and my USB mouse is on one file: /dev/mouse. How can I disable it?

Bruce Hill 05-07-2005 07:33 AM

try the BIOS

simanyay 05-10-2005 06:49 AM

I can't find it there :(

Bruce Hill 05-10-2005 06:53 AM

Well, the touchpad does not use the same modules as the USB mouse.
I can't imagine that not being in the BIOS, and I know absolutely nothing
about SuSE, but if nothing else works, you should be able to remove the
PS/2 mouse support from your kernel, and perhaps that will disable the

okmyx 05-10-2005 07:08 AM

It might not be the same, but my Toshiba laptop have keyboard combo to disable the touch pad (Fn+Key).

xmav78 05-26-2005 05:51 AM

I have the same problem on a travelmate 254; several fn+Fn keys do not work. xev gives no hit for those keys. Disabling by BIOS? or other? I would like to be able to enable/disable it on the fly, each time I want! It is possible under Windows so it must be possible under linux too! using keyboard special keys for this and other stuff (for example, volume and muting, for this i almost solved the problem...)

phillips321 06-04-2005 11:11 AM

in suse 9.3 it may be possible to use SaX2 to disable it? have a little look

xmav78 06-14-2005 08:33 AM

suse 9.3

Originally posted by phillips321
in suse 9.3 it may be possible to use SaX2 to disable it? have a little look
ops i have sus 9.2...

but i tried with sax... i killed all input devices like mice that it shows me and...
still i can move my mouse!! - of course i restarted the gfx system too

doing a cat on the /dev/mouse or something like that it happens there is output
both if i move my mouse or if i touch the tpad... hmmm...

awtoc123 06-24-2005 01:24 AM

Same problem here, I need to totally disable the tocuhpad,

I'm using Redhat RHEL4 with kernel 2.6.11

Notebook Compaq M2000

In the old Compaq 2200 thee where a small switch where you could enable/disable the touchpad, but as always when you upgrade to new model something is left out.
The touchpad is very fustrating when using mouse and you are typing your arm hair or hand touches the touchpad, and you are typing in a diffeent place.

I have been thinking to open the machine to pull the plug, but there must be a way via software to disable it.

I have tried to uninstall all the synaptics drivers so there is absolutly no reference to the touchpad in xorg.conf, but still it is working.

Any Idea would be highly welcome.

xmav78 09-20-2005 09:16 AM

touchpad off... forever?
ok i have done: touchpad is out. i did it in a very unfriendly way: i noticed
as said that there's a device that "hears" both tpad and mouse, but still they are reacheable
via single device entry. (check it via cat /dev/mouse or /dev/input/mouse*)
so I made a link of /dev/input/mice to /dev/mouse if I remember well... worked, until I run sax2
which get confused... x86conf in trouble, X didnt started, i fixed it (there where two
line with SendCoreEvent) and now seems to work... but well still I am not able to get back
the touchpad and if I plug out the mouse, nothing can move the pointer! even though I plug in
it again... hm hotplug too get confused?
wll, still i really didn't need the tpad but in a future....
when i will understand better the matter i will post a answer with details... bye

rlfederico 11-02-2005 06:19 PM

Gateway 7422GX and SUSE 9.2
I installed Suse 9.2 on my Gateway 7422GX and it freezes after boot. What did i do wrong.
What can I do to get a useable screen?

hg01 12-06-2005 10:03 AM

I know, this post is old, but this reply may be usefull for others. I am newbe, but it works on my laptop + USB mouse (distro archlinux, kernel 2.6.13)
To see on witch device your touchpad is mapped, try (in a console)
"cat /dev/input/mouse0 (or mouse1, mouse2,...) and move first only your mouse. Garbage will appear. Then touch your touchpad. If nothing appear, it's the right one. (for me /dev/input/mouse2)
(Press ctrl+c to cancel it.)
In /etc/X11/xorg.conf (make first a backup from yout file!), in Section "InputDevice", replace:
Option "Device" "/dev/input/mice"
Option "Device" "/dev/input/mouseX" (X ist the right number)
You must have only 1 entry for Input Device. Comment out the others.
Save your new xorg.conf
Rerun X (Ctrl+alt+backspace for killing X session)
It should work
Sorry for my bad english!

robin48gx 06-26-2007 04:42 AM

thankyou !
the f**king touchpad was driving me insane. I would be typing away and the cursorwould have moved to some randon place in the text nd mucked everything up.

Thanks once again

All times are GMT -5. The time now is 02:32 AM.