-   SUSE / openSUSE (
-   -   how to access files in USb flash drive (

riba43 06-30-2007 10:06 AM

how to access files in USb flash drive

i need an instruction about the following problem:

I can see my flash drive in "My computer" but cant see any files in it. I am getting the following message:
"The option flush is not allowed for uid=1000"
I tried to change that in YAST, but obviously I cant. So I need help.

rednuht 07-01-2007 04:07 PM

if you run

sudo dmesg
the last messages should give you a better idea whats going on.
evn better run dmesg before and a few seconds after plugging in the device

jschiwal 07-01-2007 05:06 PM

I just plugged in a Cruzer mini. This is how it was automounted:

/dev/sdc1 on /media/disk-1 type vfat (rw,nosuid,nodev,noatime,flush,uid=1000,utf8,shortname=lower)
The "My Computer" icon opens up konqueror with the url of "sysinfo:/". Locate the device on the page and right click. Select Properties. Click on the "Mounting" tab. Notice the mounting options on the bottom. Make sure mount as user is selected. If it is you could try unselecting the "Flushed I/O" box.

I wonder if the filesystem on the drive itself is OK. You might want to mount it once as root.

sudo mount -t vfat /dev/sd<##> /mnt -o rw,defaults,dmask=000,fmask=111,uid=1000
Where <##> is the device, such as sdb1

If it doesn't mount, check out the filesytem:

# make sure it is unmounted
sudo umount /media/disk-1
sudo /sbin/fsck.vfat /dev/sdc1
dosfsck 2.11, 12 Mar 2005, FAT32, LFN
/dev/sdc1: 119 files, 4629/15656 clusters

Your device's mount point is probably somewhere else.

riba43 07-02-2007 01:02 AM

jschiwal thanks. i fixed the problem. Just unchecked the "Flushed I/O" in the properties windov.
Thanks again

ashwinidubey 07-09-2007 03:34 AM

one of the easiest way is
cd /media/urUsbDeviceName/
cp command to copy

may be u need to be super user
ur password

All times are GMT -5. The time now is 01:26 PM.