LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 08-22-2006, 07:16 AM   #1
ionmich
Member
 
Registered: Sep 2003
Location: Mexico, Sweden
Distribution: openSUSE 15.2, Microware OS-9, MX-19, Bodhi 5.1.0
Posts: 256

Rep: Reputation: 41
How smart is SMART?


Trying to install KBasic I lacked one dependancy. Downloaded the required .rpm and when I tried to install it with smart I got the following...

# smart install expat-1.95.0-1.i386.rpm
Loading cache...
Updating cache... ############################### [100%]

Computing transaction...

Downgrading packages (3):
expat smart smart-debuginfo

Installing packages (1):
Kick-suseRegister

Removing packages (268):
3ddiag libgnomeprintui
CheckHardware libgnomesu
ImageMagick libgnomeui
Mesa libgphoto2
Mesa-devel libgsf-gnome
MozillaFirefox libgtkhtml
MozillaFirefox-translations libkexif
NX libkipi
NetworkManager libmusicbrainz
NetworkManager-kde librsvg
OpenOffice_org libsvg-cairo
OpenOffice_org-Quickstarter libtunepimp
OpenOffice_org-kde libvisual-plugins
RealPlayer libwmf
SDL libxine1
SDL_image libzypp
SDL_mixer libzypp-zmd-backend
SDL_net mozilla-xulrunner
SDL_perl nedit
SDL_ttf neon
WindowMaker openmotif
WindowMaker-applets openmotif-libs
WindowMaker-themes openssh-askpass
aalib opera
amarok-libvisual pango
arts pango-devel
autoyast2 perl-XML-Parser
autoyast2-installation pinentry
cairo poppler
cairo-devel poppler-qt
capi4linux powersave
dbus-1-glib powersave-libs
dbus-1-x11 python-cairo
digikam python-elementtree
digikamimageplugins python-gtk
dragonegg python-qt
enigma qca
flash-player qscintilla
fontconfig qt3
fontconfig-devel rdesktop
fonts-config sane
freeciv sax2
freeglut sax2-gui
freetype sax2-ident
frozen-bubble sax2-libsax
fvwm2 sax2-libsax-perl
gail sax2-tools
gcc-java sisctrl
gconf2 skype
ghostscript-x11 smart-gui
giflib smart-ksmarttray
gimp startup-notification
gimp-cmyk sumf
glitz supertux
glitz-devel suseRegister
gnome-desktop susehelp
gnome-keyring susehelp_en
gnome-vfs2 tightvnc
goom2k4 unclutter
gpg2 v4l-conf
gpgme wv
gtk x11-input-synaptics
gtk-qt-engine xdg-menu
gtk2 xdmbgrd
gtk2-devel xli
gtksourceview xlockmore
gwenview xmoto
hal xmset
hal-resmgr xorg-x11
hplip xorg-x11-Xvnc
hwinfo xorg-x11-devel
i4l-base xorg-x11-driver-video
i4lfirm xorg-x11-driver-video-nvidia
imlib xorg-x11-libs
imlib2 xorg-x11-server
imlib2-loaders xscreensaver
java-1_4_2-gcj-compat xterm
java-1_4_2-sun yast2
k3b yast2-backup
kaffeine yast2-bluetooth
kdeaddons3-kate yast2-bootloader
kdeaddons3-kicker yast2-control-center
kdeaddons3-konqueror yast2-country
kdeartwork3-kscreensaver yast2-dhcp-server
kdeartwork3-xscreensaver yast2-dns-server
kdebase3 yast2-firewall
kdebase3-SuSE yast2-hardware-detection
kdebase3-kdm yast2-http-server
kdebase3-nsplugin yast2-inetd
kdebase3-samba yast2-installation
kdebase3-session yast2-irda
kdebindings3-python yast2-kerberos-client
kdebluetooth yast2-ldap
kdegames3 yast2-ldap-client
kdegraphics3 yast2-mail
kdegraphics3-fax yast2-mouse
kdegraphics3-kamera yast2-ncurses
kdegraphics3-pdf yast2-network
kdegraphics3-postscript yast2-nfs-client
kdegraphics3-scan yast2-nfs-server
kdelibs3 yast2-nis-client
kdelibs3-arts yast2-nis-server
kdelibs3-doc yast2-ntp-client
kdemultimedia3 yast2-online-update
kdemultimedia3-CD yast2-online-update-frontend
kdemultimedia3-mixer yast2-packager
kdenetwork3 yast2-pam
kdenetwork3-InstantMessenger yast2-perl-bindings
kdenetwork3-news yast2-phone-services
kdenetwork3-vnc yast2-pkg-bindings
kdepim3 yast2-power-management
kdepim3-kpilot yast2-powertweak
kdepim3-networkstatus yast2-printer
kdepim3-sync yast2-profile-manager
kdetv yast2-qt
kdeutils3 yast2-repair
kdeutils3-extra yast2-restore
kdeutils3-laptop yast2-runlevel
kio_ipodslave yast2-samba-client
kio_slp yast2-samba-server
kipi-plugins yast2-scanner
knights yast2-security
konversation yast2-sound
kpowersave yast2-storage
krecord yast2-support
kscpm yast2-sysconfig
ktorrent yast2-tftp-server
libbonoboui yast2-tune
libgcj yast2-tv
libgcj-devel yast2-update
libglade2 yast2-users
libgnome yast2-vm
libgnomecanvas yast2-x11
libgnomeprint yast2-xml

992.4kB of package files are needed. 1276.4MB will be freed.

-------------------------------------------------

The way I see it, smart is going to delete over a gigabyte of installed software and replace it with a one megabyte file. This doesn't sound too smart to me. Can anybody explain why?

Thanks.
 
Old 08-22-2006, 07:57 AM   #2
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 61
Sounds like you are trying to install an older or somehow different version of something. It's so far off that installing it will toast your system.
Don't do it unless you have a good backup!
 
Old 08-22-2006, 08:23 AM   #3
marozsas
Senior Member
 
Registered: Dec 2005
Location: Campinas/SP - Brazil
Distribution: SuSE, RHEL, Fedora, Ubuntu
Posts: 1,465
Blog Entries: 1

Rep: Reputation: 66
Try to install expat not specifying the version and release, just the name of the package:
Code:
$ smart install expat
 
Old 08-22-2006, 09:55 AM   #4
broch
Member
 
Registered: Feb 2005
Distribution: Slackware-current 64bit
Posts: 465

Rep: Reputation: 32
no, smart is not really smart (looks like PR), few times it tried to replace 64-bit with 32-bit libs/software and there was no way to stop it except quiting smart and running installation/upgrade manually. It also tries to replace i686 with i586. However as far as I heard for smart (no pun indended) devs this is not a bug.

Currently there is no PM dependable enough to use exclusively in suse.
My setup includes:
-completely deleted zen/mono (speed up and stabilization for yast)
-Yast PM
-smart PM
if Yast is slow try to use smart
if smart fails use Yast

If Yast is sleepy and smart is stupid install upgrade software manually. This works prety well.
 
Old 08-22-2006, 10:15 AM   #5
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 77
You are trying to install a local rpm that is older than the version available in the repos, so smart will downgrade any packages that explicitly require the newer version. Use the syntax posted by marozsas and you shouldn't have any problems.
 
Old 08-25-2006, 03:39 AM   #6
ionmich
Member
 
Registered: Sep 2003
Location: Mexico, Sweden
Distribution: openSUSE 15.2, Microware OS-9, MX-19, Bodhi 5.1.0
Posts: 256

Original Poster
Rep: Reputation: 41
Quote:
Originally Posted by reddazz
You are trying to install a local rpm that is older than the version available in the repos, so smart will downgrade any packages that explicitly require the newer version. Use the syntax posted by marozsas and you shouldn't have any problems.
Good diagnosis. Thanks.
 
Old 08-25-2006, 06:26 AM   #7
linux_learner
LQ Newbie
 
Registered: Sep 2002
Posts: 17

Rep: Reputation: 0
I am currently looking into another problem. smart remove expat. With this, smart wants to remove the system, but with YaST only a few rpm's are removed. I have been working with Niemeyer for sometime, and have done the official smart documentation.

I can tell the OP forced smart into the predicament. smart install expat, would have been better, and would not have caused this problem.

You can track the discussions here http://forums.suselinuxsupport.de/in...1&#entry187751
and here http://tracker.labix.org/issue198 and http://tracker.labix.org/issue199

Please use the smart tracker to file bug reports, and please be detailed as we will want to reproduce it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Smart Question confused_bof SUSE / openSUSE 10 08-29-2006 09:46 AM
anybody tried smart-urpmi? bioalchemist Mandriva 1 02-07-2006 06:34 AM
Smart Quotes apostate Linux - Software 1 09-09-2005 07:27 PM
dsc-1.3m smart ic1404 Linux - Hardware 0 07-28-2005 10:23 AM
How To Ask Questions The Smart Way yixudong General 4 08-31-2002 11:07 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 12:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration