LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 05-08-2006, 10:05 AM   #1
Hangetsu
LQ Newbie
 
Registered: Nov 2005
Location: Pennsylvania, USA
Distribution: openSuSE 10
Posts: 27

Rep: Reputation: 15
How do I get WPA2 Encryption on SUSE 10.0?


At least until Thursday, I'd like to get my machine working with WPA2 encryption. I have my card configured and recognized by the system, but WPA2 is not an option (I have wpa_supplicant installed from Yast).

Also, my access point does not broadcast its SSID -- Do I have to make any changes to the SUSE system to handle that?
 
Old 05-08-2006, 11:19 AM   #2
Artanicus
Member
 
Registered: Jan 2005
Location: Finland
Distribution: Ubuntu, Debian, Gentoo, Slackware
Posts: 827

Rep: Reputation: 31
The trick is that kinternet for some odd reason doesn't support WPA at all.. So, youll have to disable kinternet, and set the wpa options with the Yast hardware configurator. After a reboot it should work but make sure kinternet stays off, it _will_ mess up the wpa..
 
Old 05-08-2006, 02:12 PM   #3
Hangetsu
LQ Newbie
 
Registered: Nov 2005
Location: Pennsylvania, USA
Distribution: openSuSE 10
Posts: 27

Original Poster
Rep: Reputation: 15
Thanks for that info. I went with GNOME rather than KDE - Is KInternet even installed?

Also, would you know of a guide on setting up those options? Right now I only see WPA-PSK as an option, no WPA2-AES.

I also have the added fun of having an access point that doesnt broadcast its SSID, so I'm sure there is some configuration for that as well!
 
Old 05-08-2006, 09:23 PM   #4
crazibri
Member
 
Registered: Mar 2004
Location: Orange County, CA
Distribution: OS X, SuSE, RH, Debian, XP
Posts: 377

Rep: Reputation: 31
The downside in Linux is you need to broadcast your essid. Actually its not really a downside since the average smartguy (linux nerd) can find your access point w/o an essid. Thats what monitor mode is for

So just broadcast it anyway. I know the WPA_supplicant for Suse 10.0 works for WPA-PSK (TKIP and/or AES) but the Suse 10 version of WPA_supplicant doesnt support WPA2. You'll probably have to search for the new version and see if it supports it.

If you're using Gnome, dont worry about Kinternet. Just go into Yast2 and configure the options ther for WPA-PSK. I'm sure you could get WPA2 working, just need to update WPA_supplicant and probably edit your /etc/sysconfig/network/ifcfg-wlan0 file (which contains your key and device info settings).
 
Old 05-09-2006, 01:49 AM   #5
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
Argh! I forget what utility I got from YaST, but it does allow WPA2 because I was using it on my wireless card with SuSE10 before I got my new Dell Latitude D620. I just can't recall what the application was called. It's not kinternet (for KDE), I know that much.
 
Old 05-09-2006, 12:31 PM   #6
Hangetsu
LQ Newbie
 
Registered: Nov 2005
Location: Pennsylvania, USA
Distribution: openSuSE 10
Posts: 27

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by crazibri
The downside in Linux is you need to broadcast your essid. Actually its not really a downside since the average smartguy (linux nerd) can find your access point w/o an essid. Thats what monitor mode is for

So just broadcast it anyway. I know the WPA_supplicant for Suse 10.0 works for WPA-PSK (TKIP and/or AES) but the Suse 10 version of WPA_supplicant doesnt support WPA2. You'll probably have to search for the new version and see if it supports it.

If you're using Gnome, dont worry about Kinternet. Just go into Yast2 and configure the options ther for WPA-PSK. I'm sure you could get WPA2 working, just need to update WPA_supplicant and probably edit your /etc/sysconfig/network/ifcfg-wlan0 file (which contains your key and device info settings).
Actually, you can have this work in Linux: I was able to get Ubuntu 5.10 to connect with little issue by modifying the /etc/wpasupplicant.conf file. As SuSE does something different, I'm trying to find the method.
 
Old 05-09-2006, 01:00 PM   #7
onlooker
LQ Newbie
 
Registered: Apr 2006
Posts: 7

Rep: Reputation: 0
which wireless card are u using. ie what is the output of the following

ifconfig
ip addr
rcnetwork restart
 
Old 05-09-2006, 11:21 PM   #8
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
I think I remember the application now. It is called netapplet. install it via yast and it has WPA2 support.
 
Old 05-10-2006, 09:39 PM   #9
crazibri
Member
 
Registered: Mar 2004
Location: Orange County, CA
Distribution: OS X, SuSE, RH, Debian, XP
Posts: 377

Rep: Reputation: 31
Netapplet is for using "ifup" and "ifdown" for already configured devices. If you right click the netapplet icon in the system tray it will take you to "/sbin/yast lan" which is Yast Network Card configuration. Which basicall you're back to what I said that you need to configure WPA-PSK in Yast and if you'd like WPA2, you need to download the new version of WPA_supplicant on their website. Suse 10 doesnt have the newest version of it yet. I saw it on their site a few days ago when I made my posting.

Once you do that you might have to do some 'figiting' of the ifcfg-wlan file to make sure it works correctly w/ the new version of wpa_supplicant. Possibly even the wpa_supplicant.conf file.

Good luck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mad at wpa2 BobAymon Linux - Software 0 03-10-2006 04:27 PM
Problems with wireless encryption in Suse liquidrave Linux - Wireless Networking 3 02-10-2006 03:24 AM
Does anyone know how to get WPA2 working under linux? kevingpo Linux - Networking 2 08-10-2005 04:59 PM
WPA2 and prism gt wcard woes kevingpo Linux - Hardware 0 08-03-2005 08:58 AM
Wpa2 in linux hyapadi Linux - Wireless Networking 1 06-29-2005 01:50 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 07:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration