-   SUSE / openSUSE (
-   -   Help With Netgear WG311v3 PCI Wireless adapter (

cmtishler 05-05-2006 11:23 PM

Help With Netgear WG311v3 PCI Wireless adapter
Hello again all..

I am trying to get a Netgear WG311v3 PCI wireless network adapter working. I heard that Netgear is one of the better cards to get for SuSE but after installing the drivers with DriverLoader off of my Netgear CD the card installed and worked fine but now after a couple restarts of my box it will not load. I go to the driverloader area and reload the driver files and it says that there is an error starting the card or the card is not connected. I know that the card is connected because it's PCI lol so now the question is if anyone knows how to correct this problem. Does not matter if it's with DriverLoader or ndiswrapper. I can try either way... Still a newbie to linux so be easy lol j/k...

Thank you

Cogar 05-07-2006 09:58 AM

You did not mention which version of SUSE you are using, and that will make a difference. If it is version 10.0, they have a setup function for wireless adapters that makes setting up most wireless adapters (there are exceptions) "Windows easy" (and I mean that in a good way). For someone who is new to Linux, using this capability would be your best bet for long term stability. (I am also making the assumption that you did not have a hardware failure somewhere along the line.) Although the setup process has been explained here many times (and I have done it myself as well), the best general guide I can point you to for this task is here:
Scroll down to the “Setting up a wireless card” section. I hope that helps.

crazibri 05-07-2006 02:03 PM

Hmm sounds like you're using Linuxant? Could you clarify what you're using to load the driver on Suse? And what version of Suse you're using?

cmtishler 05-07-2006 10:15 PM

Sorry for not posting the version of SuSE... I am used to having all of that in my signature block... I am using SuSE version 10.0 Retail. I am using the linuxant Driver Loader to try to get the card to work... I had it working for a bit when I first installed it but now for some reason it will not enable and when I try to load the drivers off of my netgear cd into the DriverLoader page it still says that it cannot recognise my card even though it's plugged in.. The card is Brand New straight out of the box and works fine on my Windows XP system... I was just wondering how to get it to work.. Doesn't have to be with the linuxant driverloader, I am willing to try anything as long as I can get the adapter to work.. I am using the SuSE box for my DJ and Audio Studio Editing business and it would be nice to have internet access from it..


psiborg999 05-08-2006 04:39 AM

wireless lan card problem
I had a similar problem with my Gateway 7320GZ and it's built-in wlan card. Here's the short "fix it" list:

1) Google in NDISWRAPPER SUSE RPM or NDISWRAPPER RPM. Pick the most promising link.

2) Download the RPM files for your Suse version. ( try to get the SRC RPM version as well. )

3) Find your XP driver disk for the wlan card, copy the dll's and inf file to a directory on your HD

4) log in as ROOT, start a console, type in NDISWRAPPER, follow the instructions.

5) REMEMBER to update the "conf" file while still in the console!!

6) Re-install the wlan card in YAST, don't enable PCMCIA or USB, when asked for module, use NDISWRAPPER

7) Finish the YAST config, all is now setup; hopefully....

8) If you have an indicator light and a software switch for the wlan card, try it..... IT WORKS!

9) Now the wireless should work with a greater degree of permanence.

10) I did this less than 48 hours ago, and am using the laptop now to write this.

Any questions, just email me..... Glad to help U.


crazibri 05-08-2006 10:17 PM

FYI - you shouldnt have to google Ndiswrapper. Software management should have it if you have all 5 CDs (or 1 DVD) from their site.

Ndiswrapper is the free version of Linuxant. Linuxant is $20 after you get the 1st 30 days free, possibly why yours stopped working...

Once you install ndiswrapper, go to the terminal as root and to be more specific you should find your .inf and .sys file for your card and put it in your home directory.

Once in terminal as root:

cd <home directory where .inf and .sys are>
ndiswrapper -i <inf file>
ndiswrapper -l (should say installed and hardware detected)
modprobe ndiswrapper

Go to Yast as psiborg indicated to add your device. Dont choose a card type, just type in "ndiswrapper" for the module box.

Everything else should be pretty easy after that.
Hope this helps and gives you a bit more detail. :D

cmtishler 05-10-2006 10:28 PM

ok, I did what you both said above, however, I notice that my card is automatically displayed in YAST2 as netgear 802.11b/g already, cannot delete it.. I also tried adding it to the list, do not know what to add it as, so I tried wireless and entered all info including the paraphrase and all, still not connecting for me... It's a brand new card and I know it works because I can connect to the Internet via my Windows XP system... any ideas??

Cogar 05-11-2006 01:47 PM

As a guess, you may be having DNS issues. If that is the case, go to the page I mentioned earlier and check out the section entitled "Getting Internet connection to work if the wireless connection is configured correctly, but you cannot seem to connect to the Internet."

JimCockfield 05-12-2006 08:46 PM


Originally Posted by cmtishler
ok, I did what you both said above, however, I notice that my card is automatically displayed in YAST2 as netgear 802.11b/g already, cannot delete it.. I also tried adding it to the list, do not know what to add it as, so I tried wireless and entered all info including the paraphrase and all, still not connecting for me... It's a brand new card and I know it works because I can connect to the Internet via my Windows XP system... any ideas??

I've got this card. Most of the stuff you read (or at least I've found on forums) tells you that a version 3 card won't work (only version 2 cards are listed as being able to work in some of the lists around).

I'm a Linux newbie (I don't even know enough to be dangerous), and I have not yet switched to Linux (I'm running XP Pro).

But, I have managed to get this card working under any Linus distro I've tried with that's got a relatively recent version of ndiswrapper available, and I've got it working under Suse 10.0 before.

I have not tried it under Suse 10.1 yet (I was just debating on whether or not I wanted to go through the hassle of downloading and installing it or not) to check it out.

But, I'm confident the Netgear WG311v3 will work with it via ndsiwrapper.

The trick with this card is to make sure you're using the Windows 2000 drivers that came on the CD with the card, and not any drivers the distros have included designed to work with version 2 cards (you may have to remove them first).

Then, after you update ndiswrapper with the Win2K drivers that came with your card on CD, you have to specify your ESSID. It will not work without a specific ESSID from what I've found messing around with it using multiple Linux distributions.

I've got some comments on getting it to work with SimplyMepis in a thread on their forums, and the procedure to get ndiswrapper working is almost identical except for different utilities for getting an IP address via DHCP and where you put the card info so that starts it automatically each time.

I'll probably try to install Suse 10.1 either tmrw or Monday. When I do, I'll make some screen prints of how I got it working (it will work, as I've got it working under Suse 10.0 before with ndiwsrapper). Then, I'll post an update to this thread.

In the interim, look through the ndiswrapper stuff I posted in that thread on getting it to work with SimplyMepis and follow most of the same steps.

If memory serves, about the only step that's different (other than the stuff under menus for specifying card info) is that one distro uses dhcpcd and the other uses dhclient as a last step for getting an IP address. So, you'd need to substitute one for the other.

Here's the thread on getting it to work with SimplyMepis via ndiswrapper

I'll update this one after I download and install Suse 10.1 to check it out.

jimbo7 08-10-2006 01:41 AM

WG311v3 WIKI
Hi guys. Check out my mini wiki on how to install the WG311v3 Driver on Debian, i hope it can be helpful. And feel free to contribute comments to make it better!


JimCockfield 08-11-2006 01:14 AM

Cool jimbo7

I never got around to trying Suse 10.1

I saw so many posts in forums from users of 10.0 that said it worked better, that I decided against giving it a try.

Interestingly, I've seen my share of users complaining about problems with this card (WG311V3) in forums with some of the other distros around, too. Mine works fine with most distros (but, it is a bit picky with Ubuntu 6.06LTS or SimplyMEPIS 6.0

You can get segment faults with modprobe with it, if you don't do things a bit differently.

I downloaded your driver and will give it a try on a few of the distros I've been playing with. The one that comes with the card requires that you specify an ESSID (it's got to match the one in your router or it won't work, so forget the defaults for ESSID).

Perhaps the one you linked to in your Wiki might solve some of the quirks (segment faults, needing to use a specific ESSID) with it in other distros, too.

All times are GMT -5. The time now is 03:58 PM.