-   SUSE / openSUSE (
-   -   Help with Enlightenment on openSUSE 10.3 (

altumfred 11-18-2007 07:11 PM

Help with Enlightenment on openSUSE 10.3
I have downloaded and installed all the enlightenment libraries and files needed but an getting the following error:

"Enlightenment found Evas can't create a buffer canvas. Please check Evas has Software Buffer engine support.

Its all installed correctly; openSUSE has distribution for the OS now; but can't get the crazy thing to run. The error above occurs after log out and back in changing the session to Enlightenment.

Anyone successfully running Enlightenment 16 or 17 on openSUSE?


icitall 11-20-2007 02:43 PM

evas and framebuffer missing
I had the same problem and got the same error when I tried to start E17. I installed E17 using Yast. I went back into Yast and found that the evas app was not listed when I searched for enlightenment. I searched for evas and found it had not been installed along with the other enlightenment packages. I installed evas and framebuffer. After installing those packages E17 came up fine. I am not sure if you will really need to install framebuffer.

altumfred 11-22-2007 11:13 AM

Yep, that solved it all right. Apparently YaST2 doesn't do a solid job of checking dependencies. Evas was there but there were a couple of e-libraries missing including framebuffer.

She's up and running! Thanks for taking the time to respond.

sporks 11-27-2007 12:59 PM

I started using the easy-e script rather than the packages in the repsitories for my e17 fix.

All times are GMT -5. The time now is 07:25 PM.