LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   SUSE / openSUSE (https://www.linuxquestions.org/questions/suse-opensuse-60/)
-   -   Help! Black screen with mouse pointer X (https://www.linuxquestions.org/questions/suse-opensuse-60/help-black-screen-with-mouse-pointer-x-323159/)

duncnz 05-13-2005 12:05 PM

Help! Black screen with mouse pointer X
 
Hi everyone, Linux virgin here...

Just installed Suse 9.2 64bit over FTP. Was going through the Yast setup during which I installed my Packard Bell monitor and 6600GT graphics card and deleted the old monitor and Vesa graphics. Having done that it now goes through the boot process and then the monitor switches to a different resolution and I just get a black screen with a mouse curser on it...

What have I done? I'm thinking I shouldn't have deleted the old monitor and graphics... So how do I rescue it from here? I really don't fancy reinstalling over ftp again!

Thanks in advance

Duncan.

HenchmenResourc 05-13-2005 09:54 PM

The 6600GT (even though SuSE's website says it is) does not seem to be fully supported in SuSE 9.2 especially the AGP version of the card. hit "ctrl + alt + f1" to switch over to another terminal screen , login as root and type "init 3" to go to run level 3, if it hangs for a second hit "enter" and you should get a command prompt run sax (sax2) and change the graphic card device to a vesa BIOS device.
this will make it run with just basic/generic settings. exit sax and type "init 5" to go back to run level 5 with a GUI.

With the card running a as a vesa BIOS card you will not be able to use any openGL or 3D programs so you may want to try backing up you /etc/X11/XF86conf file and than playing with different settings to try to get SuSE 9.2 to recognise the card as an nVidia card. If you don't need 3D or openGL than you should be fine running it with the basic vesa driver. If you need 3D and openGL you may consider upgrading to SuSE 9.3 as the 6600GT is full supported.

hope this helps you out, if you have any other issues let us know and we'll try to get you up and running.

duncnz 05-14-2005 02:29 AM

Thanks for your help HenchmenResourc. Unfortunately ctrl+alt+f1 doesn't bring up a terminal screen. What next?

Maybe I should just upgrade to 9.3....

Thanks
duncan.

kencaz 05-14-2005 03:05 AM

Have you tried running the configuration again to correct the problem.
either:
# xorgconfig
or
#xf86config

Sounds like an incorrect video driver or monitor frequency. Post your /etc/X11/XF86Config file so everyone here can get a little more input as to the problem.

KC

duncnz 05-14-2005 11:55 AM

Guys, I'm in way too deep here!

The only way I get any sort of command line is if I boot up in rescue mode from the CD. From here I think I'm supposed to login as root then mount the linux partition.

Then I'm typing in dir /etc /X11/XF86Config followed by enter. All I get is /bin/ls: /etc/X11/XF86Config: No such file or directory....???

If I type in dir /etc I get a big long list of stuff but X11 isn't one of them.

Not having any joy with xorgconfig or xf86config either.

What am I doing wrong? Am I doing anything right?

Thanks people!

HenchmenResourc 05-14-2005 02:49 PM

try rebooting again, but this time instead of going into rescue mode boot the regular SuSE option but before it boots type "init 3" into the line for command options at the bottom of the boot menu. That will boot it up to runlevel 3 and give you a command line with everything up and running except the X windows server.

Then you will be able to run Sax and set your video card

if you run sax and it does not display properly you will need to edit the XF86conf file maually with vi

$>vi /etc/X11/XF86Conf

then in vi find the line that says something like:

Section "Device"
BoardName "007e0"
Driver "nvidia"
Identifier "Device[1]"
Screen 0
Option "Rotate" "off"
VendorName "nvidia"
EndSection

and change it to:

(in vi hit "i" to change to edit/insert mode, you can't back space in vi but you can del)

Section "Device"
BoardName "Vesa-BIOS Graphics"
Driver "vesa"
Identifier "Device[1]"
Screen 0
Option "Rotate" "off"
VendorName "VESA"
EndSection

(when you done editing hit "Esc" and then ":" you should see a command prompt at the bottom of the screen type "wq" and hit enter that will save the file and exit vi)

then type "init 5" at the command prompt to start up the X server and see if it works.

duncnz 05-14-2005 06:38 PM

Awesome, all go! Managed to run Sax as above, thanks a lot guys!

J.W. 05-15-2005 12:16 AM

Excellent thread - thanks for posting back duncnz, and thanks HenchmenResourc and kencaz for providng the guidance -- J.W.

haiders 09-11-2006 06:50 PM

I have the same problem above but I'm running suse 10.1. For some reason etc/X11/XF86Config doesn't exist. I tried running xorgconfig but it's asking about the monitor refresh rate, etc., it doesn't ask about the graphic card. Can you please help me?

Thanks!

haiders 09-11-2006 06:58 PM

Gents nevermind,

The file in 10.1 is /etc/X11/org.conf.

Made the same changes you suggested above and worked like a charm!!!
Thanks!


All times are GMT -5. The time now is 08:30 AM.