LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 09-20-2005, 01:26 PM   #1
<3Tux
LQ Newbie
 
Registered: Sep 2005
Distribution: SuSe 9.3 (HOPEFULLY)
Posts: 17

Rep: Reputation: 0
GUI not working... just ssh


I installed 9.3 and when I boot up for some reason it only allows me to use SSH and will not boot into KDE or anything. I tried logging into root and doing sax2 as I read on novell's site but it didn't do anything but say "Failed" after I did the command.
 
Old 09-20-2005, 02:10 PM   #2
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
When you say SSH, do you actually mean the command prompt/terminal?

As for not being able to load the GUI, do this and tell us what the output is:

At the command prompt/terminal, do this:

login: root
(type root password)
startx

What does the error exactly say? I'm concerned about what it says next to the (EE) sections.

Please report back
 
Old 09-20-2005, 02:12 PM   #3
<3Tux
LQ Newbie
 
Registered: Sep 2005
Distribution: SuSe 9.3 (HOPEFULLY)
Posts: 17

Original Poster
Rep: Reputation: 0
yeah I mean the actually command prompt/terminal... i'll go try what u said right now, and I'll write down the error that I am getting with sax2...
 
Old 09-20-2005, 02:26 PM   #4
<3Tux
LQ Newbie
 
Registered: Sep 2005
Distribution: SuSe 9.3 (HOPEFULLY)
Posts: 17

Original Poster
Rep: Reputation: 0
Errors with StartX

auth: (stdin):1: bad "add" command line
auth: (stdin):2: bad "add" command line
auth: (stdin):3: bad "add" command line

(EE) Problem parsing config file
(EE) Error parsing config file

IXO: Fatal IO error 104 (connection reset by peer) on X server ":0.0" after 0 requests (0 known requests) 0 events remaining

Errors with Sax2

XC: Sorry could not start config server



Thanks for any help

Last edited by <3Tux; 09-20-2005 at 02:28 PM.
 
Old 09-20-2005, 02:31 PM   #5
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
Quote:
Originally posted by <3Tux
Errors with StartX

auth: (stdin):1: bad "add" command line
auth: (stdin):2: bad "add" command line
auth: (stdin):3: bad "add" command line

(EE) Problem parsing config file
(EE) Error parsing config file

IXO: Fatal IO error 104 (connection reset by peer) on X server ":0.0" after 0 requests (0 known requests) 0 events remaining

Errors with Sax2

XC: Sorry could not start config server



Thanks for any help
OKay, do this:

when you're at the command prompt/terminal:

login: root
(type root password)
cd /etc/X11
xorgconfig

Go through the text based install. I recommend using VESA graphics card for right now to keep things simple.
After you're done with all that, type:

startx

Now what does it say (if anything)?
 
Old 09-20-2005, 02:54 PM   #6
<3Tux
LQ Newbie
 
Registered: Sep 2005
Distribution: SuSe 9.3 (HOPEFULLY)
Posts: 17

Original Poster
Rep: Reputation: 0
(EE) xf86OpenSerial: Cannot open device /dev/mouse
(EE) Mouse1: cannot open input device
(EE) Preinit failed for input device "Mouse 1"
No core pointer

Failed to initilize core devices
 
Old 09-20-2005, 03:05 PM   #7
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
Quote:
Originally posted by <3Tux
(EE) xf86OpenSerial: Cannot open device /dev/mouse
(EE) Mouse1: cannot open input device
(EE) Preinit failed for input device "Mouse 1"
No core pointer

Failed to initilize core devices
When selecting the mouse, choose AUTO (or whatever mouse you have) and give it the name /dev/input/mouse1

By default it's /dev/mouse and that did not work for me. I had to change it to /dev/input/mouse1. If that doesn't work, try /dev/input/mouse, or /dev/input/mouse0, and lastly, try /dev/input/mice

Do you know what the 'vi' editor is? are you comfortable using it? If not, just do the whole xorgconfig all over again. Make sure you do the WHOLE thing. If you are familiar with vi, then just edit the /etc/X11/xorg.conf file and change the /dev/mouse to /dev/input/mouse1. Save it and exit back to command prompt/terminal.

Either way, type startx again.

Let us know what happens.

Last edited by Micro420; 09-20-2005 at 03:08 PM.
 
Old 09-20-2005, 03:08 PM   #8
<3Tux
LQ Newbie
 
Registered: Sep 2005
Distribution: SuSe 9.3 (HOPEFULLY)
Posts: 17

Original Poster
Rep: Reputation: 0
I'm pretty new to linux, the only distro I've succesfully installed was Mandrake 10.0 awhile back. I'm just real interested in learning more about it etc.
 
Old 09-20-2005, 03:10 PM   #9
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
Quote:
Originally posted by <3Tux
I'm pretty new to linux, the only distro I've succesfully installed was Mandrake 10.0 awhile back. I'm just real interested in learning more about it etc.
Well this is good to know because most LInux distros are now using X.org for this graphical server. Once you learn how to configure the X server using X.org, then you can work with all X servers in any Linux distro
 
Old 09-20-2005, 03:32 PM   #10
<3Tux
LQ Newbie
 
Registered: Sep 2005
Distribution: SuSe 9.3 (HOPEFULLY)
Posts: 17

Original Poster
Rep: Reputation: 0
YIPPIE!! I got in =D I can't thank you enough bro

Few more questions though <<<

I need to configure my Wireless network card... I have a D-Link DWL-g520... is there an easy way to go about this?

Also I'm only able to set a max of 800x600 for my res, how could I allow it to get up to 1600x1200 or something (I have a PowerColor ATi Radeon 9600 Pro (256MB))?


Thanks again

Last edited by <3Tux; 09-20-2005 at 03:34 PM.
 
Old 09-20-2005, 03:50 PM   #11
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
Yes, you can configure your wireless card. See in the lower right hand corner the little green "PCI card"? Click on that and that is your hardware settings. Then click on Network and click on the one that is your wireless card (eth0 or eth1). Then just click configure.

As for your video card and resolution, you should have been prompted when you ran xorgconfig. Choose the correct ATI video card and for the resolution, you need to select 1600x1200. Then you select the default bit-depth (8-bit, 16-bit, 24-bit). Then run startx again.

If you get errors and it won't boot, then that means the wrong video card or monitor configuration was not done properly. Again, post the (EE) section for us to see.

I would try going to www.ati.com and downloading their recent Linux drivers and installing that. But before you do that, you need to run YAST (SUSE's control center). Then install kernel-source and install gcc. Then after all that, run the Online update (the green/yellow/red ball in the lower right hand corner). It will update kernel-source and gcc.

Report back

Last edited by Micro420; 09-20-2005 at 03:55 PM.
 
Old 09-20-2005, 04:01 PM   #12
<3Tux
LQ Newbie
 
Registered: Sep 2005
Distribution: SuSe 9.3 (HOPEFULLY)
Posts: 17

Original Poster
Rep: Reputation: 0
Ok i'm online now and going threw xorgconfig again but I forgot to ask you, what exactly is this identifier it wants for my video card?
 
Old 09-20-2005, 04:09 PM   #13
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
Quote:
Originally posted by <3Tux
Ok i'm online now and going threw xorgconfig again but I forgot to ask you, what exactly is this identifier it wants for my video card?
The identifier can just be blank, which will resort to the default, which is okay.

If you're using xorgconfig IN KDE/GNOME GUI, then you have to "kill the X server" for you to see the changes. Presss CTRL+ALT+BACKSPACE and it should kick you out to the Command prompt/terminal. Then do xorgconfig again (as root) and then type startx blah blah blah.
 
Old 09-20-2005, 04:13 PM   #14
<3Tux
LQ Newbie
 
Registered: Sep 2005
Distribution: SuSe 9.3 (HOPEFULLY)
Posts: 17

Original Poster
Rep: Reputation: 0
Cool man thanks , yeah right now I'm doing those YaST update things, which seems like it'll be awhile but as soon as those are done I'll go and do xorg but this is the first time I've ever been able to get online with Linux hehe The only other time I had linux was with Mandrake and it wouldn't work ><
 
Old 09-20-2005, 04:14 PM   #15
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
I have a Nvidia 6600GT video card, but I found this thread a few lines below that can assist you with installing the ATI drivers.

http://www.linuxquestions.org/questi...hreadid=356511

Again, remember to install the 'kernel-source' and 'gcc' or else you can't install the ATI video card drivers. Then remember to update the 'kernel-source' and 'gcc'

Maybe SUSE 9.3 already has installed the ATI drivers for you (assuming you set it up correctly with xorgconfig) and you may not have to get the ATI drivers. I don't know, but I know that the Nvidia drivers were not included with SuSE9.3 due to legal reasons.

Last edited by Micro420; 09-20-2005 at 04:18 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
gui and ssh kpachopoulos Linux - General 1 09-08-2005 01:30 PM
SSH Client GUI ? Snipersnest Linux - Software 6 03-03-2005 04:34 PM
ssh + gui? SamerAdra Linux - Newbie 5 10-27-2004 10:59 PM
good ssh GUI? kersten78 Linux - Networking 4 10-08-2004 12:49 PM
Ssh Gui DavidPhillips Linux - General 2 11-11-2001 05:53 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 06:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration