LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 04-10-2005, 01:41 PM   #1
allelopath
Member
 
Registered: Jan 2003
Location: New Mexico
Distribution: Ubuntu 18.04.3 LTS
Posts: 539

Rep: Reputation: 30
gnumeric / apt


I want to get a newer version of gnumeric
SuSE 9.2 comes with 1.3, but the latest appears to be 1.4.3

gnumeric.org links to this site for SuSe download:
http://www.gnome.org/projects/gnumeric/

this requires a program called apt, which is not installed and not available from the SuSE 9.2 dvd.
Can I install apt?
Will it intefere with Yast?
 
Old 04-10-2005, 02:45 PM   #2
mjrich
Senior Member
 
Registered: Dec 2001
Location: New Zealand
Distribution: Debian
Posts: 1,046

Rep: Reputation: 45
Yes -- you can follow the tutorial here for installing apt4rpm.

Otherwise, if you would prefer to stay with a purely Yast system, then just add the directories at the bottom of the Gnome download page (http://ftp.gwdg.de/pub/linux/usr-local-bin) to your Yast sources, click Refresh, and carry on as normal.

Cheers,

mj
 
Old 04-10-2005, 09:15 PM   #3
allelopath
Member
 
Registered: Jan 2003
Location: New Mexico
Distribution: Ubuntu 18.04.3 LTS
Posts: 539

Original Poster
Rep: Reputation: 30
Quote:
then just add the directories at the bottom of the Gnome download page
i use kde, not gnome...what can i do equivalently?
 
Old 04-10-2005, 09:38 PM   #4
mjrich
Senior Member
 
Registered: Dec 2001
Location: New Zealand
Distribution: Debian
Posts: 1,046

Rep: Reputation: 45
The same procedure will still work fine -- Gnumeric works perfectly under KDE also.

Cheers,

mj
 
Old 04-11-2005, 09:34 AM   #5
allelopath
Member
 
Registered: Jan 2003
Location: New Mexico
Distribution: Ubuntu 18.04.3 LTS
Posts: 539

Original Poster
Rep: Reputation: 30
i just noticed
http://ftp.gwdg.de/pub/linux/usr-local-bin/
has no version 9.2 folder.
 
Old 04-11-2005, 02:48 PM   #6
mjrich
Senior Member
 
Registered: Dec 2001
Location: New Zealand
Distribution: Debian
Posts: 1,046

Rep: Reputation: 45
I would simply install the version in the 9.1 folder - it has version 1.4.2 (the same as that which I run, and it's great). My guess is that 1.4.3 is probably only available as source - which you could easily compile, as long as you don't mind downloading all of the dev libraries needed.

Cheers,

mj
 
Old 04-23-2005, 10:52 AM   #7
allelopath
Member
 
Registered: Jan 2003
Location: New Mexico
Distribution: Ubuntu 18.04.3 LTS
Posts: 539

Original Poster
Rep: Reputation: 30
ok, so i'm going with 1.4.2
I get a broken packages error, and it even says that a package it needs is not installable.
What can I do?

# apt-get install gnumeric-1.4.2-100.SuSE.ulb.1.i586.rpm
Reading Package Lists... Done
Building Dependency Tree... Done
Selecting gnumeric for 'gnumeric-1.4.2-100.SuSE.ulb.1.i586.rpm'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
gnumeric: Depends: libgsf (>= 1.11.1) but 1.10.1-3.1 is to be installed
Depends: libgnomedb-2.so.1 but it is not installable
E: Broken packages

I also did the following commands (before the command above):

# apt-get updgrade libgsf
(everything looked good)

# apt-get install libgnomedb-2
Reading Package Lists... Done
Building Dependency Tree... Done
E: Couldn't find package libgnomedb-2
 
Old 04-23-2005, 11:26 PM   #8
mjrich
Senior Member
 
Registered: Dec 2001
Location: New Zealand
Distribution: Debian
Posts: 1,046

Rep: Reputation: 45
Drat

With a quick search of the net, I haven't been able to find an rpm version of libgnomedb-2 either. It's available from the Debian mirrors -- see http://packages.debian.org/cgi-bin/s...ll&release=all, and these can usually be converted to rpms without too much bother (using Alien), but otherwise you may want to just compile it from source.

Cheers,

mj
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
gnumeric gone from RH? molivera Red Hat 1 10-20-2004 10:26 AM
Gnumeric help broken? chasn Linux - Software 0 04-21-2004 11:36 AM
Gnumeric phishman3579 Slackware 3 06-02-2003 06:06 PM
gnumeric griv Linux - Software 0 06-30-2002 12:56 PM
gnumeric ry Linux - Software 1 06-30-2002 12:27 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 06:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration