Latest LQ Deal: Latest LQ Deals
Go Back > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
SUSE / openSUSE This Forum is for the discussion of Suse Linux.


  Search this Thread
Old 05-23-2005, 05:54 PM   #1
Registered: Oct 2004
Posts: 128

Rep: Reputation: 15
GNOME and SUSE 9.3 and transparent windows

I wondered if it was possible to get GNOME AND KDE options on the start up menu. I have GNOME but I try yo use it and the whole thing bombs out and I have to reboot, what have I done wrong?

Secondly, I saw some of the sexy new pictures of SUSE 9.3 and it had one of transpartent windows, how do I go about doing this?

Old 05-30-2005, 02:23 AM   #2
Registered: Mar 2005
Location: London, United Kingdom
Distribution: Fedora Core 5
Posts: 83

Rep: Reputation: 15
The actual capability is quite easy to install, however it is still very slow and very buggy. People use this capability when they want to make really good screen shots but be warned that it will get in the way of your normal productivity.

Firstly, you need Xorg 6.8.2 (or later if it exists yet).

Then edit your /etc/X11/xorg.conf file as root to include these lines (place them at the bottom, if you like)

Section "Extensions"
    Option "Composite" "Enable"
nVIDIA users have an advantage here: add Option “RenderAccel” “true” just underneath Option "Composite" "Enable" for speed

Next, you need xcompmgr and transset. Xcompmgr enables drop shadows, while transset enables window transparency. The method of installation will vary between the two, but you can just use to find the two tarballs. Extract and install them as usual.

That's it. Restart X. You'll notice that the system will be a tad slower, this is normal due to the new extensions that you've made.

To enable drop shadows, simply type "xcompmgr -c". All your windows have drop shadows.

To make a window transparent, type "transset". Your cursor will change into a little crosshair; click on the window you want transparent, and it'll become transparent.

If you later decide that this isn't for you, just remove the Extensions section that you added in the /etc/X11/xorg.conf file. You don't need to uninstall the other two programs because they can't be used anyway without the extension.


UPDATE: nVIDIA users, put RenderAccel in the setting under your display driver, not in the Extensions section.

Last edited by naimslim89; 05-30-2005 at 05:20 AM.
Old 05-30-2005, 08:30 PM   #3
Registered: Aug 2004
Location: Langley, BC, Canada
Distribution: Debian, SUSE {9.1, 9.2-64, 9.3-64}, Ubuntu
Posts: 80

Rep: Reputation: 15
Maybe this will clear up some confusion for somebody.

I use an AMD64 running suse 9.3 with an ATI card and tried all of the Xcomp stuff only to have it blow up in my face everytime. From reading other forums and doing some research it turns out that the 64bit ATI driver does not support the xcompmgr. Basically it freaks out and turns DRI off.

As far as I can tell that's what we get to live with, if anyone knows differently please let me know!
Old 05-31-2005, 01:45 AM   #4
Registered: Mar 2005
Location: London, United Kingdom
Distribution: Fedora Core 5
Posts: 83

Rep: Reputation: 15
Unfortunately, Xcompmgr is only really supported on nVIDIA linux drivers (correct me if I'm wrong). I'm using nVIDIA GeForce FX 5200 and the composite manager works like a charm, but most importantly, it works fast. This is still experimental, as the technology is bleeding-edge, but support should be emerging for ATI too. From what I've read though, nVIDIA is supported by Linux better than ATI and others...
Old 06-16-2005, 05:39 PM   #5
Registered: May 2004
Location: Wiltshire UK
Distribution: SuSE 9.2 AMD64
Posts: 50

Rep: Reputation: 15
xcompmgr is reported to work with ATI, but it's very buggy.
I run it with nvidia and its fine ... crashes occasionally but that just means i lose the eyecandy .. the system carries on just fine. HOWEVER if you dont have a pretty fast machine it WILL slow you down considerably.

The RenderAccell option makes a HUGE difference but this is only applicable to nvidia cards


just a quick tip for anyone that has it running in SuSE on a fast box, if you find the autolaunch for xcompmgr (/opt/kde3/share/autostart/xcompmgr.desktop) change the command to :

xcompmgr -c -f

then you get shadows as usual but all the windows fade in and out when you open/minimise/maximise/switch desktop etc...

looks really cool ... eats more resources though
Old 06-19-2005, 01:16 AM   #6
Registered: Aug 2004
Location: Wausau, WI
Distribution: SuSE Linux Enterprise Desktop 10
Posts: 193

Rep: Reputation: 30
Originally posted by Fartwiz
HOWEVER if you dont have a pretty fast machine it WILL slow you down considerably.
Not true, I run it on a 700 Mhz Computer with an NVidia Geforce 5200 and it runs smooth. Enabling GLX and running games like Warcraft III doesn't slow the games down either.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Transparent Gnome Terminal Ahmed Linux - Software 5 11-25-2005 09:04 AM
Transparent Gnome Terminal Ahmed Linux - Networking 1 10-24-2005 10:04 PM
Display transparent terminals, Gnome? johnnydangerous Fedora 4 02-10-2005 06:59 PM
Transparent gnome windows Zonednode Linux - Newbie 1 02-12-2004 09:54 AM
Transparent terminal in gnome 2.0 Cookie Linux - Software 1 10-17-2003 08:46 PM > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 07:37 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration