LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 03-17-2005, 10:00 PM   #1
R¬dical_úD
Member
 
Registered: Oct 2004
Location: New Jersey
Distribution: SuSE 10.0
Posts: 69

Rep: Reputation: 15
Full write access to vfat


I just reformatted one of my drives to FAT32 and I modified fstab so that I have write privilages as well. The problem is that I only have partial write privilages as a regular user and under root, Azureus seems to have a problem writing new files. Here's my current fstab file:

/dev/hda2 / reiserfs acl,user_xattr 1 1
/dev/hda1 /windows/C ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hdb1 /windows/D vfat iocharset=iso8859-15,users,gid=users,umask=0002 0 0
/dev/hda3 swap swap pri=42 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
sysfs /sys sysfs noauto 0 0
/dev/cdrecorder /media/cdrecorder subfs fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/fd0 /media/floppy subfs fs=floppyfss,procuid,nodev,nosuid,sync 0 0

I'm planning to convert hda1 to FAT32 as well to run Wine so I need to make sure I have absolute write power.
 
Old 03-17-2005, 10:14 PM   #2
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 60
even though you give users write access to the fat drive, and when it doesn't work
with azureus i think its just a buggy problem ...
cause i have full privledges to my user, and my root user for all secondary fat
drives, and i also have the problem with azureus ...
what i did is was go into the opitions under files on the left and put the check
mark on "allocate and zero new files on creation" and i never had a problem
since ...

and all i use for my fat drives is the following :
Code:
/dev/hdb1        /mnt/20gig       vfat        user,rw,umask=000         1   0
hope this helps .. i know the azureus thing bug the hell outta me for a while ...
 
Old 03-18-2005, 04:15 AM   #3
linmix
Senior Member
 
Registered: Jun 2004
Location: Spain
Distribution: FC5
Posts: 1,993
Blog Entries: 1

Rep: Reputation: 46
maybe the azureus problem is the same I had with aMule. It disappeared once I added 'exec' to my fstab line.

And since this question was about using wine and executing programs on a vfat partition (if I understand correctly) you may need 'exec' in your fstab as well
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SAMBA - VFAT local mount for all user write access... dolvmin Linux - Software 13 12-21-2006 04:50 PM
Can't get write permission to vfat Chomper Linux - General 9 01-13-2005 12:38 AM
What fstab mount setting do you use to get full access to a vfat drive? BarkingBonefish Linux - Newbie 4 03-12-2004 01:36 AM
Can't write to vfat and ntfs partitions linuxfond Linux - Newbie 7 11-12-2003 05:54 PM
vfat write permissions andrea.corelli Linux - General 4 04-23-2002 03:43 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 06:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration