LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 07-18-2006, 07:42 PM   #1
Red Knuckles
Member
 
Registered: Jan 2006
Location: Colorado USA
Distribution: Debian AMD 64 Testing, Sabayon Linux x86-64 3.4, and Ubuntu AMD 64 7.04
Posts: 235

Rep: Reputation: 30
Firewall Problems In Azureus, Suse 10.1


In Azureus I get NAT error even though I have my port enabled In >Firewall>Allowed Services>TCP and UDP. BUT if I stop the Firewall while Azureus is open then restart it I get NAT OK. How can I correct this? Seems to be a communication problem between Azureus and Firewall.

Or, as an alternative how do I configure GuardDog for Azureus? I have everything else [so far] working in GuardDog.
 
Old 07-18-2006, 11:25 PM   #2
Red Knuckles
Member
 
Registered: Jan 2006
Location: Colorado USA
Distribution: Debian AMD 64 Testing, Sabayon Linux x86-64 3.4, and Ubuntu AMD 64 7.04
Posts: 235

Original Poster
Rep: Reputation: 30
Wink

Quote:
Originally Posted by Red Knuckles
In Azureus I get NAT error even though I have my port enabled In >Firewall>Allowed Services>TCP and UDP. BUT if I stop the Firewall while Azureus is open then restart it I get NAT OK. How can I correct this? Seems to be a communication problem between Azureus and Firewall.

Or, as an alternative how do I configure GuardDog for Azureus? I have everything else [so far] working in GuardDog.
Well I'll be dipped in bleep and hung out to dry! I guess because I have a voip phone router I needed in >Yast>Firewall>Allowed Services>Internal Zone' to add my prefered Azureus port. I was adding it to Externel Zone'. Now if I could get my Firefox extensions to work in Swiftfox I'd be bleeping in tall cotton!
 
Old 07-18-2006, 11:28 PM   #3
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 128Reputation: 128
Glad you got it working, and thanks for posting your solution for other members to see and learn from!
 
Old 08-17-2006, 08:49 PM   #4
.Alexandru.
LQ Newbie
 
Registered: Aug 2006
Posts: 29

Rep: Reputation: 15
i am experiencing the same problems but i cannot get it working can you plz explain in depth how i can get azureus working???? it says NAT ERROR so can you plz explain so someone new to linux can understand plz.....thanks
 
Old 08-18-2006, 12:35 AM   #5
xbennyboy
Member
 
Registered: Jul 2004
Distribution: openSUSE 10.2
Posts: 141

Rep: Reputation: 15
Red Knuckles. Is your internet connection configured under external zone or internal zone? If its internal zone, that's why you had to add the Azureus port in the firewall internal zone section. I think if you had the internet connection configured as external, your previous port opening in the external zone would have worked.

Alexandru. Go to your azureus settings and check which port it is using. Then go to yast-> firewall and open a port in both TCP and UDP. If that doesn't work, just disable the firewall. I find that it isn't as useful under Linux as much as it is in Windows. Linux machines don't get hacked either way.
 
Old 08-18-2006, 03:41 PM   #6
.Alexandru.
LQ Newbie
 
Registered: Aug 2006
Posts: 29

Rep: Reputation: 15
i have tried and i am still having problems with azureus max download is 6.8kb/s is there anything else i can doo to have azureus running in good condition ??? it still shows the yellow icon all the time i have never seen it turn green only yellow i would appreciate any help thanks
 
Old 08-18-2006, 05:13 PM   #7
Red Knuckles
Member
 
Registered: Jan 2006
Location: Colorado USA
Distribution: Debian AMD 64 Testing, Sabayon Linux x86-64 3.4, and Ubuntu AMD 64 7.04
Posts: 235

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by xbennyboy
Red Knuckles. Is your Internet connection configured under external zone or internal zone? If its internal zone, that's why you had to add the Azureus port in the firewall internal zone section. I think if you had the Internet connection configured as external, your previous port opening in the external zone would have worked.

Alexandru. Go to your Azureus settings and check which port it is using. Then go to yast-> firewall and open a port in both TCP and UDP. If that doesn't work, just disable the firewall. I find that it isn't as useful under Linux as much as it is in Windows. Linux machines don't get hacked either way.
Not sure if Internet connection is internal or external. I have a voip phone router. It has it's own address as does my computer. The router connects to my Comcast address. I think that makes it an internal connection.

Also, I can get the Suse/Yast firewall to work for periods of time with Azureus but it doesn't keep working. Therefore I have disabled it and installed GuardDog which works fine with Azureus. For some reason I haven't figured out yet the Suse/Yast firewall and Azureus just don't work well together for me.
 
Old 08-18-2006, 05:18 PM   #8
Red Knuckles
Member
 
Registered: Jan 2006
Location: Colorado USA
Distribution: Debian AMD 64 Testing, Sabayon Linux x86-64 3.4, and Ubuntu AMD 64 7.04
Posts: 235

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by .Alexandru.
i have tried and i am still having problems with azureus max download is 6.8bk/s is there anything else i can doo to have azures running in good condition ??? it still shows the yellow icon all the time i have never seen it turn green only yellow i would appreciate any help thanks
See above post. I eventually disabled Suse/Yast firewall and installed GuardDog. You can get GuardDog here:

http://www.simonzone.com/software/guarddog/#download

Note there is a very helpful on line manual. Also you may need KDE to install and use GuardDog.
 
Old 08-18-2006, 10:16 PM   #9
.Alexandru.
LQ Newbie
 
Registered: Aug 2006
Posts: 29

Rep: Reputation: 15
ok i will try this and let you know thanks for the help so far i appreciate it and i hope it will work for me too
 
Old 08-18-2006, 11:13 PM   #10
drsketch1
Member
 
Registered: Apr 2006
Distribution: CentOS 6.X, pclinuxos
Posts: 50

Rep: Reputation: 15
If you are running suse as a desktop OS and have a router and or using NAT I think that is plenty of security for a firewall. That is unless you have malicious people inside your LAN
 
Old 08-19-2006, 10:43 AM   #11
.Alexandru.
LQ Newbie
 
Registered: Aug 2006
Posts: 29

Rep: Reputation: 15
my dsl is connected to a wireless router maybe im having trouble with azureus because im using wireless internet????????
 
Old 08-21-2006, 10:58 AM   #12
.Alexandru.
LQ Newbie
 
Registered: Aug 2006
Posts: 29

Rep: Reputation: 15
so what can i do?
 
Old 08-21-2006, 05:07 PM   #13
Red Knuckles
Member
 
Registered: Jan 2006
Location: Colorado USA
Distribution: Debian AMD 64 Testing, Sabayon Linux x86-64 3.4, and Ubuntu AMD 64 7.04
Posts: 235

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by .Alexandru.
so what can i do?
I don't know anything about wireless. But you may need to enable UPnP in Azureus and in your wireless router or use port forwarding in your wireless router to open a port for Azureus. Also in router make sure NAT is enabled. To enable UPnP in Azureus open Azureus>Options>Plugins>UPnP and check the box to enable [it normally is enabled by default]. To change settings in your wireless router you need to read the router manual, should be fairly easy though.
 
Old 04-12-2008, 09:46 PM   #14
jaysan
LQ Newbie
 
Registered: May 2001
Distribution: Slackware Linux 9.1
Posts: 23

Rep: Reputation: 15
I also had the same issues with azureus and guarddog.

Fixed the problem by enabling ip forwarding on the DSL modem/router. The modem/router can be configured via web interface, i guess this may depend on the hardware.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I configure firewall for Azureus??? Red Knuckles SUSE / openSUSE 4 01-23-2006 05:57 PM
Azureus +firewall: UDP-discovery drop packetsport 8008 alt_http What is Azureus doing Emmanuel_uk Linux - Networking 0 08-31-2005 06:06 AM
azureus torrent behind ADSL router firewall problem kpachopoulos General 2 08-27-2005 01:10 PM
Azureus can't install in SuSE 9.1 SolidSnakeX28 SUSE / openSUSE 4 07-02-2005 05:46 AM
stopping the linux firewall for azureus jax8 Linux - Newbie 1 11-18-2004 03:26 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 01:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration