LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   SUSE / openSUSE (https://www.linuxquestions.org/questions/suse-opensuse-60/)
-   -   F-spot crash in 10.1 (https://www.linuxquestions.org/questions/suse-opensuse-60/f-spot-crash-in-10-1-a-447103/)

fragos 05-21-2006 04:27 PM

F-spot crash in 10.1
 
This is a new install and F-spot always crashes on launch. Any ideas? -- George

Additional Information:
An unhandled exception was thrown: no such table: photos

in <0x00134> Mono.Data.SqliteClient.SqliteCommand:GetNextStatement
(IntPtr pzStart, System.IntPtr pzTail, System.IntPtr pStmt)
in <0x00136> Mono.Data.SqliteClient.SqliteCommand:ExecuteReader
(CommandBehavior behavior, Boolean want_results, System.Int32
rows_affected)
in <0x0002b> Mono.Data.SqliteClient.SqliteCommand:ExecuteReader
(CommandBehavior behavior)
in <0x00013> Mono.Data.SqliteClient.SqliteCommand:ExecuteReader ()
in <0x000da> PhotoStore:Query (System.String query)
in <0x005cc> PhotoStore:Query (.Tag[] tags, .DateRange range)
in <0x0002e> FSpot.PhotoQuery:.ctor (.PhotoStore store)
in <0x00944> MainWindow:.ctor (.Db db)
in <0x00046> FSpot.Core:get_MainWindow ()
in <0x00012> FSpot.Core:Organize ()
in <0x0071f> FSpot.Driver:Main (System.String[] args)
.NET Version: 1.1.4322.2032

Assembly Version Information:

FlickrNet (1.1.0.0)
System.Web (1.0.5000.0)
gconf-sharp (2.8.0.0)
pango-sharp (2.8.0.0)
SemWeb (0.5.0.2)
glade-sharp (2.8.0.0)
gtkhtml-sharp (2.8.0.0)
System.Data (1.0.5000.0)
Mono.Data.SqliteClient (1.0.5000.0)
gdk-sharp (2.8.0.0)
Mono.Posix (1.0.5000.0)
gnome-vfs-sharp (2.8.0.0)
dbus-sharp (0.60.0.0)
System (1.0.5000.0)
atk-sharp (2.8.0.0)
gtk-sharp (2.8.0.0)
glib-sharp (2.8.0.0)
gnome-sharp (2.8.0.0)
f-spot (0.0.0.0)
mscorlib (1.0.5000.0)

Platform Information: Linux 2.6.16.13-4-default x86_64 x86_64 GNU/Linux

Disribution Information:

[/etc/lsb-release]
LSB_VERSION="core-2.0-noarch:core-3.0-noarch:core-2.0-x86_64:core-3.0-x86_64"

[/etc/SuSE-release]
SUSE LINUX 10.1 (X86-64)
VERSION = 10.1

knetknight 05-25-2006 03:01 PM

i get the same error on one of my 10.1 boxes but not on another. i think it's a permissions issue because if i fire it up as root it works. you had any luck resolving this?

fragos 05-25-2006 04:48 PM

Root worked for me as well. If its permissions there is no indication permission error when running from terminal. I don't know what to chmod when all I get is:

An unhandled exception was thrown: no such table: photos

I may have to try digikam which has always worked for me but that's like letting the issue beat me. I tried "locate photos" but it only gave a list of unrelated files.

knetknight 05-26-2006 05:48 PM

FWIW, I recreated my user profile and then fired up f-spot and now it works great. The only thing "different" is that the first time f-spot ran (and subsequently didn't work) is when it autodetected that I had plugged in my digital camera. After I recreated my user profile I started f-spot manually first. Now when I plug in my camera f-spot starts up like it should. This doesn't pinpoint the actual problem but maybe it'll give you a little more to go on.

fragos 05-26-2006 07:10 PM

Thanks for the info. F-Spot crashes during launch so I have no GUI way to configure a profile for it. I'd still like to get it working but have tried a backup strategy that looks very inviting. Google now has a Linux version of Picasa which downloaded as an RPM and installed. It downloads with the latest version of wine and although a 32 bit application runs just fine on SuSE 10.1 x86_64. SuSE has done a great job with 32 bit compatability as part of the default installation.

knetknight 05-26-2006 10:09 PM

Quote:

I have no GUI way to configure a profile for it.
Aha, let me clarify -- I didn't create a new profile in f-spot, I completely recreated my user profile at the Linux account level. i.e. I backed up my home, deleted my account and home, recreated my account and home, and then restored only essential information from my backup -- things like ~/Documents, ~/.mozilla, and ~/.thunderbird.

This is my first time using f-spot, my wife really likes it too. I spent some time with it then showed her some cool things it does and how it can help organize our growing list of digital photos and she was really impressed. SUSE 10.1 looks so nice and works so well on our family computer that I was finally, after attempts with each previous version of SUSE since 9.0, able to convince my wife to use it now instead of Windows.

I've heard about Picasa but haven't actually tried it, what do you think of it?

ross_cav 06-04-2006 12:59 AM

I found this post that fixed the problem

http://mail.gnome.org/archives/f-spo.../msg00030.html

"Had you run f-spot before? Try moving ~/.gnome2/f-spot/photos.db out of the way and starting f-spot again. Let me know what happens then."

That's the main thing that I got from that other post, I just renamed my photos.db and ran f-spot again, worked no problem.

fragos 06-04-2006 01:41 AM

Thanks for the help.


All times are GMT -5. The time now is 06:08 AM.