LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 03-29-2006, 06:23 AM   #16
dpet
LQ Newbie
 
Registered: Mar 2006
Posts: 2

Rep: Reputation: 0

no I have an ups
 
Old 05-09-2006, 10:18 AM   #17
ZeromusM
LQ Newbie
 
Registered: May 2006
Distribution: OpenSUSE 10.0
Posts: 27

Rep: Reputation: 15
As a note to those who use the command line to create users:

When using useradd to create users, use the -m (create home directory) option if you want that user to use the desktop, otherwise you will run into the "Could not start kstartupconfig" error being discussed here.

Another way to fix this problem is to create the home directory manually, chown it as mentioned above, then change the user to point to that home directory:

mkdir /home/foo
chmod user:users /home/foo
usermod -d /home/foo user

To make things easier, the home directory should be the user name, but you can make it anything you want this way.
 
Old 05-19-2006, 07:50 PM   #18
anatman
Member
 
Registered: May 2006
Location: NEWBIE!
Distribution: Ubuntu 6.06
Posts: 31

Rep: Reputation: 15
I have a somewhat similar problem I think. After updating lots of stuff through the auto-update thingie in KDE I come to the command line whenever i start or reboot the computer. Being a complete newbie i tried typing: 'kde' <enter> and got these messages:

Quote:
pdyinfo: unable to open display
pdyinfo: unable to open display
/opt/kde3/bin/starthde.therm:line 122[:-gt:unary operator expected]
(same for line 123,126,127,128, and 129)
xset: unable to open display
xset root: starting up...
kde init: aborting -$display is not set
Warning: connect() failed: no such file or directory
tosmserver:cannot connect to x server
ERROR: Couldn't attach to DCOP server!
startkde: shutting down...
Warning: connect() failed: No such file or directory
Error: Can't contact kdeinit!
Starting artsd
kcminit:cannot connect to X server
startkde: Running shutdown scripts
startkde: done.

and then I'm back on the command line. So I tried these commands:

Quote:
Originally Posted by ganeshv
I logged into the shell prompt (using System->Command line) and reset the PATH variable by executing:
export PATH=$PATH:/bin:/usr/bin/

Then I was able to use all the basic commands. So, then I executed:
chown -R username:users /home/username

I logged in as root (su), and deleted the .X0-lock file in /tmp directory. I also updated the PATH for all users in the .bashrc file.

Thats it! It all works fine now.

hope this helps,
Ganesh
ganeshv@ufl.edu
The first command (export..) worked (at least no error message).

The second command I just don't understand. Is username my username? and users? I tried with my username but got the error message: chown: missing operand after <<users/home/myusername>>

Then I just guessed and tried:

Quote:
chown -R myusername: /home/myusername
and that gave me no errormessage, but I still get to the command line, not KDE, after rebooting.

And lastly I couldn't find the -XO-lock file in the tmp directory. I looked in /tmp and no such file was there for me to delete as I could see.


Any ideas on how I can get this to work?
 
Old 05-20-2006, 11:05 AM   #19
ZeromusM
LQ Newbie
 
Registered: May 2006
Distribution: OpenSUSE 10.0
Posts: 27

Rep: Reputation: 15
anatman:

It sounds like you might not be starting in the proper runlevel. To get the X server, you need to be at runlevel 5. When you start up to the command line, either log in as root or type in "su" if you're already logged in, enter the root password, then type in "runlevel", which will return your current runlevel (1-5)

1 is single user command line mode, with no other terminals available, 3 is multi-user command line mode, and 5 is full graphical mode. The X server and KDE are only available in 5.

If runlevel returns anything other than 5, type in "init 5" as root

After typing in init 5, you should either get the KDE login screen, or some error messages saying why it isn't coming up.

oh btw, chown = change ownership, with username being the username you want to own that file, in this case yours. users is the group your username most likely belongs to.
 
Old 05-20-2006, 06:10 PM   #20
anatman
Member
 
Registered: May 2006
Location: NEWBIE!
Distribution: Ubuntu 6.06
Posts: 31

Rep: Reputation: 15
Thanks ZeromusM. I ran runlevel as root and it said N 5 so I guess that means I'm level 5? This time I got both the export and the chown command working, and my runlevel is 5, but I still can't start kde. So I want to find the .XO-lock file in the /tmp directory, to delete it. Where can I find this file? Anyone know? In the /tmp directory there were files like:

Quote:
gconfd-myusername
gconfd-root
kde-myusername
kde-anotherusername
kde-root
klik
ksocket-myusername
ksocket-anotherusername
ksocket-root
orbit-myusername
but no .XO file?
 
Old 05-20-2006, 08:07 PM   #21
ZeromusM
LQ Newbie
 
Registered: May 2006
Distribution: OpenSUSE 10.0
Posts: 27

Rep: Reputation: 15
Yeah that means you're at runlevel 5. I don't think your problem is what is being talked about here, because when this happens, you will get the graphical login screen, then a popup at login. What you want to do is look for errors in /var/log/Xorg.0.log and dmesg (type "dmesg" to get the output). Also, I assume you typed in "kde" to try to get kde working again - what did the output of that say?

Cut and paste output always helps more than a description of the problem, so the exact wording of any messages you find would be appreciated.
 
Old 05-21-2006, 09:23 AM   #22
anatman
Member
 
Registered: May 2006
Location: NEWBIE!
Distribution: Ubuntu 6.06
Posts: 31

Rep: Reputation: 15
Yes there were some errormessages both in the xorg logfile (no screens found) and kde, and dmesg, but how can I get the output of those files on a floppy so I can copy it on here? I'm using Kubuntu 5.10 live until I get it fixed...
 
Old 05-26-2006, 10:29 AM   #23
ZeromusM
LQ Newbie
 
Registered: May 2006
Distribution: OpenSUSE 10.0
Posts: 27

Rep: Reputation: 15
anatman: Please refer to and reply to: Problem starting KDE - xorg no displays found
 
Old 11-15-2006, 07:15 AM   #24
navyanthgn
LQ Newbie
 
Registered: Nov 2006
Posts: 1

Rep: Reputation: 0
Red face kstartconfig error

Hi Guys

chown -R navi:users /home/navi
this worked for me.

I created the home directory, as it was not created before and then executed this above command.
It worked.

-Navyanth
 
Old 02-19-2007, 02:54 AM   #25
flipflopnick
LQ Newbie
 
Registered: Feb 2007
Posts: 2

Rep: Reputation: 0
kstartupconfig error

Thanx for the thread. had similar fault, tried everyone suggestions. Realised having /home on FAT32 partition meant problems with write permissions.
So moved /home to a linux file system partition, with symlink to FAT32 partition.
Set FAT32 partition to automount in fstab.
That got rid of one error.

Then logged on as root, created 'users' with their 'home' directories in new /home, on a linux partition.

Moved any data files across to new 'user's' home directories.
got rid of old config files in old FAT32 partition.

Now to get other errors fixed.
 
Old 03-22-2007, 06:52 AM   #26
edubidu
Member
 
Registered: Mar 2007
Location: Switzerland
Distribution: Ubuntu
Posts: 32

Rep: Reputation: 15
Hi, my problem was: I used SMB login and Kerberos. So, the user I logged had the same name @ local as @ the domain, but the domain user could not write into /home/user/.kde
Normal, cause the domain user is considered as another user than the local user, even if it has the same name....

THE SOLUTION: go into user management (I use Suse10.2 so: yast2), configure Expert Options - Authentication and User Data Sources - Samba

As domain Membership click "yes" to "Create Home Directory on Logon"

That's it.
 
Old 03-28-2007, 11:23 AM   #27
nj78
LQ Newbie
 
Registered: Mar 2007
Distribution: Suse
Posts: 1

Rep: Reputation: 0
In response to above, about display not set, I would use startx. That seems to always work past this.
 
Old 03-15-2008, 02:05 PM   #28
dpeirce
Member
 
Registered: Mar 2004
Location: Central Texas
Distribution: Kubuntu, Fedora, DamnSmall, etc, etc
Posts: 78

Rep: Reputation: 15
Still happening! March 15, 2008, ver 10.3

Hi guys. Here it is March 15, 2008, and it bit me too. OpenSUSE 10.3. No /home/dave. The chown fix worked for me too. BUT BUT.....

If somebody from OpenSUSE is looking in, isn't it time this got corrected? It's been going for almost 3 years now.

This is my first time to try OpenSUSE and its installation, anyway, is pretty impressive. The installation went well and offered me more control over partitioning and setup than any others I've experienced. It even let me set screen resolution at my favorite 2048x1536 during the install. But, even though it said it had set up my wireless, it hadn't ^_^. And this "Can't start kstartupconfig" thing.

In faith, Dave
Viva Texas

Linux: Welcome /home.
 
Old 06-19-2008, 02:14 PM   #29
hitman_vivek
LQ Newbie
 
Registered: Jun 2008
Distribution: SUSE 10.3 ,11 , Redhat enterprise server,
Posts: 5

Rep: Reputation: 0
Lightbulb Could not start kstartupconfig. Check your installation

while creating the user account use the command as follows
" useradd -m <username>"
-m indicates it to create the home directory for the specified user.
After creating the account ,you should be able to login into the newly created account
 
  


Reply

Tags
linux, suse


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
unable to start kstartupconfig error manis SUSE / openSUSE 6 09-19-2012 05:01 AM
Starting MySQL OLD Error : imeout error occurred trying to start MySQL Daemon Fr33B5D Linux - Software 9 10-28-2006 06:23 AM
error on fluxbox start ... marlor Slackware 1 08-03-2004 08:08 PM
apache2ctl start <--- error mrosati Linux - Software 6 06-03-2004 12:49 PM
apachectl start error emsky Linux - Newbie 1 04-04-2004 12:16 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 04:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration