Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
SUSE / openSUSE This Forum is for the discussion of Suse Linux.


  Search this Thread
Old 03-23-2007, 09:01 AM   #1
LQ Newbie
Registered: Mar 2007
Posts: 1

Rep: Reputation: 0
Domain users are unable to automount disk(or flash)

Hi all

OS: OpenSuse 10.2 + KDE

OpenSuse was added into Windows 2003 domain through Yast without problems.
Domain Users can login to OpenSuse using domain credentials.

But unfortunately I've got few problems:

1. Users do not have access to the audio device. The problem went as follows
a) In /etc/security/group.conf add a new line

; *; *; Al0000-2400; dialout, video, cdrom, audio
b) in /etc/pam.d/common-auth add line

auth optional
The sound device for the domain user has been available.

2. Automounting does not work.

When automounting CDdrive or flash (under the domain user) displays the
following error:

kded: ERROR: mount failed
for /org/freedesktop/Hal/devices/volume_label_SU1020_001:
org.freedesktop.DBus.DBus.Error.AccessDenied - A security policy in
place prevents this sender from sending this message to this recipient,
see message bus configuration file (rejected message had interface
"org.freedesktop.Hal.Device.Volume" member "Mount" error name "(unset)"
destination "org.freedesktop.Hal")

Found seems to be a solution to the problem ... In the article had been
proposed by the next version of a solution to the problem :

BTW: The policy can be changed in /etc/dbus-1/system.d/hal.conf
<policy group="500">
<allow send_interface="org.freedesktop.Hal.Device.SystemPowerManagement"/>
<allow send_interface="org.freedesktop.Hal.Device.LaptopPanel"/>
<allow send_interface="org.freedesktop.Hal.Device.Volume"/>
<allow send_interface="org.freedesktop.Hal.Device.Volume.Crypto"/>
By adding this to the end I can now mount everything as my user and
root. group 500 is users on my system. Thanks a lot Jurg. Also as a side
note, You can't have more then one option in the policy tag, you have to
create multiple policy tags.

I have a "user" local group, I added these lines only by changing <policy group="users"> .
Added the "users" to a file /etc/security/group.conf :

; *; *; Al0000-2400; dialout, video, cdrom, audio, users

Reloaded service hal...... But the problem still remain:
"kded: ERROR: mount failed for /org/freedesktop/Hal/devi....."

Please tell me how can we solve the problem?

FRIDAY\all@Daz-Work:~> id
uid=10000(FRIDAY\all) gid=10000(FRIDAY\domain users)
group=16(dialout),17(audio),20(cdrom),33(video),100(users),10000(FRIDAY\domain users),10001(FRIDAY\domain admins),10002(FRIDAY\programmers)

In /var/run/resmgr/classes /, in all folders have a file FRIDAYall

FRIDAY - Domain Name
all - Domain User


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
copy a file to the flash disk and extract it from the flash disk indu.a Linux - Kernel 2 11-15-2006 03:22 AM
KDE won't automount flash drive pxumsgdxpcvjm Debian 4 07-26-2006 09:51 PM
fstab, automount usb flash HPB Linux - Newbie 10 05-31-2006 05:35 PM
Mandriva 2006 USB flash Drive Automount casperbg Linux - Hardware 4 10-20-2005 01:43 PM
Flash disk automount sixth_sense Linux - Hardware 3 08-07-2005 04:54 PM > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 09:09 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration