LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 01-25-2006, 02:14 AM   #1
melenex
LQ Newbie
 
Registered: Jan 2006
Posts: 5

Rep: Reputation: 0
Display problems after installation ATI


Hello.. i just downloaded SuSE Linux 10.0 yesterday and installed everything. The installation went fine, but after everything finished, when i restarted the machine, linux boots fine, but i get a black screen that says "Cannot display video mode".
I have a ATI Radeon x600 video card. And installing Linux in 64 bit.
Thank you
 
Old 01-25-2006, 03:17 AM   #2
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,513

Rep: Reputation: 58
Try to configure your monitor with sax2. Change to textconsole with Ctrl+Alt+F1, login as root, type init 3 and sax2, enter your monitor data, test, save and exit. Type init 5 and hope it will work.
 
Old 01-25-2006, 01:22 PM   #3
victorh
Member
 
Registered: Jul 2005
Location: La Paz, Bolivia
Distribution: Debian Sarge - Sid, Slackware, Gentoo, openSuse, Fedora, Ubuntu, Mandriva
Posts: 241

Rep: Reputation: 30
If you want 3d acceleration of your ATI card, you must install the propietary driver of ATI, the latest one is ati-driver-installer-8.21.7-i386.run. Please note that even sax2 will recognize your graphic card it will not install this driver and therefore you'll not have 3d acceleration. Even more important after installing the ATI driver, you have to run fglrxconfig, this script will overwrite the file /etc/X11/xorg.conf. I'll suggest you do the following:
1. Run sax2 as pointed by abisko00. This will overwrite your xorg.conf file. By default sax2 will choose a driver I believe it is ATI or something like that, if you have problems starting X, you can change this driver with:
Driver "vesa"
this will enable you to start X safely until you install the propietary driver, since ths driver always work.
2. Install the ATI propietary driver in a Linux 64-bit is a little more complex, I suggest you follow the instructions of this page:
http://linux.wordpress.com/2005/10/1...-installation/
3. Check if you have the driver properly configured, type:
Quote:
$ glxinfo
you must see the following in the first lines
Quote:
name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
If you have this, you are done! You can see the real power of your graphic card while playing TuxRacer or GL-117, enjoy it!
 
Old 01-25-2006, 08:28 PM   #4
melenex
LQ Newbie
 
Registered: Jan 2006
Posts: 5

Original Poster
Rep: Reputation: 0
Ok.. i did that already. I tried running sax2, but the computer just freezes. I tried a bunch of times more but i always end up with a black screen. Same as YaST. i tried doing that and when i click on the Video card and Monitor option i get the "Unable to display this video mode".
As for installing the drivers. I downloaded the .run file to my windows directory. When i log in as root on linux i try following the instructions on the page. I type ./ati-driver.... but then it says Access denied.
Any other suggestions?
 
Old 01-25-2006, 08:51 PM   #5
csmall011
LQ Newbie
 
Registered: Jan 2006
Location: Central California
Distribution: Suse 10.2
Posts: 4

Rep: Reputation: 0
As far as the "Access Denied" message. Navigate to where you downloaded the driver file. Right click on the file and choose 'Properties'. Then choose the 'Permissions' tab. Then ensure that 'Execute' is checked.

Enjoy and keep trying!!!
 
Old 01-25-2006, 09:18 PM   #6
victorh
Member
 
Registered: Jul 2005
Location: La Paz, Bolivia
Distribution: Debian Sarge - Sid, Slackware, Gentoo, openSuse, Fedora, Ubuntu, Mandriva
Posts: 241

Rep: Reputation: 30
Hi melenex, it seems very rare that you can't run sax2, did you do it as root?, did you do it in a console? (or the equivalent in init level 3?).
Anyway, if you can't run it, you can always edit manually the file /etc/X11/xorg.conf and configure it by yourself. In order to do that, you must know the exact reason why X is not working. Could you post the result of the following command?
Quote:
cat /var/log/Xorg.0.log | grep "(EE)"
With this info we can give you more suggestions.
 
Old 01-25-2006, 10:35 PM   #7
melenex
LQ Newbie
 
Registered: Jan 2006
Posts: 5

Original Poster
Rep: Reputation: 0
Ok.. as far as the Permission Denied goes.. under windows i click on "properties".. but theres no permission tab. At the bottom it says Attributes. But theres only 2 options, read-only and hidden. They are both unchecked.

To answer Victorh.
This is what it says when i type cat /var/log/Xorg.0.log | grep "(EE)"

(WW) warning, (EE) error, (NI) not implemented, (??) unknown

Thats about it.

And the sax2 thing.. it does run. it just freezes. yeah, i ran it under init 3 as root.
 
Old 01-26-2006, 08:48 AM   #8
victorh
Member
 
Registered: Jul 2005
Location: La Paz, Bolivia
Distribution: Debian Sarge - Sid, Slackware, Gentoo, openSuse, Fedora, Ubuntu, Mandriva
Posts: 241

Rep: Reputation: 30
Hi melenex, the objective of posting the result of the command cat /var/log/Xorg.0.log | grep "(EE)" was to find the reason why X is failing to start, the command cat prints the file /var/log/Xorg.0.log in the console and this result is filtered with the command grep to show us only the lines that start with (EE), i.e. the lines that describes the errors while starting X. Unfortunately with your last post we can't have this info. Then I'll have to ask you to post the entire file /var/log/Xorg.0.log, this file logs all the information regarding X, be ware that this file is quite long. Also can you post your current configuration of X? this is located in the file /etc/X11/xorg.conf. So in a console type the following commands
Quote:
cat /etc/var/Xorg.0.log
cat /etc/X11/xorg.conf
and copy the results.
Just be patient and hang on.
 
Old 01-26-2006, 11:38 AM   #9
RedShirt
Senior Member
 
Registered: Oct 2005
Location: Denver
Distribution: Sabayon 3.5Loop2
Posts: 1,150

Rep: Reputation: 45
Quote:
Ok.. as far as the Permission Denied goes.. under windows i click on "properties".. but theres no permission tab. At the bottom it says Attributes. But theres only 2 options, read-only and hidden. They are both unchecked.
Dear God... I sincerely hope you don't mean Windows. I hope you mean in the window manager... you can't do anything in Windows for SuSE... you need to run SuSE, even if only in command line to make these changes. executable is an option for unix, not windows/dos. You can use command line to change it to executable if you don't have SuSE's graphical options available.
 
Old 01-27-2006, 07:27 AM   #10
Dubious Dave
Member
 
Registered: Jan 2006
Location: Tampa, FL. USA
Distribution: Fedora
Posts: 108
Blog Entries: 7

Rep: Reputation: 17
ATI driver problem

It really sounds like you are running 'microsoft windows' when you are trying some of these suggestions. The not being able to find the 'permissions' tab, only seeing a check box for 'read only' and 'hidden', and "I downloaded the .run file to my windows directory.".

If you are downloading files while running a microsoft windows product and then rebooting to linux, you won't be able to access any of them.
 
Old 01-27-2006, 08:18 PM   #11
melenex
LQ Newbie
 
Registered: Jan 2006
Posts: 5

Original Poster
Rep: Reputation: 0
I know.. im a loser. Anyway, yeah i was doing all that in windows because i dont know how to do it off of linux. I can start linux in text mode only, init 3. Because if i try to do it in graphics mode it wont. Anyway, i tried changing the properties of the file using chmode but that didnt help, it kept saying "Permission Denied". Maybe you can tell me how to change it so its executable. Also, i downloaded the file using windows, to my C:/ directory, should i copy this file while on linux? if so, how do you copy..
Thanks and sorry for the ignorance.
 
Old 01-27-2006, 09:01 PM   #12
RedShirt
Senior Member
 
Registered: Oct 2005
Location: Denver
Distribution: Sabayon 3.5Loop2
Posts: 1,150

Rep: Reputation: 45
pheeeeeeeeeeew.

Okay step one. You need to be root to access higher level commands. As a normal user, you cannot chmod or chown unless you are the owner. This means you needs to type "su" and your then hit enter(su is short for super user, to give yourself root access temporarily). Then it prompts for password, so put that in. Then you can use commands like chmod and chown.(change privileges and change ownerships).

Okay, then as root, you can fire up "sax2". Let sax2 configure stuff, and hopefully it will set up a new xorg.conf to get you bootable into graphical mode where you can begin the rest of the process. There is a CLI(command line) way of changing a file to executable, but I don't recall it offhand, as I use the GUI a lot more.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ati display nforce2 mewgle Linux - Hardware 12 11-08-2005 08:13 PM
Display problems with Dell 2005FPW screen and ATI x850 xt pt weston_skye SUSE / openSUSE 2 08-02-2005 09:39 AM
After updates: ati driver installation problems 4hp Fedora 0 09-16-2004 02:38 PM
ATI Radeon 9000 pro Dual Display Problems komby Linux - Hardware 12 09-10-2003 03:33 AM
display problems with ATI - Radeon TDEE Linux - Hardware 2 08-08-2002 10:29 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 07:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration