Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
SUSE / openSUSE This Forum is for the discussion of Suse Linux.


  Search this Thread
Old 02-09-2006, 07:59 PM   #1
LQ Newbie
Registered: Jan 2006
Posts: 3

Rep: Reputation: 0
DHCP problem with D-Link Router


I have a D-Link DI-604 router. It has a DHCP server
which allocates IPs in the range

I setup my linux box with Yast and configured DHCP.
When I boot first time after a power off, it boots
and is unable to get an Ip Address.
ifconfig shows a inet6 address but no inet address.

If I reboot(without power off), I now get an inet
address and I am able to connect to internet.
rc3.d/S05network restart does not help either.

I have tried cloning the dynamic address
in the router for the linux machine mac address
so that the linux eth0 always gets the same ip,
but this did not help.
I have to reboot to get the inet address every time.
I also upgraded the router firmware to the latest

I have Suse 10.0 on a Del PC.

Can anyone help with this problem please ?


Last edited by jaijeet; 02-09-2006 at 11:06 PM.
Old 02-10-2006, 12:56 PM   #2
Registered: Sep 2004
Distribution: SUSE 10.0 OSS
Posts: 261

Rep: Reputation: 30
Just a suggestion:

Do like you did in the router setup - in browser window, enter username and password, go to dhcp, make current ip static from dhcp, done there.

go to yast, setup network card, edit config, set the static ip there. You will have to set the mask, always unless you changed it. You should add default gateway, and maybe even add your isp's dns lookup servers - found in status of the router setup.

Don't have a clue if it will work but the one thing I noticed from your post is you didn't set up the card in yast to static ip.
Old 02-10-2006, 01:23 PM   #3
LQ Newbie
Registered: Jan 2006
Posts: 3

Original Poster
Rep: Reputation: 0
Hi jdblick,

Thank you for yr suggestion. But I really don't want to set it up with a static IP.
I have dynamic PPPoe and I am not sure when the ISP might change their DNS servers.

I would want the DHCP client to get the inet address correctly at the first boot.
I don't want to boot twice every time to get the inet address.

Is there anything I need to do with DHCP client setup on linux ? I am curious
how it works on the 2nd reboot ? Maybe something gets set during the boot process
and I need to configure that in boot.local or something

Old 02-10-2006, 01:33 PM   #4
Registered: Sep 2004
Distribution: SUSE 10.0 OSS
Posts: 261

Rep: Reputation: 30
broch said in another thread:

1) disabling IPv6 for KDE only:
Yast -> System -> sysconfig editor -> Expand "Desktop" scroll down to
and set this to "no"
restart KDE session

2) disable IPV6 in whole system:
open terminal window su to root, and enter
#echo "alias net-pf-10 off" >> /etc/modprobe.conf
#echo "alias ipv6 off" >> /etc/modprobe.conf

restart computer

3) disabling IPv6 in FF only
enter in the address bar:
(no spaces above)
in search filter enter ipv6
from false to true

method 2) is best.
maybe that will be helpful?


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
D-link G604T adsl wireless router problem linux_yearner Linux - Wireless Networking 2 10-11-2005 08:54 AM
D-Link 604 router w/ DHCP chbin Linux - Networking 4 03-26-2005 11:37 PM
WEIRD connection problem w/ D-Link Router iminj Linux - Networking 15 10-28-2004 06:21 PM
DHCP problem with Fedora Code 1 / D-Link DWL-650+ atlantanewbie Linux - Wireless Networking 1 05-09-2004 02:01 AM
D-link router and web server problem peteABK Linux - Networking 0 06-02-2003 03:30 PM > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 02:58 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration