LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   SUSE / openSUSE (https://www.linuxquestions.org/questions/suse-opensuse-60/)
-   -   delete the home folder and trash icon (https://www.linuxquestions.org/questions/suse-opensuse-60/delete-the-home-folder-and-trash-icon-599022/)

dissident_goodchild 11-12-2007 07:55 AM

delete the home folder and trash icon
 
How I delete the home folder and trash icon of the desktop?

Simon Bridge 11-12-2007 08:14 AM

rt-click on it and select "move to trash"?
Then "empty trash"... but wait: you've just deleted it!

look in ~/.Desktop perhaps?

dissident_goodchild 11-12-2007 08:26 AM

Of course ;)

Home icon: the option is disabled.
Trash icon: the option not exists.

Simon Bridge 11-12-2007 10:45 PM

Quote:

Originally Posted by simon
look in ~/.Desktop perhaps?

You know, most people have trouble just getting those on the desktop.

dissident_goodchild 11-13-2007 08:25 AM

The folder .Desktop is not available. Has to be some configuration of the system. Thanks by you interest.

Simon Bridge 11-13-2007 09:19 AM

How about .desktop

http://docs.kde.org/userguide/custom...erminaloptions

colucix 11-13-2007 02:06 PM

On my Opensuse 10.3 I have not the Home icon on the desktop, but in the bottom panel only. Anyway, they are stored in directory $HOME/Desktop and are those files with extension .desktop. If you want to remove the trash icon, I suggest to do simply
Code:

cd ~/Desktop
mv trash.desktop trash.desktop.bck

it will immediately disappear. But you can also restore it later.

dissident_goodchild 11-17-2007 10:43 AM

:(

How can they appear in my desktop having the same version?, openSUSE work of very different ways in each installation and computer.

The files .desktop are not available.

I will leave it just as comes, but seems interesting to understand this.

colucix 11-17-2007 02:00 PM

Quote:

Originally Posted by dissident_goodchild (Post 2962102)
openSUSE work of very different ways in each installation and computer.

The files .desktop are not available.

I have installed different releases of SuSE/OpenSUSE through years on different machines and the feeling is almost the same. The file.desktop are the way to address icons in KDE, which is installed by default. Maybe you're running GNOME or some other desktop environment?

Simon Bridge 11-17-2007 10:20 PM

Yep, I thought .desktop was there by default in KDE. And this is not distro-specific. The OpenSUSE DVD has the option to install gnome, however.

In gnome there is a file called "Desktop" sitting in the user home directory. But you should go to
Applications-->System Tools--->Configuration Editor

... instead.

dissident_goodchild 11-19-2007 08:43 AM

solved
 
That's right, I did not mention the desktop environment, sorry!

Fine!, I found the solution in /apps/nautilus/desktop/trash_icon_visible key of GNOME Configuration Editor.

Thanks to all.

Simon Bridge 11-20-2007 02:30 AM

moo hahahahahaha! All us bigwig experts!
:o It took 9 posts... oh boy. :o

colucix: well done.

I thought I was able to delete them, but now realize that I was using a launcher instead.
Hmmm... mine's using the wrong trash icon, all the others follow the theme but that one. Oh well - disable.


All times are GMT -5. The time now is 12:27 AM.