-   SUSE / openSUSE (
-   -   cups daemon/lpr won't print (

rzavarella 03-20-2005 11:13 AM

cups daemon/lpr won't print
Hi, I'm a newbie and I'm very confused. I've tried installing my printer many times and it just won't print a test page at all. I'm using Suse 9.2 on a compaq nx9030 laptop. I have an HP deskjet 940c. The firewall is automatically set to "closed", I don't know if that makes a difference.

When I go to yast and run the printer configuration, everything seems fine until it "checks the environment" and I get a "Cups daemon died during installation" error message. It runs through the rest fine until it gets to "Load current settings" and then I get another "Cups daemon" error message.

When I go to the "Edit Configuration" part and I try to print a test page, I get this error message:

"An error occurred while communicating with the Cups serverwhile serving queue y2test. Error while contacting Cups server occurred"

"Unable to print test page. Output from lpr: error-unable to print file: server-error-service-unavailable."

I am at a total loss as to what to do. I've done Google searches for every key word I can think of and no help..... I"ve posted on forums and no help.... AAAHHH!! I"ve had this computer for 3 months and I cannot use it fully, it's very frustrating. Please help me, it is greatly appreciated!!!

PS I'm very bad at the command line but I tried "rccups restart" (per the advice of one wiser than me) and it worked fine. At the end it said: "Child exited with status 98!" What is status 98?


cylix 03-20-2005 01:06 PM

Not a Suse person...

Let's hope they haven't bastardized CUPS too much.

Just by chance, can you goto localhost:631 in a browser. (assumming you are at console)

Something else that might be helpful, before you do anything, open up a terminal.
There type tail -f /var/log/cups

Then fool around with whatever it is you normally do. Tail will constantly poll the last lines of the log file and give a real time reading of whats going on. (At least as far as logs are concerned)

This might shed some light on the problem.

Also, make sure all your packages are up to date as well.

rzavarella 03-20-2005 01:28 PM

Hi, thanks for your reply!

I couldn't connect to localhost 631, it said "connection refused."

I typed tail -f /var/log/cups and this is what I got:

linux:/home/rzavarella # tail -f /var/log/cups
tail: error reading `/var/log/cups': Is a directory
tail: /var/log/cups: cannot follow end of this type of file; giving up on this name
tail: no files remaining

Ummm....... I have no idea what this means

naps 03-20-2005 03:50 PM

I'm glad you are getting help on this rzavarella; cylix has been really helpful to me in my query about printing (similar problem to yours; see my post below). I am quite awed about how complex printing is under linux; fortunately SuSE (like most new distros) makes it easy. The printing how-to says

8. How to set things up

For common configurations, you can probably ignore this section entirely -
<<SNIP>> Most GNU/Linux distributions supply one or more
"idiot-proof" tools to do everything described here for common printers.

So just use YAST2!


Originally posted by rzavarella

I couldn't connect to localhost 631, it said "connection refused."

This is what will happen if you are getting the status 98 child error. The official explanation for this error is that some other demon is already using the port, but I suspect SuSE has ensured that that does not in fact happen. See cylix's reply to my post below to see how to verify this is not the source of your problems. I presume you have not been editing your cupsd.conf file, so the other thing to correct also does not apply. But you should also check the file called error_log which is in your /var/log/cups directory. (which is why you got the message)

tail: error reading `/var/log/cups': Is a directory
and all the other stuff. so do tail /var/log/cups/error_log or, instead of tail, use the command cat if you want to see more of it or view if you want to use vi (good to learn) without risking altering the file. But the easiest is just to point and click your way there and click on it in konq (starting by clicking on the house symbol on your kicker).
To get your problem licked you might have to remove and re-install the cups packages that I did (see my post; no gaurantees especially as my SuSE is different to yours; the risk is all yours!) (Also on reading your first post I see you are using an HP inkjet so that package might be a problem, for all I know. I had already removed it as I do not have an HP inkjet and was going to re-install it when I got a message to run some script.. so I hope someone else can advise you on that).
One more thing before I go to bed; I did manage to use the cups utility in my browser (http://localhost:631) after re-installing and restarting cups as you did in an earlier post BUT only after changing the password for the user lp. This is something that SuSE have done for security reasons, so I suggest you don't bother and stick to YAST with its' point and click management of printers.
Good luck

rzavarella 03-28-2005 09:04 AM

I tried uninstalling and reinstalling the hp driver in YAST2. When I got to the part where I had to reinstall the driver and go to the terminal to type the command for the setup, I got this:

linux:~ # /usr/sbin/ptal-init setup
-bash: /usr/sbin/ptal-init: No such file or directory

Umm.... yeah. No idea what to do next.

I tried to just reinstall the driver without typing in the command but I guess you can't do that because I am back to square one; the printer wouldn't work. The odd thing is that YAST2 recognizes the printer itself; maybe something is wrong with the spooler thing? Or the queue? I'm still getting the same error messages as I was getting in the first post.

::stuck floating in printer purgatory::

sudya 03-28-2005 10:44 AM

Make sure that you see that cups is loading at the beginning(well actually ending) of a booting process. In case you missed it, try to check the status of cups:

/etc/init.d/cups status
IF it is not working try to start it - ste same command but put start instead of status or restart if you want to restart it(it is always a good idea to try to restart it). Then checkif it really working - goto any browser and type http://lcalhost:631 - it should give you a cups page, if not write what went wrong

naps 03-28-2005 04:56 PM

That is a useful suggestion that sudya made. I tried it from a normal (i.e. non-root) shell and got the no such file. So the question is, Rachel, are you sure you tried to run /usr/sbin/ptal-init from a root console? Are you sure there was a# sign at the end of the prompt instead of the usual > ? On my machine the root console in KDE has a lurid yellow to remind me to be careful working as root. Like if I use the switch user menu item in KDE (it has a rocket icon) and switch to root the wallpaper is bright red; you could try that... then everything you do is as root. Just use root as the username when switching.
It worked fine on my machine when I had to reinstall that package... The other possibility is a small error in typing the command, like an extra space or capitalisation. Easy to do and sometimes hard to spot. To see where the typo is, get the command back by using the up arrow on the keyboard. Go to the beginning of the command (with the arrow key) and add ls followed by a space followed by /usr/sbin/ptal-init. Hit enter and it should show you the name of the file (in green because it is a script). If not get back the ls /usr/sbin/ptal-init and backspace out the ptal-init. You MUST have a /usr/sbin directory so if still "no such file" you still have a typo, so backspace out more till you find it.
P.S Sometimes when I restart a root console I lose the access to the commands I typed last time it was open, so you might just have to type it in again ( /usr/sbin/ptal-init ) to get started. Also, if you are looking for the file with ls /usr/sbin/ptal-init , you dont need the setup at the end of the line.

rzavarella 03-29-2005 08:30 PM

Thank you for all of your help!! I tried to get the status of cups and this is what I got:

linux:/home/rzavarella # /etc/init.d/cups status
Checking for cupsd: unused
linux:/home/rzavarella # /etc/init.d/cups start
Starting cupsd done
linux:/home/rzavarella # cupsd: Child exited with status 98!

rzavarella 03-29-2005 08:35 PM

I took your suggestion and tried to delete some of the command. This is what I did, and what I got:

rzavarella@linux:~> su
linux:/home/rzavarella # /usr/sbin/ptal-init
bash: /usr/sbin/ptal-init: No such file or directory
linux:/home/rzavarella # /usr/sbin/ptal-init
bash: /usr/sbin/ptal-init: No such file or directory
linux:/home/rzavarella # usr/sbin/
bash: usr/sbin/: No such file or directory
linux:/home/rzavarella # /usr/sbin/
bash: /usr/sbin/: is a directory
linux:/home/rzavarella # /usr/sbin/ptal
bash: /usr/sbin/ptal: No such file or directory
linux:/home/rzavarella #

I guess I made a mistake in the beginning, but it says /usr/sbin/ptal is not a file or a directory... Do I have to add that or something?

naps 03-30-2005 01:49 AM


Originally posted by rzavarella

I guess I made a mistake in the beginning, but it says /usr/sbin/ptal is not a file or a directory... Do I have to add that or something? [/B]
No, it looks like you are doing everything right; I don't know why the file is not there (you could look for it using the Konqueror applet that you use to see the files in your home directory, just to be sure). This is after you re-installed the hp-officejet driver? Maybe it didn't install properly because CUPS is not working properly? I dunno.
Anyway, the main problem is that CUPS is not working (or keeps crashing) so I suggest the best thing is to uninstall the hp-officejet driver and get CUPS working before getting that working.

Ps you got it right with /usr/sbin/ptal-init, with the / before usr and the file-name ptal-init

osbie 04-04-2005 06:34 PM

I'm now having the same problem since the upgrade to 9.2 and 3.4.. was unable to connect to localhost:631 so i found the error log and found this:
Listening to 0:631
I [29/Mar/2005:22:04:02 -0800] Loaded configuration file "/etc/cups/cupsd.conf"
I [29/Mar/2005:22:04:02 -0800] Configured for up to 100 clients.
I [29/Mar/2005:22:04:02 -0800] Allowing up to 100 client connections per host.
I [29/Mar/2005:22:04:02 -0800] Full reload is required.
I [29/Mar/2005:22:04:16 -0800] LoadPPDs: Wrote "/etc/cups/ppds.dat", 3592 PPDs...
I [29/Mar/2005:22:04:16 -0800] Full reload complete.
E [29/Mar/2005:22:04:16 -0800] StartListening: Unable to find IP address for server name "(none)" - Host name lookup failure
E [29/Mar/2005:22:04:16 -0800] StartBrowsing: Unable to bind broadcast socket - Address already in use.
I [29/Mar/2005:22:07:29 -0800] Scheduler shutting down normally.
I [29/Mar/2005:22:07:29 -0800] Listening to 0:631

so I guess it dosent know where it is! How do I tell it?
It knows the printer and where it's at, found and tested at install.

and no. Yast is no help here. it goes into 'detecting system settings' a child procc. starts 'Restarting cups daemon' "this will take 1 or 2 minutes to compleat" which ends in failure 20mins later. And from print manager 'initializing print manager' which never ends and i have to kill it.

this is just one of a few probs. i've had since the forced upgrade(my HD died).

naps 04-05-2005 04:57 AM


Originally posted by osbie
I'm now having the same problem since the upgrade to 9.2 >>snip<<

so I guess it doesn't know where it is! How do I tell it?
It knows the printer and where it's at, found and tested at install.

and no. Yast is no help here.

this is just one of a few probs. i've had since the forced upgrade(my HD died).

I don't think this is a problem one can fix by tinkering. I don't know if it is the same in different distros (or even in different cases with SuSE), but it seems to be a CUPS problem or a problem with CUPS interfacing with the rest of the printing system rather than distro specific. I got out of it by uninstalling 3 or 4 packages and re-installing them (search for the other post on this by me, naps,) so I hope this works for you (I am sure I tried it in Debian and it didn't).

Interesting that you also got this upgrading ... you mean you are not re-installing from scratch on the new hard drive?

osbie 04-05-2005 04:33 PM


thanks for the reply, I'll take alook at your other post, see if it can help.

You see, i'm in a slight quandry here as to whats to blame. My old drive faild, i.e. died, went through all trying to save it. Now a new drive.

Previously, BTW i have a tinkpad A21m PIII 750 new 40G Seagate, netgear wifi., I had 9.1 w/ KDE 3.3 and everything worked flawlessly. I had 9.2 on disks i had D/L'd waiting to be installed. Well, here I am.

now the variables have multiplied. 9.2 , kde 3.4 and the new drive.

So, whats new? printer was found and tested at install and worked fine, now it does'nt.
- wifi no problemes at all.
-Xine- works fine- EXEPT only when conected to internet, otherwise it opens and packs up in the same
-certain text instances are invisible. bubble text in Firefox, print preview and other in openoffice
-KDE will not start if my wifi card is in.
-konqurer- starts to open on kicker then goes away. 2 mins later it opens. kate does the same. At first i thought it was the new HD, but everything else starts fine.
-now, in the last 2 boots ide.dma can't see my cdrom tho the sys. does so dma mode is not started.

BTW i have uninstalled all cups progs. and reinstalled them. nothing. i had a feeling its a firewall prob. nothing changes with it off.

anyway, i've searched for a couple of days to see if anyone else has any of these probs. now i'm thinking my copy is corrupted somewhere.- so reinstall?

holding out hope,

All times are GMT -5. The time now is 07:56 AM.