-   SUSE / openSUSE (
-   -   Choppy VLC Playback on mkv files (

swampdog2002 02-04-2008 07:51 PM

Choppy VLC Playback on mkv files
I am using VLC Media Player 0.86d downloaded from the VideoLAN website for openSUSE 10.3. Whenever I attempt to play Matroska (mkv) format video files, the video track is choppy. There is no problem with the audio, however. I have successfully played Matroska files with other media players, such as Totem and MPlayer on the same system. With VLC, avi files seem to play fine. From what I know, all required dependencies are installed, and I also have libmatroska installed, but it seems to make no difference. Is anyone else experiencing this? I am unsure what the problem could be.

marksthespot 02-06-2008 12:18 AM

I am seeing the same thing. What type of video card are you using?

I have an NVidia GeForce 6600 GT, running OpenSuse 10.3 with the latest vidz drivers.

swampdog2002 02-06-2008 01:36 PM

It's an older ATI Radeon Mobility M32 (I believe) card in a Gateway 450SX4 laptop. I have no problems with other media players such as Totem or MPlayer in playing Matroska files, just in VLC. I have this same version installed on a 10.2 machine that is slightly more powerful, so I may check this out to see if the problem occurs on this system as well.

marksthespot 02-06-2008 10:42 PM

I have a AMD Athlon(tm) 64 Processor 3700+ with 2GB of RAM and it's choppy. The video card has 128MB. As you say, when I run any other file through VLC, it works fine... Just mkv's seem to be a hassle.

swampdog2002 02-08-2008 07:00 PM

With your system specs, these files should play without issue. Perhaps it is the package, I thought, but I tried both the VLC packages from Packman and the official VideoLAN repository and still get the same results. Fortunately, I have other options in either Totem and MPlayer to handle Matroska files until (or if) this issue is resolved in VLC.

dkvasnic 10-15-2008 12:52 PM

I have the same issue.

I'm using OpenSuSE 11.0 with an nVidia Quadro FX 570M video card.

TennTuxedo 05-11-2009 01:40 AM

I had the same problem and found these instructions on the VLC forums.

H.264 codecs are pretty CPU intensive and VLC can't use multi-cores to decode it yet.

So if your computer is dying when decoding 1080p samples from H264, do the following.

* Open the preferences
* Tick advanced in the lower right corner
* Go to "Input/Codec"
* Go to "other codecs" subcategory
* Go to "FFmpeg"
* Put the "skip-filter for H264" to all
* Restart VLC

while the file I was trying to play was only 720p the playability of the file increased greatly there was only a couple of places that it stopped for a sec or 2.

hope this helps


GreggGaz 10-11-2011 11:23 PM

appreciate the tip, TennTuxedo! It worked, and I am thrilled - again, THANK YOU!~

All times are GMT -5. The time now is 09:14 AM.