-   SUSE / openSUSE (
-   -   Can't install SuSE 9.2 64-bit version (

Jesper77 04-01-2005 12:35 PM

Can't install SuSE 9.2 64-bit version
Hey there,
I recently purchased SuSE 9.2 and I'm currently experiencing some problems installing it on my recently purchased machine. I'm completely new to the world of Linux.
My machine setup is:
mobo: ASUS A8N-SLI; cpu: AMD64 3000+; RAM: 2*512 mb Elixir DDR400; gfx: Point of View GeForce 6600GT (PCI-E); hd: 2*80 GB Seagate Barracuda.
The problem is this:
At the first graphical (low-res) installation screen appearing after booting
on the DVD, the installer automatically chooses 64-bit. However, pressing <enter> to commence installation results after the initialization of hardware etc. in a black screen at the moment when it tries to start up YaST; changing to "textmode" by pressing <esc> at this black screen tells me this and from that "text screen" furthermore this happens: after a while it changes to a blue screen and a red box appears saying that an error occured during installation and I have to reboot. I've tried all the different
preset-installation modes (ie. no acpi etc.) and it's still the same thing. If,
however, I choose 32-bit instead of 64-bit it all works fine!
The only way I've managed to install a 64-bit version is by choosing text mode as resolution. This does not solve the problem though, as I can't start SuSE in graphical mode after installation; the screen is all messed up with strange green figures all around the screen and the mouse pointer is a big green box (?!).
I have a feeling this might have something to do with the gfx-card, but I'm
not sure. I've read quite a lot of threads on nVidia's forum, but it's all very
confusing, since I have no idea if I'm on the rigth track or not.
Any help from you guys would be greatly appreciated. And please keep it very
step-by-step :-) . Thank you.
Jesper Larnaes

taxtropel 04-01-2005 12:59 PM

Welcome To Linux!

Ok your right in assuming there is a problem in the gfx driver, however SuSE makes you install the nVidia drivers later, and defaults to VESA mode.

check out the file
and read through it.
(use less to read the file (read-only) and joe or jmacs or vi or pico to edit)
if you need help w/ it read the man page
man xorg.conf
(yes some config files come w/ their own man pages)

You can also try downloading the latest nvidia drivers (make sure you look for the NOTE about SuSE on nvidia's website.)
to do so from linux in a text console type
(possibly links instead, there are 2 different versions w/ similar names)
the text browser will start up and it wll ask for a URL
g -> go to url
G -> go to modified URL
d -> download the current link
z -> stop
up, down -> move through page
left, right -> back, forward
enter -> follow link

don't forget the man page if you need more help

to run the driver install program from nvidia

You can solve and fix these problems. yes the SuSE disto may be broken, but it is not so broken as to be unfixable.
With a little reading and time spent, this will be an excellent oppertunity for you to learn and understand the basic workings of X (the GUI part to linux, and many many other Unixies )

Jesper77 04-01-2005 01:09 PM

It appears I don't have a directory "/X11" for some reason and I have dl the latest nVidia drivers. Could it be that my kernel is not updated; I think it's 2.6.8-24-default (that's what I get by typing "uname -r", anyway)?

paul_e_t 04-01-2005 01:54 PM

Do you know if your 9.2 contains the parted bug ? I am also having video trouble with two other systems similiar to yours both COMPAQ machines (EP/SB) series. They will only run MS Win's in GUI.
Your not alone. Hope you post a fix.

Jesper77 04-01-2005 02:08 PM

No, I'm afraid I don't know whether it has this bug or not. I will definitely post a fix for the problem if I manage to find one :-)

All times are GMT -5. The time now is 03:40 AM.