LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   SUSE / openSUSE (https://www.linuxquestions.org/questions/suse-opensuse-60/)
-   -   Can't find Mime Type (https://www.linuxquestions.org/questions/suse-opensuse-60/cant-find-mime-type-295925/)

cootetom 02-28-2005 01:26 PM

Can't find Mime Type
 
Hi, i keep getting this really annoying error but don't where it is coming form!

When i run an application the following error pops up before the application opens.

Quote:

could not find mime type
application/octet-stream
I have tried running applications from a terminal to see if i get any output there but i don't. The mime type octet-stream.desktop file is there, it's in directory /opt/kde3/share/mimelnk/application/ and it's also in my home directory under .kde/share/mimelnk/application/

This isn't happening for any other users, no others users have this file in there home dir. Maybe it's the format of my octet-stream file. Here is the file content for both files,

/opt/kde3/share/mimelnk/application/

Type=MimeType
Encoding=UTF-8
MimeType=application/octet-stream
Comment=Unknown
Comment[af]=Onbekende
Comment[ar]=غير معروف
Comment[az]=Namə'lum
Comment[be]=Невядомы
Comment[bg]=Неизвестен
Comment[bn]=অজ্ঞাত
Comment[br]=Dianav
Comment[bs]=Nepoznat
Comment[ca]=Desconegut
Comment[cs]=Neznámý
Comment[cy]=Anhysbys
Comment[da]=Ukendt
Comment[de]=Unbekannt
Comment[el]=Άγνωστο
Comment[eo]=Nekonata
Comment[es]=Desconocido
Comment[et]=Tundmatu
Comment[eu]=Ezezaguna
Comment[fa]=ناشناخته
Comment[fi]=Tuntematon
Comment[fr]=Inconnu
Comment[ga]=Neamhaitheanta
Comment[gl]=Descońecido
Comment[he]=לא ידוע
Comment[hi]=अज्ञात
Comment[hr]=Nepoznat
Comment[hu]=Ismeretlen
Comment[id]=Tidak Diketahui
Comment[is]=Óţekkt
Comment[it]=Sconosciuto
Comment[ja]=未知
Comment[ko]=모름
Comment[lt]=Nežinomas
Comment[lv]=Nezināms
Comment[mi]=Kaore i te Mohio
Comment[mk]=Непознато
Comment[mn]=Мэдэгдэхгүй
Comment[ms]=Tidak Diketahui
Comment[mt]=Mhux magħruf
Comment[nb]=Ukjent
Comment[nds]=nich bekannt
Comment[nl]=Onbekend
Comment[nn]=Ukjend
Comment[nso]=Ga e tsebje
Comment[oc]=Desconegut
Comment[pa]=ਅਣਪਛਾਤਾ
Comment[pl]=Nieznany
Comment[pt]=Desconhecido
Comment[pt_BR]=Desconhecido
Comment[ro]=Necunoscut
Comment[ru]=Неизвестный
Comment[se]=Amas
Comment[sk]=Neznámy
Comment[sl]=Neznano
Comment[sq]=I Identifikuar
Comment[sr]=Непознат
Comment[sr@Latn]=Nepoznat
Comment[ss]=Ngatiwa
Comment[sv]=Okänt filformat
Comment[ta]=தெரியாத
Comment[tg]=Номуайян
Comment[th]=ไม่รู้จัก
Comment[tr]=Bilinmeyen
Comment[uk]=Невідомий
Comment[uz]=Номаълум
Comment[ven]=Zwisadivhei
Comment[vi]=Không biết
Comment[wa]=Nén cnoxhou
Comment[xh]=Engaziwayo
Comment[zh_CN]=未知
Comment[zh_TW]=未知
Comment[zu]=Okungaziwa

.kde/share/mimelnk/application/

[Desktop Entry]
Hidden=true
MimeType=application/octet-stream
Type=MimeType

How come it's not being found? Maybe it's not looking in the right place? Anyone know anything i can try to resolve this coz i can't seem to find any info on it.

abisko00 02-28-2005 01:38 PM

A long time ago I had the same problem. Unfortunately I don't remember how I solved it. Try to delete (better:rename or move) the file octet-stream.desktop in your homedirectory. I think that was it...

cootetom 02-28-2005 01:50 PM

Ok, i have tried deleting the file in my home. Then I tried deleting file in /opt then I tried it with both deleted. None of it worked so have got both files back now!

Anymore thoughts abisko00?

tormented_one 02-28-2005 02:03 PM

delete /tmp/kde-user/ksyscoca (kde-user = kde-yourusername)
I got alot of these once when updating KDE. I spit out like 30 or so of the errors you have. Removing /tmp/kde-user/ksyscoca solved the problem and sped up KDE.

cootetom 02-28-2005 03:06 PM

Thanks tormented_one thats done the trick, strange huh!

/tmp/kde-user/ksycoca was a sim link on my computer so i had to then delete the ksyscoca and ksyscocastamp dirs from /var/tmp/kdecache-user/

How u ever found out the answer to that is beyond me but glad u did.

cootetom 02-28-2005 06:01 PM

O dear, i just logged back into kde and for some reason the files i deleted are back and so are the error messages! How come the files come back? How can i get rid of them completely?

tormented_one 02-28-2005 07:48 PM

I don't know mine never came back. I also deleted the dir kde-otheruser/ kde-root/ ksocket-*/ and gconf-*/ all in /tmp dir.. Then ran kbuildsyscoca. Problem never returned. At the time that was the only error my machine had, and took me about a week to figure it out.

cootetom 03-01-2005 08:00 AM

It appears if i delete only /var/tmp/kdecache-user/ksycoca and the sim link to it in /tmp/kde-user then i don't get the errors but my k menu reverts back to it's default number of programs!

As soon as i run kbuildsycoca or edit the k menu in the control centre the menu returns to how it was before deleting ksycoca but also the error comes back. So when it creates the menu again it must be using some data somewhere otherwise how would it remember how the k menu looked.

Lars2 03-07-2005 05:10 AM

could not find mime type application/octet-stream
 
Tom, did you finally solve the above problem? I get the same error message right now. Browsing several discussion groups, nobody seems to understand what is going on.
Regards

Lars

cootetom 03-07-2005 06:55 AM

No i never did solve it. I can't find any information as to what the file is or does either?

I stopped trying because i messed my system up big time when messing around re-compiling the kernel and so i decided to re-install linux, so the problem went.

If you find any information as to what the file is etc or how the problem is solved then please post it because i would like to know anyway.

Other than that kde 3.4 will probably be made easily available for each distro soon so maybe the problem will go away when upgrading to that. I checked out the liveCD of it that you can get from kde.org and it's nice.

tormented_one 03-07-2005 05:07 PM

This happens only when updating to kde 3.3, for some reason. Has nothing to do with the kernel. I had the same problem but I did the above steps, then updatedb && ldconfig, and something else don't remember what it was and that solved my problem.

muzhogg 03-11-2005 04:55 PM

Hi all,

I also had the same problem - it seems to be rather common!

I have so far found two ways of solving the immediate problem both involving the file;

~/.kde/share/share/mimelnk/application/octet-stream.desktop

My first solution was to delete the file altogether.

The second was to edit the file;

Original listing

Hidden=true
MimeType=application/octet-stream
Type=MimeType

Altered listing (note change in first line only)

Hidden=false
MimeType=application/octet-stream
Type=MimeType

I can't explain this, but it did prevent the error message from showing. I am trying to find a proper fix to the problem and would be intrigued to know (1) whether the file octet-stream.desktop exists under your reinstillation and (2) whether it includes the line "Hidden=true/false" and (if so) the set value

Regards,
MH

cootetom 03-12-2005 11:50 AM

With my re-installation the file doesn't exist in my home dir .kde/share/mimelink/application but it does exist in the /opt/kde3/share/mimelnk/application/

In the /opt directory the the file looks exactly as i posted in my very first post on this topic.

So it would be interesting to know what creates and needs the file to be in your home directory and of course why the error exists.

Lars2 03-14-2005 06:58 AM

RPM package manager, reinstall kdelibs3
 
Following earlier advice, I had simply deleted both the local and global copy of octet-stream.desktop.

That didn't work for me. So I created a dummy file octet-stream.desktop in 'Configure Konqueror/ File Association', which was of course empty and not the original one. With

rpm -q --file octet-stream.desktop

I checked who owned octed-stream.desktop. That was kdelibs3-3.3.0-34.3 in my case. I delted that package in YAST and then immediately reinstalled it. After a reboot the error message did not reappear.
Regards

Lars

yorches 03-17-2005 10:40 AM

could not find mime type application/octet-stream
 
Hi,

It happend to me too when I upgraded my system (I use Slackware). The solution was to create a new MIME type named "octet-stream" using KDE's control center.

In the control center select "KDE Componentes" then "File Associations". In the window that appears click on the Add... button. A small dialog box will appear. Select "application" fom the drop down box, and type "octet-stream" (without the quotes) in the blank labeled Type name. Click OK to add the new MIME type. After you click OK another window appears. I had to type something in the "Filename Patterns" box so that my new MIME type would be actually saved. Because if I left it all blank, it would not be saved. So I just typed "octet-stream" (again, without the quotes). Make sure you don't use an already existent filename pattern or any wildcards. Make sure to click Apply before clicking OK. That's it. I hope it helps.

Jorge.


All times are GMT -5. The time now is 08:37 PM.