-   SUSE / openSUSE (
-   -   Can't delete certain files or do I change this? (

xsithlordx 02-28-2006 04:39 AM

Can't delete certain files or do I change this?
I have a few files and folders that are simply taking up space on my machine. I have tried to delelte them but I'm getting an access denied error. I even logged in as root but still nothing happened. Can some kind soul explain whats happening,why and how I can remedy this problem?

thanks in advance

abisko00 02-28-2006 04:50 AM

Please give an example. The file may be in use or the filesystem may be read-only (e.g. NTFS).

xsithlordx 02-28-2006 12:40 PM

An example? When I go into Konqueor to locate a file or folder, right click it to send it to the the trash and get an access denied! The files ARE NOT in use, they are music and movie folders. though they are currently being shared on my network, I suggges this could be he problem, but all of the properties are greyed out with no options to unshare them or even change the permissions. Some of these are DVD ISO images and they are taking up gigs of space. i hope this information was useful :)

XavierP 02-28-2006 04:05 PM

I think he was asking where the files reside and we also need to know whether the user that is trying to delete them has full read/write/modify rights to the folder.

xsithlordx 03-02-2006 01:13 PM

Some files reside in my home folder/music folder the other is on my desktop...

crazibri 03-02-2006 02:19 PM

I think it would make it clearer for everyone if you went to your Konsole and pasted the following here:


ls -l <your path>
example: ls -l /home/name or /windows/d or whatever. This shows us your permissions on files in the folder you put.

xsithlordx 03-02-2006 03:47 PM

cam@linux:~> ls -l /home/cam/MUSIC
total 246655
-r-xr-xr-x 1 cam users 3684856 2004-09-12 06:47 02+Aaliyah+-+Loose+Rap.mp3
-rw-r--r-- 1 cam users 3453031 2006-01-26 16:52 [02] - [adventures in the land of music].mp3
-rw-r--r-- 1 cam users 7101141 2006-01-19 14:15 02 - T.H.U.G. feat. Tragedy Khadafi.mp3
-rw-r--r-- 1 cam users 7925760 2006-01-19 10:30 [09] boogie down productions - super hoe.mp3
-rw-r--r-- 1 cam users 8455318 2006-01-19 13:05 09 - super-hoe.mp3
-rw-r--r-- 1 cam users 98391058 2006-02-18 01:21 36mafia_MKUK.rar
drwxr-xr-x 2 cam users 1016 2005-09-28 06:12 6 Feet Deep
drwxr-xr-x 2 cam users 864 2006-02-06 18:28 against all odds
-rwxrw-rw- 1 nobody nobody 3758764 2006-02-20 12:14 A Lil Story.mp3
-rw-r--r-- 1 cam users 6465664 2006-01-26 06:50 Angela Winbush - You Don't Have to Cry.mp3
drwxr-xr-x 4 nobody nobody 96 2006-01-25 18:29 Banned From The Bible
drwxr-xr-x 3 cam users 128 2006-02-22 16:22 Beneth the surface
-rw-r--r-- 1 cam users 3899014 2006-01-26 06:41 Billy Ocean - Carribean Queen.mp3
-rw-r--r-- 1 cam users 75649966 2006-02-20 22:46 blue raspberry-out of the blue.rar
drwxr-xr-x 45 cam users 2136 2006-02-15 13:58 cam
-rw-r--r-- 1 cam users 12117163 2006-01-18 22:52 camron-jay-z-i_m_not_a_writer.mp3
drwxr-xr-x 2 cam users 1136 2006-01-19 03:04 Cormega_-_Hustler_Rapper_Mixtape
-rw-r--r-- 1 cam users 3732594 2006-02-20 23:44 deck.rar
drwxr-xr-x 2 cam users 776 2006-01-08 03:52 DJ MUGGS VS GZAGENIUS GRANDMASTERS
drwxr-xr-x 2 cam users 960 2006-01-06 17:38 GZA - Liquid Swords
drwxr-xr-x 3 cam users 136 2006-02-21 18:00 IRONMAN
drwxr-xr-x 2 cam users 1696 2005-10-18 18:03 Method Man - Tical 2000 Judgement Day (1998)
-rw-r--r-- 1 cam users 6394652 2006-02-04 06:52 Norman Connors - You Are My Starship.mp3
drwxr-xr-x 2 nobody nobody 544 2006-01-26 08:29 Notorious B.I.G. - Ready to Die (Instrumental)
drwxr-xr-x 9 nobody nobody 608 2006-01-29 02:56 OFFICE XP SUITE
drwxr-xr-x 2 cam users 1320 2006-02-03 12:14 Ol_Dirty_Bastard-A_Son_Unique-Advance-2006-FTD_INT
-rw-r--r-- 1 cam users 4605855 2006-01-19 03:32 patrice rushenl - 05. where there is love.mp3
drwxr-xr-x 2 cam users 688 2006-01-19 03:10 PORTISHEAD
drwxr-xr-x 3 nobody nobody 128 2006-01-26 08:28 rza presents harlem 6-
drwxr-xr-x 3 cam users 96 2006-02-16 23:17 Sean Price
drwxr-xr-x 2 nobody nobody 640 2006-02-17 19:34 Streetlife
-rw-r--r-- 1 cam users 427442 2006-02-16 21:48 strike a match on a dollar trick_.wmv
-rw-r--r-- 1 cam users 6221824 2006-01-27 22:58 trag_trueconfessions.mp3
drwxr-xr-x 2 cam users 272 2006-01-28 13:34 Unbreakable-Bruce_Willis-Xvid-ENG
drwxr-xr-x 2 nobody nobody 1048 2006-01-26 08:28 Undadogz_INS_CARLTON FISK
drwxr-xr-x 2 cam users 2400 2006-02-28 05:35 XP 9in1
cam@linux:~> /home/cam/MUSIC

xsithlordx 03-04-2006 07:34 AM

anyone got any insight?

abisko00 03-04-2006 09:08 AM

From you listing above, I could imagine that there is a problem with the codetable. Maybe some characters are not recognised. You could try to set the filename in quotation marks (").

spooon 03-04-2006 04:07 PM

So what files are you trying to delete? And what commands are you using to delete them? Can you show us the error it outputs? Also, show us "ls -dl /home/cam/MUSIC".

kenwoodman 03-05-2006 10:32 PM

I have a similar problem trying to delete and or change a file that I can't, although I don't have a problem doing it as root...

I am using Fedora 4. I have only 2 users on my system so far, root, and wolf. I do not like to log in as root unless I have to, so I always log in as wolf, and either use a root console, or SU to perform tasks needing root access. I am doing a lot of work on a Samba server right now, and the smb.conf file needs root permission to be modified. I made a copy that I stored in my home directory to edit, but each time I need to copy it over the working file, I have to do this as root.

I added a group to my system called admin with the intent of using this for system administrators other than root. Wolf is currently the only member. I then went to the /etc/samba directory and changed the group ownership of the smb.conf files to admin as shown below. I also set user wolf's primary group to admin. The permissions look right to me, but user wolf can not edit or delete the smb.conf files... I tried to delete the backup file and edit the working smb.conf file and was denied both.

I am not sure what I am doing wrong. I thought that security changes took effect immediately, but when it did not work properly, I rebooted just in case. Still won't go. Please let me know what I might be missing here. I am still pretty new to Linux. Any help you could provide would be greatly appreciated.


ls -l listing for /etc/samba directory:
drwxr-xr-x 2 root root 4096 Mar 5 17:10 samba

[wolf@fedora samba]$ pwd
[wolf@fedora samba]$ ls -l
total 52
-rw-r--r-- 1 root root 20 May 2 2005 lmhosts
-rw------- 1 root root 8192 Feb 12 18:20 secrets.tdb
-rw-rw---- 1 root admin 784 Mar 5 17:13 smb.conf
-rw-rw---- 1 root admin 2008 Feb 23 19:43 smb.conf~
-rw------- 1 root root 308 Mar 5 16:04 smbpasswd
-rw-r--r-- 1 root root 109 Feb 12 23:38 smbusers
[wolf@fedora samba]$

All times are GMT -5. The time now is 06:03 PM.