LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   SUSE / openSUSE (https://www.linuxquestions.org/questions/suse-opensuse-60/)
-   -   Can't change screen resolution (https://www.linuxquestions.org/questions/suse-opensuse-60/cant-change-screen-resolution-600576/)

andmer 11-18-2007 09:32 AM

Can't change screen resolution
 
Hi there,
I have just installed opensuse 10.3 and I have the following problem.
By dafault suse gives ma a screen resolution of 1280x1040 and I would like to change it to 1280x768, but if I follow the procedure from Yast nothing happens. I mean, when I restart the Xsystem I still have the previous screen resolution. It happens the same if I try with a reolsuiton lower the 1280x768. I edited /Etc/X11/xorg.conf but everything seems to be ok.
Any ideas?
thank you

Simon Bridge 11-18-2007 09:42 AM

Quote:

I would like to change it to 1280x768
Widescreen 16x9?
http://www.linuxquestions.org/questi...-linux-524319/

Intel graphics?

jess1975 11-18-2007 12:04 PM

Quote:

Originally Posted by andmer (Post 2963049)
Hi there,
I have just installed opensuse 10.3 and I have the following problem.
By dafault suse gives ma a screen resolution of 1280x1040 and I would like to change it to 1280x768, but if I follow the procedure from Yast nothing happens. I mean, when I restart the Xsystem I still have the previous screen resolution. It happens the same if I try with a reolsuiton lower the 1280x768. I edited /Etc/X11/xorg.conf but everything seems to be ok.
Any ideas?
thank you

Have you tried setting this resolution in SAX2?

jess1975 11-18-2007 03:17 PM

Post your Xorg.conf, maybe that clears some things.

andmer 11-19-2007 01:53 AM

Quote:

Originally Posted by jess1975 (Post 2963355)
Post your Xorg.conf, maybe that clears some things.

this is my xorg.conf - section monitor

Section "Monitor"
Option "CalcAlgorithm" "XServerPool"
DisplaySize 338 270
HorizSync 30-80
Identifier "Monitor[0]"
ModelName "DELL E196FP"
Option "DPMS"
VendorName "DEL"
VertRefresh 43-75
UseModes "Modes[0]"
EndSection

Section "Modes"
Identifier "Modes[0]"
Modeline "1280x1024" 108.00 1280 1328 1440 1688 1024 1025 1028 1066
EndSection

Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1280x1024" "1152x864" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1152x864" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1152x864" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1152x864" "1024x768" "800x600"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection

Section "Device"
BoardName "915 G"
BusID "0:2:0"
Driver "intel"
Identifier "Device[0]"
Option "monitor-VGA" "Monitor[0]"
Screen 0
VendorName "Intel"
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
EndSection

Please note that even though I change it manually with 1280x768, screen resolution nothing change!
thank you

jess1975 11-19-2007 02:19 AM

As far as I know, this resolution should also be listed in modes, not only in screen.

My xorg.conf look like this:

Section "Modes"
Identifier "Modes[0]"
Modeline "1280x800" 83.46 1280 1344 1480 1680 800 801 804 828
Modeline "1280x800" 69.75 1280 1328 1360 1440 800 803 809 823 +HSync -Vsync
Modeline "1280x768" 80.14 1280 1344 1480 1680 768 769 772 795
Modeline "1280x768" 67.00 1280 1328 1360 1440 768 771 778 790 +HSync -Vsync
Modeline "1024x768" 64.11 1024 1080 1184 1344 768 769 772 795
Modeline "1024x768" 55.00 1024 1072 1104 1184 768 771 775 790 +HSync -Vsync
Modeline "1280x600" 61.50 1280 1336 1464 1648 600 601 604 622
Modeline "1280x600" 52.50 1280 1328 1360 1440 600 603 613 619 +HSync -Vsync
Modeline "1024x600" 48.96 1024 1064 1168 1312 600 601 604 622
Modeline "1024x600" 43.00 1024 1072 1104 1184 600 603 613 619 +HSync -Vsync
Modeline "800x600" 38.22 800 832 912 1024 600 601 604 622
Modeline "800x600" 34.75 800 848 880 960 600 603 607 617 +HSync -Vsync
Modeline "768x576" 34.96 768 792 872 976 576 577 580 597
Modeline "768x576" 32.25 768 816 848 928 576 579 583 593 +HSync -Vsync
Modeline "640x480" 23.86 640 656 720 800 480 481 484 497
Modeline "640x480" 23.25 640 688 720 800 480 483 487 494 +HSync -Vsync
Modeline "1024x768" 66.33 1024 1080 1184 1344 768 769 772 796
Modeline "1024x600" 50.60 1024 1064 1168 1312 600 601 604 622
Modeline "800x600" 39.49 800 832 912 1024 600 601 604 622
Modeline "768x576" 36.13 768 792 872 976 576 577 580 597
Modeline "640x480" 24.70 640 656 720 800 480 481 484 498
EndSection


Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1280x800" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x800" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x800" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x800" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection


I can't really tell you what you should add in modes, because I don't really know what the rest of the numbers mean.

Simon Bridge 11-19-2007 03:53 AM

Quote:

Section "Modes"
Identifier "Modes[0]"
Modeline "1280x1024" 108.00 1280 1328 1440 1688 1024 1025 1028 1066
EndSection
Find out about those numbers in:
/usr/share/doc/howto/en/XFree86-Video-Timings-HOWTO.gz

Quote:

Please note that even though I change it manually with 1280x768, screen resolution nothing change!
What? What do you change? What do you change it to? You have to be specific..

You have to alter the modeline as well as the mode.

In openSUSE, sax2 generates the modeline. But you could try:
Code:

$ gtf 1280 768 60 -x

  # 1280x768 @ 60.00 Hz (GTF) hsync: 47.70 kHz; pclk: 80.14 MHz
  Modeline "1280x768_60.00"  80.14  1280 1344 1480 1680  768 769 772 795  -HSync +Vsync

Alter your modeline accordingly. Alter the modes so that 1280x768 shows up as the very first entry.

All this info is in the link off post #2, as well as lots more.

andmer 11-19-2007 05:17 AM

Quote:

Originally Posted by Simon Bridge (Post 2963853)
Find out about those numbers in:
/usr/share/doc/howto/en/XFree86-Video-Timings-HOWTO.gz

What? What do you change? What do you change it to? You have to be specific..

You have to alter the modeline as well as the mode.

In openSUSE, sax2 generates the modeline. But you could try:
Code:

$ gtf 1280 768 60 -x

  # 1280x768 @ 60.00 Hz (GTF) hsync: 47.70 kHz; pclk: 80.14 MHz
  Modeline "1280x768_60.00"  80.14  1280 1344 1480 1680  768 769 772 795  -HSync +Vsync

Alter your modeline accordingly. Alter the modes so that 1280x768 shows up as the very first entry.

All this info is in the link off post #2, as well as lots more.

Hi,
I followed your advices but nothing changes. I noticed that setting up the contrast of my monitor, in the windows setting it is said "resolution 1280x1024. Is it possible that the resolution is fixed by the monitor and there is non way to changed it?
The monitor is a Dell E196FP

thank you

Simon Bridge 11-19-2007 11:07 PM

Is your monitor a widescreen monitor?
Did you run gtf on your machine?
Did you alter the modeline as well as the modes?

This one?. Very nice! But this is not a widescreen monitor.

Your monitor and your videocard need to support the resolution. But normally, if the monitor doesn't, you'd get a "mode not supported" error and a blank screen.

andmer 11-20-2007 01:40 AM

Quote:

Originally Posted by Simon Bridge (Post 2964856)
Is your monitor a widescreen monitor?
Did you run gtf on your machine?
Did you alter the modeline as well as the modes?

This one?. Very nice! But this is not a widescreen monitor.

Your monitor and your videocard need to support the resolution. But normally, if the monitor doesn't, you'd get a "mode not supported" error and a blank screen.

Yes Idid all the operation mentioned in your message.
My monitoris is not widescreen. it's exactly the monitor in the article of your link. There no way to change resolution from 1280x1024 to 1024x768! It's strange because using Pclinuxos the resolution is just fine (1024x768) without any problem.

I really do not know what to do. May I should go back to Pclinuxos.

Please help!!!

andmer 11-21-2007 03:49 PM

Quote:

Originally Posted by Simon Bridge (Post 2963056)

my monitor is not a widescreen 16x9 it's a normal dell E196FP 19 inch . Anyway if I set the monitor with Sax2 like a LCD video and I change the resolution to 1024x768 70Hrz it works, but the definition of images and icons is not very good. It seems they are a kind of out of focus. Is there a way to fix the definition? It's hard to work with 1280x1024 resolution or 1024x768 but out of focus.

Any idea?

Simon Bridge 11-21-2007 09:06 PM

To me, it seems strange to want to use a widescreen display on a standard ratio monitor - don't you get a black bar top and bottom?

Fuzzyness is usually corrected in the monitor itself.

However - if you get full-screen at that resolution, then you can expect distortion, yes. If the desktop stuff seems tall and thin, you can adjust the vertical display in your monitor simply enough.

[edit - fuzzy at 1024x768? - try commenting out the sync and refresh entries in xorg.conf. But, adjusting the monitor should help - is it just the icons or every image? There is no advantage to high scan rates in a digital lcd monitor as these things do not scan in any case.]

If PCLinuxOS does what you want, how you want, you would be silly to change. If there are other, compelling, reasons to change, then I'd have thought screen-resolution would be the least of your troubles.


All times are GMT -5. The time now is 03:02 AM.