-   SUSE / openSUSE (
-   -   can only launch KDE after first booting in failsafe mode (

kshaffer 11-13-2004 04:14 PM

can only launch KDE after first booting in failsafe mode
I helped my brother install SuSE Linux 9.1 on his old Dell desktop (I have used SuSE for almost a year on my Sony), and everything went smoothly. However, he got a new monitor (a Sony SDM-HS53 flat panel, replacing his original Dell monitor). Now when he boots linux, his monitor reports "out of range." But if he boots into failsafe, he can enter "startx" and KDE loads just fine! We have tried using YaST to reconfigure the new monitor, but it does not help the boot issue.

How can we fix the monitor problem? or How can we get the X server and KDE to load automatically and properly on this monitor? Any help would be appreciated.


PS /etc/inittab does have runlevel 5 as the default, and everything booted properly several times after installing with the old monitor before he made the switch.

mjrich 11-14-2004 06:33 PM

I'd just find which XF86Config-4 file is being used for failsafe mode, and copy that across to the standard location (/etc/X11/XF86Config-4). Alternatively, if you have a spare copy of Knoppix around, boot that and copy cross the XF86Config-4 file that it creates.



kshaffer 11-15-2004 11:08 AM

Thanks for the reply, mjrich.

How would we find the XF86Config file for failsafe mode as opposed to regular mode? We only found one file called XF86Config, and it appears to have the correct monitor information, and it was generated by sax on Nov. 12, after we hooked up and installed the new monitor.

Could the computer be overlooking this information when booting? Is there a reason that "startx" would find the info, but a regular boot would not?


abisko00 11-15-2004 12:08 PM

Are you sure that KDE doesn't come up after a while, even when you cannot see something during the boot process?

I could imagine that a wrong 'vga=' setting in menu.lst (in case you use grub) causes this error message from the monitor, but get overriden by the correct settings in XF86Config as soon as X starts. And in failsafe mode it is set to vga=normal, which is a 'always working' mode. I would recommend to play with the vga settings in menu.lst.

kshaffer 11-16-2004 10:35 AM

Thanks for the tips, guys. Turned out the "vga=" setting in menu.lst was the culprit. Fortunately, since I have the same monitor and distribution on my computer as my brother has on his, we just copied the vga setting from my menu.lst to his menu.lst, and it worked first try. Thanks again for the help!


All times are GMT -5. The time now is 08:58 PM.