LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 07-23-2006, 04:50 PM   #1
a10waveracer
Member
 
Registered: Mar 2005
Location: Southern Indiana
Distribution: Slackware-current
Posts: 32

Rep: Reputation: 15
Can't Get Xserver To Display After Initial Install


I just installed SuSE 10.1 on my computer for the first time and it will not display the X contents. When I try to startx (after booting up in failsafe mode) my monitor flashes 'Monitor Out of Range -- Lower Resolution'. I first had this problem after the initial install, so then I redid my xorg.conf with xorgconfig. I currently have it set to 1024x768, whereas in my Windows install I have it installed at 1600x1024.

You can see my xorg config http://69.65.20.66/xorg.confright here

Computer Specs --
AMD 3500+ 64-bit
Asus A8N-SLI
eVGA GeForce 6600GT PCI-E 256mb
2gigs 3400 RAM
1x320GB WD SATAI
2x160GB WD ATA

I know a decent amount about Linux computers, but I haven't tried Linux on my current setup and I haven't used it for a good 2 months.

If you get this far, thanks for reading this, and I hope you can help
 
Old 07-23-2006, 05:49 PM   #2
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
Just from taking a quick look at your xorg.conf file, it seems like your horizontal sync is too low.

HorizSync 31.5 - 48.5

Try upping that

Code:
HorizSync 31.5 - 60
And change the resolution to 1600x1024, or try 1280x1024.
Code:
Section "Screen"
    Identifier  "Screen 1"
    Device      "6600GT"
    Monitor     "My Monitor"
    DefaultDepth 24

    Subsection "Display"
        Depth       8
        Modes       "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       16
        Modes       "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth       24
        Modes       "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
EndSection
 
Old 07-23-2006, 06:12 PM   #3
a10waveracer
Member
 
Registered: Mar 2005
Location: Southern Indiana
Distribution: Slackware-current
Posts: 32

Original Poster
Rep: Reputation: 15
Okay, I tried that and got this xorg conf file. It didn't work, but I got the error log and you can find it right here.
 
Old 07-23-2006, 06:21 PM   #4
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
YOur problem is right here:

EE) xf86OpenSerial: Cannot open device /dev/mouse
No such file or directory.
(EE) Mouse1: cannot open input device
(EE) PreInit failed for input device "Mouse1"

I had this same problem when I was using SuSE. I changed the xorg to say:

Code:
ection "InputDevice"

# Identifier and driver

    Identifier	"Mouse1"
    Driver	"mouse"
    Option "Protocol"    "Auto"	# Auto detect
    Option "Device"      "/dev/mice"
Noticed what I changed. I bolded it. I can't recall, but I either changed it to /dev/mice, or /dev/mouse0, or /dev/mouse1, or /dev/mouse2.

I had this exact same problem and that fixed it. Try it and let us know how it goes

Last edited by Micro420; 07-23-2006 at 06:22 PM.
 
Old 07-23-2006, 06:34 PM   #5
a10waveracer
Member
 
Registered: Mar 2005
Location: Southern Indiana
Distribution: Slackware-current
Posts: 32

Original Poster
Rep: Reputation: 15
I just tried /dev/mice and /dev/mouse0.... Here is the xorg log for the /dev/mice...

In case it matters, my mouse is a Logitech MX500 (USB). I shall go ahead and try mouse1 and mouse2, but I have to reboot between each one of them due to the fact that I can't use the computer once X doesn't work...

EDIT : Here is my log for /dev/mouse1

Last edited by a10waveracer; 07-23-2006 at 06:38 PM.
 
Old 07-23-2006, 06:41 PM   #6
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
Yes, try /dev/mouse0, /dev/mouse1, and /dev/mouse2.

You do not need to reboot. Just make the /etc/X11/xorg.conf change and then type

Code:
startx
Just curious, but go into your /dev directory. Is there a /dev/mice? Is there a /dev/mouse0, mouse1, mouse2? If not, create them. I cannot recall completely what I did.

as root
mkdir /dev/mice

Let me know if it works. Still showing that the mouse is the error. Again, I had this problem also and fixed it by changing the path of the mouse in the xorg.conf file.

I just realized that you and I have a similar hardware set up.

I also have a Nvidia 6600GT graphics card and a Logitech MX500 mouse.

Last edited by Micro420; 07-23-2006 at 06:44 PM.
 
Old 07-23-2006, 06:55 PM   #7
a10waveracer
Member
 
Registered: Mar 2005
Location: Southern Indiana
Distribution: Slackware-current
Posts: 32

Original Poster
Rep: Reputation: 15
Okay, I have now tested all of your possible solutions...
Mice
Mouse0
Mouse1
Mouse2

None worked. There was no /dev/mice, /dev/mousex, anything. The problem is that I am getting these logs from puttying into my computer from another computer -- once I try to start the Xserv, it won't let me get back to the shell (even with the ctrl+shift+backspace, which was a way to kill the Xserv, or so I thought...)

I just tried to do a mkdir /dev/mice (from root) and it did so, but when I did it didn't work, and I got this error log.
 
Old 07-23-2006, 07:04 PM   #8
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
This is odd. Hmmm

You could try CTRL+ALT+F2, F3, F4, etc... Should open up a new session

So you don't see any errors? Your screen just goes blank and you have to remotely grap the xorg log?

Here's my mouse section. See if the path exists or not. Copy and paste it into your xorg.conf. Backup your xorg.conf file in case:

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Last edited by Micro420; 07-23-2006 at 07:14 PM.
 
Old 07-23-2006, 07:05 PM   #9
a10waveracer
Member
 
Registered: Mar 2005
Location: Southern Indiana
Distribution: Slackware-current
Posts: 32

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Micro420
So you don't see any errors? Your screen just goes blank and you have to remotely grap the xorg log?
Nope, I get no errors. It my screen just flashes 'out of range, lower resolution' (or something to that effect) and then it goes to a black screen.
 
Old 07-23-2006, 07:22 PM   #10
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
What kind of monitor do you have? Can you look up the specs and see what the vertical and horizontal rates are? Maybe for now, you can use the vesa driver, just for the sake of getting your monitor working. Even if you solved the mouse problem, you wouldn't know if it really worked or not since you can't see your screen.

So run xorgconfig again (backup your xorg.conf file) and when asked about the video card, select VESA and choose 1024x768 for your resolution. See if that solves the monitor problem. After that, we can tackle the mouse problem so you don't have to keep rebooting and waiting and waiting.

Unfortunately I have to head out and meet a friend for sushi so I'll check back in a few hours when I return home.

Good luck
 
Old 07-23-2006, 07:35 PM   #11
a10waveracer
Member
 
Registered: Mar 2005
Location: Southern Indiana
Distribution: Slackware-current
Posts: 32

Original Poster
Rep: Reputation: 15
I have a Compaq FS740. This monitor has worked before with linux (slackware when I was running a 2500+ and 9600XT, but nonetheless)

H Freq/ V Freq: 31.5-70 khz / 50-120 HZ

Okay, I rebuilt my xorg.conf and it now, instead of completely borking my machine, at least dumps me back to my shell. The error log is located here.

It seems using VESA helped at least a little bit... now to debug the mouse error...

EDIT : I just tried to use /dev/mouse and create a /dev/mouse, but it didn't work. Same errors there as before.

Last edited by a10waveracer; 07-23-2006 at 08:20 PM.
 
Old 07-23-2006, 08:21 PM   #12
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
Check out this link, maybe this will help?

http://www.linuxforums.org/forum/deb...ng-kernel.html

Just start googling as I'm sure other people out there have solutions.

http://www.google.com/search?q=Mouse...-US:unofficial
 
Old 07-23-2006, 08:47 PM   #13
a10waveracer
Member
 
Registered: Mar 2005
Location: Southern Indiana
Distribution: Slackware-current
Posts: 32

Original Poster
Rep: Reputation: 15
Yup, that first link you gave me solved the problem. Once I changed
Code:
Option   "Protocol"   "PS/2"
Option   "Device"   "/dev/psaux"
it worked. Thanks for all of your help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
The Kde Xserver Display Epidemic, Its a huge problem ..... tdeprato SUSE / openSUSE 1 03-05-2006 01:17 PM
initial startup of suse (text part) Won't display on my monitor ... miamitj SUSE / openSUSE 5 08-23-2005 02:12 PM
XServer: xauth: (stdin):1: bad display name rpb Linux - General 1 03-12-2005 12:01 PM
Xserver multiple display classical question anup_clemson Mandriva 1 03-08-2005 03:06 PM
No Xserver display with Radeon 3.7.0 drivers and kernel 2.6.1 slimshady165000 Slackware 16 03-08-2004 03:30 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 03:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration