LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 01-23-2006, 04:31 PM   #1
albertog
LQ Newbie
 
Registered: Jan 2005
Location: NO-8672 Elsfjord, Norway
Distribution: Suse 10.0,Oss,32bit; Mepis 6.5, Ubuntu 71.
Posts: 15

Rep: Reputation: 0
Smile Can't enter pasword in the login field.


Hello,
Login fails on my Suse 10, OSS, 32 bit.
I can position the cursor in the field, but can't move it or write anything in the field.
How can I regain control of the login fields? Suse has worked very well since installation a couple of months ago, until I made an update just recently.
My username appears in the un.field but can't be deleted or entered.
Thanks in advance for any help on this.

Regards from newbie Al of Norway
 
Old 01-24-2006, 09:03 AM   #2
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,513

Rep: Reputation: 58
Have you tried typing the password blindly?
You may not see the input, but it's there.

There is a setting in kdm to change the echo mode to show your input. This was in KDE Control Center -> System Administration-> Login Manager
 
Old 01-24-2006, 03:05 PM   #3
albertog
LQ Newbie
 
Registered: Jan 2005
Location: NO-8672 Elsfjord, Norway
Distribution: Suse 10.0,Oss,32bit; Mepis 6.5, Ubuntu 71.
Posts: 15

Original Poster
Rep: Reputation: 0
Hi Abisco00,

Thanks for your kind response! I have already tried what you suggest, but to no
avail.I have performed the console login, and it worked.I`m not getting any further though, giving the command startkde in root yields "xset unable to open display".

Al
 
Old 01-24-2006, 05:17 PM   #4
victorh
Member
 
Registered: Jul 2005
Location: La Paz, Bolivia
Distribution: Debian Sarge - Sid, Slackware, Gentoo, openSuse, Fedora, Ubuntu, Mandriva
Posts: 241

Rep: Reputation: 30
Hi Al, it seems to me that your problem is related with the X Windows system. The GUI of Linux. That'll also explain why you can't access your keyboard at the login screen. Try the following:

Login as root in console, then type yast2, once there reconfigure your keyboard, mouse, monitor and graphic card, follow the instructions in yast2 until it tells you that all your changes have been saved.

After that exit and login as user and try again startkde, see what happens.

By the way, you can have more info of the X windows system in the file:/var/log/Xorg.0.log. If you see a line that starts with (EE), then definitely you have some problem with X.
 
Old 01-24-2006, 06:03 PM   #5
muddywaters
Member
 
Registered: May 2005
Location: Winnipeg, Canada
Distribution: mostly mepis
Posts: 427

Rep: Reputation: 30
Just to add something that victorh implied but didn't say outright. By default Suse 10 won't allow you to log into kde as root.
 
Old 01-25-2006, 11:12 AM   #6
albertog
LQ Newbie
 
Registered: Jan 2005
Location: NO-8672 Elsfjord, Norway
Distribution: Suse 10.0,Oss,32bit; Mepis 6.5, Ubuntu 71.
Posts: 15

Original Poster
Rep: Reputation: 0
Hello Victorh, and thanks for usefull info! Although the Graphics Card and Monitor would not open in Yast.

I'm thinking of entering the x11config and create a new config.for the graphics card and monitor.
What's your opinion?
 
Old 01-25-2006, 11:15 AM   #7
albertog
LQ Newbie
 
Registered: Jan 2005
Location: NO-8672 Elsfjord, Norway
Distribution: Suse 10.0,Oss,32bit; Mepis 6.5, Ubuntu 71.
Posts: 15

Original Poster
Rep: Reputation: 0
Muddywaters hello,

Thanks for helping me!
 
Old 01-25-2006, 11:54 AM   #8
albertog
LQ Newbie
 
Registered: Jan 2005
Location: NO-8672 Elsfjord, Norway
Distribution: Suse 10.0,Oss,32bit; Mepis 6.5, Ubuntu 71.
Posts: 15

Original Poster
Rep: Reputation: 0
Victorh or muddywaters , Hello,

Being in file:/var/log/ , Which command do I use to open the Xorg.0.log?
 
Old 01-25-2006, 12:22 PM   #9
muddywaters
Member
 
Registered: May 2005
Location: Winnipeg, Canada
Distribution: mostly mepis
Posts: 427

Rep: Reputation: 30
Hello Albertog
To read the log file; cat /var/log/Xorg.0.log

Suse has a configuration tool for X called sax2. I've never needed to use it as a repair tool so hopefully one of the other users will give you a run through.
I'm not sure hand editing X configuration should be the first resort.

btw: hope I was correct about root login to kde with Suse 10. I don't use 10, this is info gathered from other posts.

Last edited by muddywaters; 01-25-2006 at 12:51 PM.
 
Old 01-25-2006, 12:54 PM   #10
victorh
Member
 
Registered: Jul 2005
Location: La Paz, Bolivia
Distribution: Debian Sarge - Sid, Slackware, Gentoo, openSuse, Fedora, Ubuntu, Mandriva
Posts: 241

Rep: Reputation: 30
Hi Al, I'm glad of giving you some help.

Now to your problem, if yast2 has not been very helpful, try the following, login as root in console and type sax2 (SUSE Advanced X11 Configuration interface) with this tool you can configure the graphical environment of your system. In order to be successful in this matter you need some information:

1. Specs of your Monitor ( Display Size, Horizontal and Vertical Frequency, available Resolutions ), if you are in doubt please check the manuals of your monitor.
2. Graphic Card: what type of Graphic Card do you have?, you can type the following command to check your graphic card:
# lspci | grep VGA
In case you are using an Nvidia or ATI card you must also activate 3D acceleration. But this matter can be dealt after, first thing is configuring X.
3. Type of keyboard and mouse, be careful in choosing the right device, normally this is done automatically but you can check them just to be sure.
When you have done all this sax2 will try to test the configuration, you'll see a screen with a small window in the center to adjust the size of the screen and also a button to save all your changes. If you have finished this, you can start X safely.

Please note the following, the config file of X is located in /etc/X11/xorg.conf. In this file you can see all the configuration, this file is written by sax2 automatically, so you don't have to modify it manually. Nevertheless if you have an Nvidia or ATI graphic card you must install the propietary drivers of these cards so you can enjoy the full capacity of the card. In the Graphic Device Section of this file you'll see a line with the driver you are using, something like this:
Section "Device"
Identifier "ATI Graphics Adapter"
Driver "fglrx"
this is my case, in case you have an Nvidia card you'll have to see "nv" or "nvidia", or the appropiate one. If you have some problem with the driver you can put:
Driver "vesa"
this driver always works no matter what graphic card you have. Once you have X running you can install the driver of your card.

Finally have you seen some lines with (EE) in the file /var/log/Xorg.0.log? Specially at the end? If so please type them, we can guide you better if we know the exact error.
 
Old 01-28-2006, 08:26 AM   #11
albertog
LQ Newbie
 
Registered: Jan 2005
Location: NO-8672 Elsfjord, Norway
Distribution: Suse 10.0,Oss,32bit; Mepis 6.5, Ubuntu 71.
Posts: 15

Original Poster
Rep: Reputation: 0
Jan.28.

Hi victor,


Here is the EE lines at the end" couldn`t load xkb keymap,falling back to pre -xkb keymap"

Situation worsened here Mouse cursor is`nt working anymore.I cant get into the login consol anymore.

I am inclined to make a new install as the rescue calls for Un and Password.My correct Pw won`t work.

And the regular Suse login is frozen.

My graphic card is an Intel 915G.

Thanks from
 
Old 01-28-2006, 08:56 AM   #12
victorh
Member
 
Registered: Jul 2005
Location: La Paz, Bolivia
Distribution: Debian Sarge - Sid, Slackware, Gentoo, openSuse, Fedora, Ubuntu, Mandriva
Posts: 241

Rep: Reputation: 30
Doing a fresh install in your case can be a good solution. You can use the option to repair your systemn instead of a complete new install.

For the record, it seems that your keyboard is not well configured (and the mouse also), that's the reason why X can't start, somehow when you did the update your system configuration has been changed and the file /etc/X11/xorg.conf has not been updated, in case you want to be adventurous you can try to fix it, you will learn a lot fixing this problem, I think that's all about Linux, learn everyday something new...
 
Old 01-28-2006, 09:42 AM   #13
albertog
LQ Newbie
 
Registered: Jan 2005
Location: NO-8672 Elsfjord, Norway
Distribution: Suse 10.0,Oss,32bit; Mepis 6.5, Ubuntu 71.
Posts: 15

Original Poster
Rep: Reputation: 0
Hello viktorh,

Thanks a lot I will.
Yes its something of the lure of linux you state there.:-)

By the way ,when you use cat, how do you get the output per page?
 
Old 01-28-2006, 09:53 AM   #14
victorh
Member
 
Registered: Jul 2005
Location: La Paz, Bolivia
Distribution: Debian Sarge - Sid, Slackware, Gentoo, openSuse, Fedora, Ubuntu, Mandriva
Posts: 241

Rep: Reputation: 30
You can use the command more, in your case type this in the console:
Quote:
cat /etc/X11/xorg.conf | more
to go to the next page press the space bar.
Or, in case you just use cat, you can go back in the console by pressing shift + PagUp.

Keep trying Al.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE 3.4.1 Login Manager won't enter admin mode rgingels Debian 12 11-09-2005 03:20 PM
No login screen to enter the WM n175uj Linux - General 2 07-02-2005 05:47 AM
Unable to set focus to the user name field in login screen using keyboard alone Lindaramachandr Linux - General 3 12-29-2004 09:43 AM
login field moved near top of "Forums" page Present LQ Suggestions & Feedback 2 12-03-2004 09:39 PM
Login problems, cant enter password pdigga Linux - Newbie 1 04-20-2004 09:10 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 02:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration