LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 02-18-2008, 07:26 PM   #1
linuxbeliever
Member
 
Registered: Oct 2004
Location: USA
Distribution: OPENSUSE 11.1 with KDE 3.5
Posts: 55

Rep: Reputation: 15
Unhappy Can't access my shares folder in XP home and Opensuse 10.2


Hi! everybody

I trying to connect an XP home and Opensuse 10.2, I have done averything as far as the 2 computers see each other connect to a router. But when I click in konqueror to see the share folders in each one I get this:

In XP Home:

Error

//Wildswede is not accessible. You may not have permission to use this network resource. Contact your administrator of this server to find out if you have access permission.

There are currently no logon servers available to service the logon request.

In Opensuse 10.2:

Konqueror

Error: Could not connect to host smb://presario/

I did the yast-samba and yast-samba-authentication in the network services. I haveSmb4K 0.7.5 (Using KDE 3.5.5 release 45.8) Opensuse 10.2, I did the share folder within konqueror by right clicking the folder and select properties.

In the XP home I did my share within My Documents folder and did a right click on the folder and selected properties and click the share tab.

I did go to both firewalls and change (what I could) to allow sharing. Other than that I don't know what to do? Any ideas?
please be specific my knowledge is novice in linux and networking.

Thanks in advance.
 
Old 02-18-2008, 07:35 PM   #2
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680
Are the username and password the same on both machines. You should post the [General] section of smb.conf and the section for the share. Are you using the default "security = user"?

Use the "smbpasswd" program to enter the username & password of the user. This creates an entry in the /etc/samba/smbpasswd file that resembles a classic /etc/passwd file but has windows uid's.

On the Linux box, enter "smbclient -L presario". It will as for the password and then list the services offered by the windows host. On windows you can enter "net view \\wildswede".
 
Old 02-19-2008, 12:16 AM   #3
linuxbeliever
Member
 
Registered: Oct 2004
Location: USA
Distribution: OPENSUSE 11.1 with KDE 3.5
Posts: 55

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by jschiwal View Post
Are the username and password the same on both machines. You should post the [General] section of smb.conf and the section for the share. Are you using the default "security = user"?

Use the "smbpasswd" program to enter the username & password of the user. This creates an entry in the /etc/samba/smbpasswd file that resembles a classic /etc/passwd file but has windows uid's.

On the Linux box, enter "smbclient -L presario". It will as for the password and then list the services offered by the windows host. On windows you can enter "net view \\wildswede".
I do not have a password on the XP Home to log in for the opensuse 10.2 yes I have a user the usual user login. Okay, here is my smb.conf:

# smb.conf is the main Samba configuration file. You find a full commented
# version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
# samba-doc package is installed.
# Date: 2007-12-04
[global]
workgroup = speebidah
printing = cups
printcap name = cups
cups options = raw
map to guest = Bad User
include = /etc/samba/dhcp.conf
logon path = \\%L\profiles\.msprofile
logon home = \\%L\%U\.9xprofile
logon drive = P:
usershare allow guests = No
add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
os level = 65
preferred master = Yes
winbind gid = 10000-20000
winbind uid = 10000-20000
security = domain
domain logons = No
domain master = Auto
idmap gid = 10000-20000
idmap uid = 10000-20000
local master = Yes
usershare max shares = 100

[homes]
comment = Home Directories
valid users = %S, %D%w%S
read only = No
inherit acls = Yes

[profiles]
comment = Network Profiles Service
path = %H
read only = No
store dos attributes = Yes
create mask = 0600
directory mask = 0700

[users]
comment = All users
path = /home/scooter/public_html/netshare102/
inherit acls = yes
veto files = /aquota.user/groups/shares/
guest ok = yes
read only = no
case sensitive = no
strict locking = no
msdfs proxy = no
guest only = yes

[printers]
comment = All Printers
path = /var/tmp/
printable = Yes
create mask = 0600
browseable = No

[drivers]
path = /var/lib/samba/drivers/

[netlogon]
comment = Network Logon Service
path = /var/lib/samba/netlogon/
write list = root
case sensitive = no
strict locking = no
msdfs proxy = no
guest ok = yes

The XP Home is owned by a friend in the same house (he's a retiree and loves to write about politics and religion), help him when $windoze$ computer crashes, he has short memory that's why I didn't set a regurlar user account on the XP Home. Opensuse in the other hand only has a regular user log in, don't remember using smbpasswd command after using the samba tools in yast network services although it ask me for a password for the samba server (so it said so server can work), which i type once I have not typed since again. I feel more better managing things with a gui, can we set that password in yast or smb4k or in the kmenu->Settings->Internet-Network tools so I know where to put it? please!

Executing smbclient -L presario on a konsole on opensuse 10.2 It displays:

wildswede:/home/scooter # smbclient -L presario
Connection to presario failed (Error NT_STATUS_BAD_NETWORK_NAME)
wildswede:/home/scooter #

On the XP Home presario executing net view \\wildswede in a dos command terminal (dos prompt) it displays:

System error 5 has occurred

Access denied

Any Ideas?

Thanks in advance.
 
Old 02-19-2008, 02:22 PM   #4
swampdog2002
Member
 
Registered: Jul 2005
Distribution: Slackware 12.2, 13.0, openSUSE 11.2
Posts: 400

Rep: Reputation: 33
I had a similar issue recently where I was attempting to access a Windows 2000 share from my Linux machines over the LAN. The only way I was able to do this was to enter the IP address of the Windows computer, since it was not resolving the host name of the Windows 2000 computer. Are your LAN IP addresses assigned by DHCP, or are they static? I usually prefer to assign them statically just to keep consistency. Please find out the local IP address of your Windows XP Home computer, and then type the following at the command prompt on the openSuSE 10.2 computer:
Code:
smbclient -L (Windows XP IP address)
If you are asked for a password, or receive another message other than the prior error, then this is most likely the same issue I was facing. If you get a password prompt, you will most likely enter the Administrator password on the Windows XP machine to authenticate yourself. On the openSuSE 10.2 computer, you will have to edit your /etc/hosts file and place an entry for the Windows XP machine in there. Again, this is much easier with staitc IP's rather than DHCP. This way, the addresses do not change, and you do not have to keep editing your /etc/hosts file to reflect the constant changes. Please post back and let us know what happens. Thanks.

Note: I was able to access my Windows 200 share directory in Linux without configuring anything related to Samba.

Last edited by swampdog2002; 02-19-2008 at 02:28 PM.
 
Old 02-19-2008, 03:05 PM   #5
linuxbeliever
Member
 
Registered: Oct 2004
Location: USA
Distribution: OPENSUSE 11.1 with KDE 3.5
Posts: 55

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by swampdog2002 View Post
I had a similar issue recently where I was attempting to access a Windows 2000 share from my Linux machines over the LAN. The only way I was able to do this was to enter the IP address of the Windows computer, since it was not resolving the host name of the Windows 2000 computer. Are your LAN IP addresses assigned by DHCP, or are they static? I usually prefer to assign them statically just to keep consistency. Please find out the local IP address of your Windows XP Home computer, and then type the following at the command prompt on the openSuSE 10.2 computer:
Code:
smbclient -L (Windows XP IP address)
If you are asked for a password, or receive another message other than the prior error, then this is most likely the same issue I was facing. If you get a password prompt, you will most likely enter the Administrator password on the Windows XP machine to authenticate yourself. On the openSuSE 10.2 computer, you will have to edit your /etc/hosts file and place an entry for the Windows XP machine in there. Again, this is much easier with staitc IP's rather than DHCP. This way, the addresses do not change, and you do not have to keep editing your /etc/hosts file to reflect the constant changes. Please post back and let us know what happens. Thanks.

Note: I was able to access my Windows 200 share directory in Linux without configuring anything related to Samba.
Hi! Thanks for the response.

Right now if I remember right the ip address is done by automatic DHCP (in the router, in the XP HOME and in Opensuse 10.2) I like to not touch to much of network addresses if i can because these are two different computers and two different owners, my only idea is to create a small script (like bath files in windows machines) to execute manually (or automatic when i run konqueror->network folders tool or smb4k utility) the command you told me, every time i need to access the XP HOME machine (if its posible include getting the ip address from the XP HOME with it, in other words asking XP HOME to send the ip address first and execute the script (or batch file), as a temporarily user for that network session, can you tell/help me how to write/create it? please!

Thanks in advance.
 
Old 02-19-2008, 03:43 PM   #6
swampdog2002
Member
 
Registered: Jul 2005
Distribution: Slackware 12.2, 13.0, openSUSE 11.2
Posts: 400

Rep: Reputation: 33
Unfortunately, I am not much of a shell script programmer, so I wouldn't really know what assistance to offer to you at this point. Based upon what you want to do, however, I can offer you what you would want this shell script to perform for you:

1. Obtain the IP address of the Windows XP Home machine on your network. I believe that you can poll for IP addresses on your LAN similar to Windows with the arp command. I don't know of the specific parameters to use in conjunction with arp, but you should be able to consult the respective man page for this information.

2. Associate the IP address of the Windows XP Home computer to its name, and then write this information to your /etc/host file.

There may be more that needs to be done, but basically since you are using DHCP, you will not be able to add a static value to your /etc/hosts file, since the IP address will change upon the DHCP lease time you have set. There are many others in this forum that can hopefully offer some more assistance to what you want to do, and possibly offer shell scripting advice, if what I mentioned above is possible at all. First, however, before you do anything else, please verify that you can at least attempt to connect to the Windows XP computer from openSuSE 10.2 by issuing the following in a terminal:
Code:
smbclient -L (Windows XP IP address)
If you still receive the same error, this may be something else, and this information that I described above may not be applicable. Thanks.

Last edited by swampdog2002; 02-19-2008 at 03:46 PM.
 
Old 02-19-2008, 07:37 PM   #7
linuxbeliever
Member
 
Registered: Oct 2004
Location: USA
Distribution: OPENSUSE 11.1 with KDE 3.5
Posts: 55

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by swampdog2002 View Post
Unfortunately, I am not much of a shell script programmer, so I wouldn't really know what assistance to offer to you at this point. Based upon what you want to do, however, I can offer you what you would want this shell script to perform for you:

1. Obtain the IP address of the Windows XP Home machine on your network. I believe that you can poll for IP addresses on your LAN similar to Windows with the arp command. I don't know of the specific parameters to use in conjunction with arp, but you should be able to consult the respective man page for this information.

2. Associate the IP address of the Windows XP Home computer to its name, and then write this information to your /etc/host file.

There may be more that needs to be done, but basically since you are using DHCP, you will not be able to add a static value to your /etc/hosts file, since the IP address will change upon the DHCP lease time you have set. There are many others in this forum that can hopefully offer some more assistance to what you want to do, and possibly offer shell scripting advice, if what I mentioned above is possible at all. First, however, before you do anything else, please verify that you can at least attempt to connect to the Windows XP computer from openSuSE 10.2 by issuing the following in a terminal:
Code:
smbclient -L (Windows XP IP address)
If you still receive the same error, this may be something else, and this information that I described above may not be applicable. Thanks.
Hi again! Thanks for the respose

Yes, you got it right, for my idea. Do you know any web sites that can help me with scripts I'm a novice on linux so but have some experience with creating simple batch files in the last version of windoze old dos system. By the way, I did manage to get the ip address from XP Home I just left click on the conection icon (the two blue screen conected to each other in the right lower corner of the screen (task manager)) and left click on support tab (on the upper left corner of the window), so when i did smbclient -L xxx.xxx.x.xxx (of course i replace the x's with the number of the ip address), NOTE: I did it first as a regular user and the second time as a root with the su command, so here it goes:

scooter@wildswede:~> smbclient -L 192.168.1.101
Password:
Domain=[PRESARIO] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]

Sharename Type Comment
--------- ---- -------
IPC$ IPC Remote IPC
My NetFolder Disk
session request to 192.168.1.101 failed (Called name not present)
session request to 192 failed (Called name not present)
Domain=[PRESARIO] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]

Server Comment
--------- -------

Workgroup Master
--------- -------
scooter@wildswede:~>

scooter@wildswede:~> su
Password:
wildswede:/home/scooter # smbclient -L 192.168.1.101
Password:
Domain=[PRESARIO] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]

Sharename Type Comment
--------- ---- -------
IPC$ IPC Remote IPC
My NetFolder Disk
session request to 192.168.1.101 failed (Called name not present)
session request to 192 failed (Called name not present)
Domain=[PRESARIO] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]

Server Comment
--------- -------

Workgroup Master
--------- -------
wildswede:/home/scooter #

Any ideas?

Thanks in advance.
 
Old 02-20-2008, 07:48 AM   #8
swampdog2002
Member
 
Registered: Jul 2005
Distribution: Slackware 12.2, 13.0, openSUSE 11.2
Posts: 400

Rep: Reputation: 33
For shell scripting, there are many sites for this, which includes this address: http://www.linuxcommand.org/writing_shell_scripts.php. I've written small ones that just contain Linux commands in them, but would not know what to suggest for what you wish to accomplish. Well, from the output of performing the smbclient command, it looks as if my assumptions were correct in that the /etc/hosts file cannot resolve the hostnmane on the LAN. I'm not certain about the output of this:
Code:
session request to 192.168.1.101 failed (Called name not present)
session request to 192 failed (Called name not present)
But now that you have the IP address of the Windows XP machine, see if you can open Konqueror (KDE) or Nautilus (GNOME), assuming that you use either one, and type in the following in the address bar:
Code:
smb://192.168.1.101
If all goes well, you should see the network share of the Windows XP machine in the window. I'm not certain how XP Home does authentication, but I would imagine that it would be similar to Pro, so see if you can access this folder with the username and password of the XP user account (assuming that the folder shows up at all). Let us know the results of this.

As I've mentioned before, it would be much less of a task if you were to assign all LAN computers static IP addresses. This way, you would not have to be concerned with shell scripting to alter the /etc/hosts file and such. Unless all users access another network, I wouldn't think that this would cause any problems for users connected to your LAN. One of the main reasons that I use static addresses for computers on my LAN is that I have found my firewall/router to be somewhat flaky when assigning IP addresses when it is set as a DHCP server. Just my recommendation to you, but you seem adament on keeping your network as is, so hopefully you will be able to come to some sort of resolve for your particular situation.

Last edited by swampdog2002; 02-20-2008 at 07:54 AM.
 
Old 02-20-2008, 07:55 AM   #9
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680
You can't use "security=domain" with XP home. XP home can't join a domain.

Which services do you want this user to access? Does this user have an account on the Linux machine?
Not having a password is absurd unless the only share this user can access is the guest share "/home/scooter/public_html/netshare102/"

With your [Profiles] service, if the user has a home directory on the Linux server, and you used "smbpasswd" to enter the username & password of the user, that users could connect to
\\WildSwede\profile and then enter the username and password. After this first time, while the session is open, he can connect again later and not have to reenter his credentials. Using this service, he won't see a bunch of home directories of the other users. This is the service I use for Linux to Linux when I run samba.

I think that it would be possible to have a password for the samba share even if there isn't one for XP, but I'm not certain. You still need to enter it with "smbpasswd".

It is possible to use other password backends but your smb.conf file doesn't indicate that you are.

Last edited by jschiwal; 02-20-2008 at 08:30 AM.
 
Old 02-20-2008, 01:41 PM   #10
linuxbeliever
Member
 
Registered: Oct 2004
Location: USA
Distribution: OPENSUSE 11.1 with KDE 3.5
Posts: 55

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by jschiwal View Post
You can't use "security=domain" with XP home. XP home can't join a domain.

Which services do you want this user to access? Does this user have an account on the Linux machine?
Not having a password is absurd unless the only share this user can access is the guest share "/home/scooter/public_html/netshare102/"

With your [Profiles] service, if the user has a home directory on the Linux server, and you used "smbpasswd" to enter the username & password of the user, that users could connect to
\\WildSwede\profile and then enter the username and password. After this first time, while the session is open, he can connect again later and not have to reenter his credentials. Using this service, he won't see a bunch of home directories of the other users. This is the service I use for Linux to Linux when I run samba.

I think that it would be possible to have a password for the samba share even if there isn't one for XP, but I'm not certain. You still need to enter it with "smbpasswd".

It is possible to use other password backends but your smb.conf file doesn't indicate that you are.
Hi! thanks for the response.

Okay, can we change it within a gui tool like YAST->Network Services->Samba Server and/or Windows Domain Membership, and/or Kmenu->Personnal Setting->Internet Network (File sharing tool, Local Netowrk Browsing tool, samba or Service Discovery) although I know where the smb.conf is, I feel more comfortable doing configurations in a graphical form? please!

My main idea that I want to do is to only have 1 folder and 1 printer in each computer to share between each other temporarily, because like I said these are 2 different computer 2 different owners (one is a retiree and alderly person with a short memory with passwords and tech stuff) but I'm trying to show that person how to work with windoze and Linux (Opensuse 10.2) and I want to leave the setting as simple and secure as possible, just in case one computer dies or we sell it then it can be use in other network house or by a different owner. Yes, each computer has (I believe) a folder to share with the other computer (XP Home<-->Opensuse 10.2) .

I remember when I was doing the configuration in one of the tools that I used in opensuse 10.2 YAST->Network Services->Samba Server and/or Windows Domain Membership, and/or Kmenu->Personnal Setting->Internet Network (File sharing tool, Local Netowrk Browsing tool, samba or Service Discovery) I do not remember which one ask me at the end to type a password to make sure samba server works okay, which I did (hopefully, I still remember it) so I do not remember using smbpasswd command in opensue 10.2, other than opensuse's 10.2 regular user login when the computer boots up. You seem to have a sort of an idea what I want to do, but like I said it has to be temporarily.access to each one.

So, any ideas?

Thanks in advance.
 
Old 02-20-2008, 09:04 PM   #11
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680
YaST has a Samba Server configuration wizard. I would recommend using Samba Swat however.

To use Swat, first edit the /etc/xinet.d/swat file. Change the line with "disable = yes" to "disable = no".
Then start or restart the xinetd daemon:
sudo /usr/sbin/rcxinetd start
or
sudo /usr/sbin/rcxinetd restart

Now point your web browser to "http://localhost:901" and enter the root username & password.
The swat first page has a wizard to quickly configure the computer with a boilerplate configuration.

Given you just want a single directory for two users to share files on, I would recommend having a global world writable directory being shared.

Example:
Code:
sudo mkdir /srv/samba
sudo chmod a=trwx /srv/samba
This will produce a directory with the same permissions as /tmp. All users can write to it, but the sticky bit protects one user from having a file deleted by another user. Each user can change the permissions on a file they save, which can make the file readable by only themselves. Your two users may not be that sophisticated, and not care. They are probably saving files on the server to share with the other user anyway.

Using swat you can click on the [Shares] icon at the top, and then enter a name in the "create share" line. Using the name of the server for the share might be a good idea. It communicates where the share is located physically.
Enter "/srv/samba" in the path line. Select "yes" for "guest OK"; "No" for "Read-Only" ;"Yes" for Browsable; and "Yes" for Available. Enter a comment so your elderly user will understand that this is a place to share files.
Then click on the "Commit Changes" button.

Samba needs to be restarted. Click on the "Status" icon and use the buttons to restart the services.
This will create a service that will look like this in smb.conf:
Code:
[wildswede]
        comment = File Sharing on WildSwede
        path = /srv/samba
        read only = No
        guest ok = Yes
This is about as simple as a service can be defined. You might want to remove the [Profile] and [Homes] services. The users don't have their own home directories on this server, so for your usage they wouldn't be needed.

Last edited by jschiwal; 02-20-2008 at 10:39 PM.
 
Old 02-20-2008, 09:13 PM   #12
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680
I forgot to mention to make sure that all computers use the same workgroup. I'm sure you are aware of this. It's true in windows also. This is the "workgoup =" line in smb.conf and properties for the computer in Windows.
 
Old 02-21-2008, 01:28 PM   #13
linuxbeliever
Member
 
Registered: Oct 2004
Location: USA
Distribution: OPENSUSE 11.1 with KDE 3.5
Posts: 55

Original Poster
Rep: Reputation: 15
Thanks jschiwal for the response.

Okay, You said in the last post "Given you just want a single directory for two users to share files on" in my last post I thought, I describe my setup as having 1 folder in each computer and the printer attached in each of the computer to share between each other, in other words I want to be able to send files from Opensuse 10.2 from my netshare folder to the My NetFolder in the XP Home (presario) or the printer connected to it or send a file from XP Home (presario) to the netshare folder in opensuse 10.2 or the printer connected to it, but like I said has to be temporarily only for that network session. Okay, I can try with swat although i want to do it with samba tools that opensuse 10.2 has (I kind of remember seeing some of those settings/commands in yast network services and kde->personal settings->internet & network tools), so I get used to the tools that opensuse 10.2 has. Just to be clear I do not connect or have a physical server (although I know that my simple router acts like a mini server (but it's not) and the two computers run a copy of server like service within each other. So, if you can walk me thru the setup with opensuse 10.2 tools (I mean all, because i used every one of the tools that i saw in suse related to networking and samba, which are (yast network services and kde->personal settings->internet & network tools)) please.

Thanks in advance.
 
Old 02-22-2008, 03:52 AM   #14
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680
You mentioned another user who was old and not very tech savy. I thought you wanted a simple and easy share setup so both of you can store and share files and that there was 2 XPs and 1 Linux Samba server. You could still setup the share I had described in the previous post.

For exchanging personal files between a Linux and XP machine, using the "security = user" mode and the [Profile] share would probably be the most userful. This wouldn't be a public share like I included in my prior post. You would want to use the same username and password and then in Linux run the "smbpasswd" program to set the password. After entering the password for to setup the initial connection, you wouldn't need to enter it again because your credentials match.

Here is the standard profile service config:
Code:
[profiles]
        comment = Network Profiles Service
        path = %H
        read only = No
        create mask = 0600
        directory mask = 0700
        store dos attributes = Yes
The "%H" in path is substituted with the users home directory on the Linux Machine.
So when connecting from XP, select your Workgroup, and then the Computer, and then Profiles. If you had several users, this would also make things neat because the other user would also see the Profile service, but when they would open it, they would get to there own home directory.

The SuSE samba server configuration is in
Applications -> System -> Administrative Settings (YaST)
Click on the Network Services Settings on the left hand pane. Click on the Samba Server icon on the right.
You can enable "printers" from there. On the bottom is Profiles. Below this section, you can click on "Allow users to share their directories". This will allow you to right click on a directory and opt to share it.

Last edited by jschiwal; 02-22-2008 at 09:13 PM. Reason: typo fix
 
Old 02-24-2008, 02:13 PM   #15
linuxbeliever
Member
 
Registered: Oct 2004
Location: USA
Distribution: OPENSUSE 11.1 with KDE 3.5
Posts: 55

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by jschiwal View Post
You mentioned another user who was old and not very tech savy. I thought you wanted a simple and easy share setup so both of you can store and share files and that there was 2 XPs and 1 Linux Samba server. You could still setup the share I had described in the previous post.

For exchanging personal files between a Linux and XP machine, using the "security = user" mode and the [Profile] share would probably be the most userful. This wouldn't be a public share like I included in my prior post. You would want to use the same username and password and then in Linux run the "smbpasswd" program to set the password. After entering the password for to setup the initial connection, you wouldn't need to enter it again because your credentials match.

Here is the standard profile service config:
Code:
[profiles]
        comment = Network Profiles Service
        path = %H
        read only = No
        create mask = 0600
        directory mask = 0700
        store dos attributes = Yes
The "%H" in path is substituted with the users home directory on the Linux Machine.
So when connecting from XP, select your Workgroup, and then the Computer, and then Profiles. If you had several users, this would also make things neat because the other user would also see the Profile service, but when they would open it, they would get to there own home directory.

The SuSE samba server configuration is in
Applications -> System -> Administrative Settings (YaST)
Click on the Network Services Settings on the left hand pane. Click on the Samba Server icon on the right.
You can enable "printers" from there. On the bottom is Profiles. Below this section, you can click on "Allow users to share their directories". This will allow you to right click on a directory and opt to share it.
Hi! Thanks jschiwal for the response.

Okay, so far what I done this.

Change about 4 settings from the original smb.conf post, following your instructions:

I change:

in [global]

security=user

There is a line that says "usershare allow guests=no", which I think supposed say "usershare allow guests=yes", right? is it safe to change it? so XP Home can log in to opensuse 10.2, (I can see it too from yast->network services->samba server and clicking identity tab, and then clicking advance settings drop menu and selecting expert global settings)

Also, there is a share call netlogon service within yast->network services->samba server, that keeps getting disable even if I change it to enable and click finish in the configuration window, why? any ideas?

I did your smbpasswd command as a regular user, and the results where:

scooter@wildswede:~> smbpasswd
Old SMB password:
New SMB password:
Retype new SMB password:
cli_pipe_validate_current_pdu: RPC fault code DCERPC_FAULT_OP_RNG_ERROR received from remote machine 127.0.0.1 pipe \samr fnum 0x7522!
machine 127.0.0.1 rejected the password change: Error was : NT code 0x1c010002.
Failed to change password for scooter
scooter@wildswede:~>

Yes, the profile that you show me matches with mine. I doube check it, just in case.

I change the workgroup to UPPERCASE because I read in somewhere else that bill windoze only sees workgroups in UPPERCASE only (I did it in the router, opensuse 10.2 and in XP Home)

Yes, you almost getting my idea of sharing files between opensuse 10.2 and XP Home. I have netshare102 in opensuse 10.2 folder already configure as a permanent (all the time, take in count that both computers are not on all the time, only when we are working on them) share in opensuse 10.2 with XP Home and My Netfolder in XP Home as a permanent share with opensuse 10.2 and of course the printers conncted to them (we never know with windows inner workings!).

As in right now, without changing "usershare allow guests=no" because i do not know if it is safe (until I get a reply about it) the share folders are still not accessible in both computers (although home and netlogon folders (opensuse 10.2) display a login screen when I click them in XP Home which I did try my regular user and pasword the first time and my samba password the second time without success. Here is my new smb.conf file:

# smb.conf is the main Samba configuration file. You find a full commented
# version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
# samba-doc package is installed.
# Date: 2007-12-04
[global]
workgroup = SPEEBIDAH
printing = cups
printcap name = cups
cups options = raw
map to guest = Bad User
include = /etc/samba/dhcp.conf
logon path = \\%L\profiles\.msprofile
logon home = \\%L\%U\.9xprofile
logon drive = P:
usershare allow guests = No
add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
winbind gid = 10000-20000
winbind uid = 10000-20000
security = user
domain logons = No
domain master = No
idmap gid = 10000-20000
idmap uid = 10000-20000
usershare max shares = 100

[homes]
comment = Home Directories
valid users = %S, %D%w%S
read only = No
inherit acls = Yes

[profiles]
comment = Network Profiles Service
path = %H
read only = No
store dos attributes = Yes
create mask = 0600
directory mask = 0700

[users]
comment = All users
path = /home/scooter/public_html/netshare102/
inherit acls = yes
veto files = /aquota.user/groups/shares/
guest ok = yes
read only = no
case sensitive = no
strict locking = no
msdfs proxy = no
guest only = yes

[printers]
comment = All Printers
path = /var/tmp/
printable = Yes
create mask = 0600
browseable = No

[drivers]
path = /var/lib/samba/drivers/

[netlogon]
comment = Network Logon Service
path = /var/lib/samba/netlogon/
write list = root
case sensitive = no
strict locking = no
msdfs proxy = no
guest ok = yes

Any ideas?

Thanks in advance.
 
  


Reply

Tags
network, shares, xp


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
WinXP home client sees Linux Samba server but no access to shares IslanderTexas Linux - Software 27 02-22-2006 04:54 PM
Folder Max Size and Limiting SSH access to home folder. Mefistofeles Linux - General 4 11-26-2005 02:09 PM
Chmod = no access to home folder! DeathPrawn Linux - Newbie 4 02-12-2005 11:50 AM
shares not in home folder rmdnet Linux - Networking 8 11-28-2004 01:02 PM
FTP access to home folder deWin Linux - Networking 5 04-26-2004 01:45 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 06:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration